summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-08-11 12:46:35 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-08-11 12:46:35 -0500
commitdce6f6c9c2acc5758a43fbf5c0866d8a265c777a (patch)
tree8bf5e410d3015f4ed6f4ecdbc92fccba194f64c6
parentdev-libs/leatherman: bup (diff)
downloadgentoo-dce6f6c9c2acc5758a43fbf5c0866d8a265c777a.tar.gz
gentoo-dce6f6c9c2acc5758a43fbf5c0866d8a265c777a.tar.bz2
gentoo-dce6f6c9c2acc5758a43fbf5c0866d8a265c777a.zip
app-admin/mcollective: bup
Package-Manager: portage-2.2.28
-rw-r--r--app-admin/mcollective/Manifest1
-rw-r--r--app-admin/mcollective/mcollective-2.9.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-admin/mcollective/Manifest b/app-admin/mcollective/Manifest
index 32c721499ede..0b771c40b61e 100644
--- a/app-admin/mcollective/Manifest
+++ b/app-admin/mcollective/Manifest
@@ -1,2 +1,3 @@
DIST mcollective-2.8.0.tar.gz 718292 SHA256 47084f9285707f2e457850adcf90811f3d39d4f4baa950d822b20b45633db259 SHA512 edc3da334dbd3afd18fcedc675c6498edce1c799d9b472f70ebfe1b972e013cba5217ec492ea4128b15d886edaf283246ba70915180f9a10a67f7c0957fd1c8e WHIRLPOOL 0c6461a43c4533334dee420e7a0debfa8aa2e0079b83407c1313a28689b5ecbd891c94740553947bdce4023786eb0e95e497da73108e283619f358d67dac7c0c
DIST mcollective-2.8.8.tar.gz 1500476 SHA256 503b26cb0beeb505bf9cd2abbb8724c67bc743ffff4fbaddc321e2a4d663b133 SHA512 fad2a277bdcb06adb56e87f545c4b85a4b8039263e7230c7b386c561a04d6f3bf80923733e1087c8090b43da734d6b7efe02e52a757191c3cb3ecab50cc97bb6 WHIRLPOOL 3e7a52b1ce3b705ed6f705067a4ab900a2faa226d19a36f106e2c2c1e4c4fc3e631630c04012ca456f0230f8fcb47dd5bd97f1d2e849af6edde67fac129301d4
+DIST mcollective-2.9.0.tar.gz 1503682 SHA256 93c97ee026986f8e966125551d7e481bd539a98f9f2f2ea94c98c024963ae331 SHA512 7d7dec7e68840bf9aea2890645f5d86389c6be8f84ad330b6ae342edf03d88cdef9f225aef741245a0f9606a46fe9394b9f740b4bf987c6f21ad018c05d84660 WHIRLPOOL 336673cdd5cfba14154435810fdbe3449646df8a85d057fc6a8bfe6d1f1d5fa5b3c4f9d9f470f0fd88d4170cbc1d6af646cfd959661720992dcffb08491657d1
diff --git a/app-admin/mcollective/mcollective-2.9.0.ebuild b/app-admin/mcollective/mcollective-2.9.0.ebuild
new file mode 100644
index 000000000000..9fc033322655
--- /dev/null
+++ b/app-admin/mcollective/mcollective-2.9.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+inherit ruby-ng
+
+DESCRIPTION="Framework to build server orchestration or parallel job execution
+systems"
+HOMEPAGE="http://marionette-collective.org/"
+SRC_URI="https://github.com/puppetlabs/marionette-collective/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/all/marionette-collective-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +client"
+
+DEPEND=""
+RDEPEND="dev-ruby/stomp"
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+each_ruby_install() {
+ cd "marionette-collective-${PV}"
+ doruby -r lib/*
+ insinto /usr/share/mcollective
+ use client && dosbin bin/mco
+ dosbin bin/mcollectived
+ if use doc ; then
+ dohtml -r doc/*
+ insinto /usr/share/doc/${P}/ext
+ doins -r ext/*
+ fi
+ newinitd "${FILESDIR}"/mcollectived.initd mcollectived
+ insinto /etc/mcollective
+ cd etc
+ for cfg in *.dist ; do
+ newins "${cfg}" "${cfg%%.dist}"
+ sed -i -e "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
+ "${D}"/etc/mcollective/${cfg%%.dist} || die "sed failed"
+ done
+ insinto /etc/mcollective/plugin.d
+}
+
+pkg_postinst() {
+ einfo "Mcollective requires a stomp server installed and functioning before"
+ einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
+ einfo "any other stomp compatible server should work."
+ einfo
+ einfo "It is recommended you read the \'getting started\' guide [2] if this"
+ einfo "is a new installation"
+ einfo
+ einfo "[1] http://activemq.apache.org/"
+ einfo "[2] https://code.google.com/p/mcollective/wiki/GettingStarted"
+}