summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-11-14 16:04:07 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-14 16:04:07 +0100
commitfe4887ef3f0503046a85748b30a4fe0c1f6e58ce (patch)
tree1f4c9fd15b0480c39978c54ce474606636feb82e /app-arch/tarsync
parentapp-arch/mscompress: Port to EAPI 7 (diff)
downloadgentoo-fe4887ef3f0503046a85748b30a4fe0c1f6e58ce.tar.gz
gentoo-fe4887ef3f0503046a85748b30a4fe0c1f6e58ce.tar.bz2
gentoo-fe4887ef3f0503046a85748b30a4fe0c1f6e58ce.zip
app-arch/tarsync: Port to EAPI 7
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-arch/tarsync')
-rw-r--r--app-arch/tarsync/files/tarsync-0.2.1-make.patch8
-rw-r--r--app-arch/tarsync/tarsync-0.2.1-r1.ebuild24
2 files changed, 16 insertions, 16 deletions
diff --git a/app-arch/tarsync/files/tarsync-0.2.1-make.patch b/app-arch/tarsync/files/tarsync-0.2.1-make.patch
index 72591115a45a..4f3d062f3619 100644
--- a/app-arch/tarsync/files/tarsync-0.2.1-make.patch
+++ b/app-arch/tarsync/files/tarsync-0.2.1-make.patch
@@ -1,13 +1,13 @@
-Respect CC and LDFLAGS.
+Respect CC, CPPFLAGS and LDFLAGS.
---- Makefile
-+++ Makefile
+--- a/Makefile
++++ b/Makefile
@@ -2,7 +2,7 @@
CC=gcc
endif
tarsync: main.o names.o tar.o string-misc.o fs.o options.o excludes.o
- gcc $(CFLAGS) $^ -o tarsync -lcfile
-+ $(CC) $(CFLAGS) $(LDFLAGS) $^ -o tarsync -lcfile
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $^ -o tarsync -lcfile
all: tarsync
clean:
diff --git a/app-arch/tarsync/tarsync-0.2.1-r1.ebuild b/app-arch/tarsync/tarsync-0.2.1-r1.ebuild
index c9db986bc6c6..f2048606800d 100644
--- a/app-arch/tarsync/tarsync-0.2.1-r1.ebuild
+++ b/app-arch/tarsync/tarsync-0.2.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Delta compression suite for using/generating binary patches"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
@@ -12,22 +12,22 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~hppa ppc x86 ~amd64-linux"
-IUSE=""
DEPEND=">=dev-util/diffball-0.7"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
-pkg_setup() {
- tc-export CC
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-make.patch
+ "${FILESDIR}"/${P}-gcc5.patch
+)
-src_prepare() {
- epatch "${FILESDIR}"/${P}-make.patch
- epatch "${FILESDIR}"/${P}-gcc5.patch
+src_configure() {
+ tc-export CC
}
src_install() {
- dobin "${PN}" #make install doesn't support prefix
+ dobin tarsync #make install doesn't support prefix
+ einstalldocs
}