summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-12-23 09:11:21 +0100
committerFabian Groffen <grobian@gentoo.org>2020-12-23 09:12:14 +0100
commitfa9750b4c24e402475d4edaa1b2ef34f17d945c3 (patch)
tree4600180d19a60cf4465c50ae1c9d241af7a460eb /app-arch
parentxfce-base/xfce4-meta: Bump to 4.16 (diff)
downloadgentoo-fa9750b4c24e402475d4edaa1b2ef34f17d945c3.tar.gz
gentoo-fa9750b4c24e402475d4edaa1b2ef34f17d945c3.tar.bz2
gentoo-fa9750b4c24e402475d4edaa1b2ef34f17d945c3.zip
app-arch/tar: add patch for macOS Big Sur 11.1
Bug: https://bugs.gentoo.org/761322 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/tar/files/tar-1.32-check-sys-ioctl-header-configure.patch53
-rw-r--r--app-arch/tar/tar-1.32.90.ebuild4
-rw-r--r--app-arch/tar/tar-1.32.ebuild3
3 files changed, 60 insertions, 0 deletions
diff --git a/app-arch/tar/files/tar-1.32-check-sys-ioctl-header-configure.patch b/app-arch/tar/files/tar-1.32-check-sys-ioctl-header-configure.patch
new file mode 100644
index 000000000000..c8aee2fcce89
--- /dev/null
+++ b/app-arch/tar/files/tar-1.32-check-sys-ioctl-header-configure.patch
@@ -0,0 +1,53 @@
+[buildsys] macOS Big Sur 11.1 doesn't have sys/ioctl.h
+
+Author: Alexei Colin
+Bug: https://bugs.gentoo.org/761322
+Bug: https://savannah.gnu.org/bugs/index.php?59755
+
+--- a/configure 2020-12-23 00:49:19.000000000 -0500
++++ b/configure 2020-12-23 00:49:52.000000000 -0500
+@@ -3422,6 +3422,7 @@
+ as_fn_append ac_header_list " sys/device.h"
+ as_fn_append ac_header_list " sys/gentape.h"
+ as_fn_append ac_header_list " sys/inet.h"
++as_fn_append ac_header_list " sys/ioctl.h"
+ as_fn_append ac_header_list " sys/io/trioctl.h"
+ as_fn_append ac_header_list " sys/mtio.h"
+ as_fn_append ac_header_list " sys/time.h"
+--- a/config.h.in 2019-02-23 07:56:20.000000000 -0500
++++ b/config.h.in 2020-12-23 01:04:49.000000000 -0500
+@@ -1480,6 +1480,9 @@
+ /* Define to 1 if you have the <sys/inttypes.h> header file. */
+ #undef HAVE_SYS_INTTYPES_H
+
++/* Define to 1 if you have the <sys/ioctl.h> header file. */
++#undef HAVE_SYS_IOCTL_H
++
+ /* Define to 1 if you have the <sys/io/trioctl.h> header file. */
+ #undef HAVE_SYS_IO_TRIOCTL_H
+
+--- a/lib/system-ioctl.h 2020-12-22 20:57:00.000000000 -0500
++++ b/lib/system-ioctl.h 2020-12-22 20:57:35.000000000 -0500
+@@ -41,8 +41,10 @@
+ # endif
+ # include <sys/tape.h>
+ # else
+-# if HAVE_SYS_MTIO_H
++# if HAVE_SYS_IOCTL_H
+ # include <sys/ioctl.h>
++# endif
++# if HAVE_SYS_MTIO_H
+ # if HAVE_SGTTY_H
+ # include <sgtty.h>
+ # endif
+--- a/src/checkpoint.c 2020-12-22 20:56:48.000000000 -0500
++++ b/src/checkpoint.c 2020-12-22 20:58:29.000000000 -0500
+@@ -20,7 +20,7 @@
+ #include <system.h>
+ #include "common.h"
+ #include "wordsplit.h"
+-#include <sys/ioctl.h>
++#include <system-ioctl.h>
+ #include <termios.h>
+ #include "fprintftime.h"
+ #include <signal.h>
diff --git a/app-arch/tar/tar-1.32.90.ebuild b/app-arch/tar/tar-1.32.90.ebuild
index 87f3d927f1c8..43686c3c26d9 100644
--- a/app-arch/tar/tar-1.32.90.ebuild
+++ b/app-arch/tar/tar-1.32.90.ebuild
@@ -25,6 +25,10 @@ DEPEND="${RDEPEND}
xattr? ( elibc_glibc? ( sys-apps/attr ) )"
BDEPEND="nls? ( sys-devel/gettext )"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.32-check-sys-ioctl-header-configure.patch
+)
+
src_prepare() {
default
diff --git a/app-arch/tar/tar-1.32.ebuild b/app-arch/tar/tar-1.32.ebuild
index 81267f7aa858..d1fd78649195 100644
--- a/app-arch/tar/tar-1.32.ebuild
+++ b/app-arch/tar/tar-1.32.ebuild
@@ -33,6 +33,9 @@ src_prepare() {
scripts/{backup,dump-remind,restore}.in \
|| die "sed non-GNU"
fi
+
+ [[ ${CHOST} == *darwin20* ]] && \
+ eapply "${FILESDIR}"/${PN}-1.32-check-sys-ioctl-header-configure.patch
}
src_configure() {