summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-benchmarks/volanomark
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-benchmarks/volanomark')
-rw-r--r--app-benchmarks/volanomark/Manifest1
-rw-r--r--app-benchmarks/volanomark/metadata.xml9
-rw-r--r--app-benchmarks/volanomark/volanomark-2.5.0.9.ebuild65
3 files changed, 75 insertions, 0 deletions
diff --git a/app-benchmarks/volanomark/Manifest b/app-benchmarks/volanomark/Manifest
new file mode 100644
index 000000000000..0af9eeaa307a
--- /dev/null
+++ b/app-benchmarks/volanomark/Manifest
@@ -0,0 +1 @@
+DIST vmark2_5_0_9.class 1591590 SHA256 55ae31452e771caded4af1bb45a2e01b710a3c3b02eea372db0d6d535591a7b4 SHA512 002953f780bfb2fa0f9663f6ee2228abbf277e98ebdc69dce3c0e9f03147e0bdb80ae381daf29838790c13aefc83406b61428871a890dcae2396a5c59fcee8bf WHIRLPOOL 00e8ffe4bae635bc72eeaac02e57ca3bfc39db416bf08251d1039dafa7e39d2f8858bd0f64f90a2623b739f84f9996efd7131a6f475df837c28dc236501b3810
diff --git a/app-benchmarks/volanomark/metadata.xml b/app-benchmarks/volanomark/metadata.xml
new file mode 100644
index 000000000000..c9b7d13fbb4f
--- /dev/null
+++ b/app-benchmarks/volanomark/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+<longdescription>Java Benchmark test</longdescription>
+</pkgmetadata>
+
diff --git a/app-benchmarks/volanomark/volanomark-2.5.0.9.ebuild b/app-benchmarks/volanomark/volanomark-2.5.0.9.ebuild
new file mode 100644
index 000000000000..59aab313cd09
--- /dev/null
+++ b/app-benchmarks/volanomark/volanomark-2.5.0.9.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Java server benchmark utility"
+HOMEPAGE="http://www.volano.com/benchmarks.html"
+SRC_URI="http://www.volano.com/pub/vmark2_5_0_9.class"
+LICENSE="Volano"
+
+# Below because of licensing.
+RESTRICT="mirror"
+
+SLOT="0"
+
+KEYWORDS="x86 amd64"
+IUSE=""
+DEPEND="virtual/jre
+ >=sys-apps/sed-4
+ sys-apps/net-tools"
+
+RDEPEND="virtual/jre"
+
+src_unpack() {
+ einfo "No unpack required"
+}
+
+src_install() {
+ dodir /opt/${PN}
+ java -classpath "${DISTDIR}" vmark2_5_0_9 -o "${D}"/opt/${PN}
+ chmod 755 "${D}"/opt/${PN}/*.sh
+ sed -i -e "s#^host=.*#cd /opt/${PN}\nhost=`hostname`#" \
+ -e 's:"$java":java:g' \
+ -e 's:! -f: -z :' \
+ -e 's:-Sn:-n:' \
+ "${D}"/opt/${PN}/startup.sh
+
+ sed -i -e "s#^./startup.sh#/opt/${PN}/startup.sh#g" "${D}"/opt/${PN}/*.sh
+
+ # Set stack-size correctly for different arches
+ if [ "${ARCH}" == "amd64" ] ; then
+ sed -i -e 's:Xss96:Xss512:' "${D}"/opt/${PN}/startup.sh
+ else
+ sed -i -e 's:Xss96:Xss128:' "${D}"/opt/${PN}/startup.sh
+ fi
+
+ keepdir /opt/${PN}/logs
+}
+
+pkg_postinst() {
+
+ ewarn "The vendor provided installation script is somewhat broken!"
+ elog
+ elog "startup.sh was patched to allow the use of the current JVM as"
+ elog "selected by java-config. This means that regardless of the"
+ elog "Java vendor you specify to ${PN}, it will STILL use the default"
+ elog "JVM configured via java-config"
+ elog
+ elog "Just make sure that when you run ${PN}, the Java vendor you specify"
+ elog "matches up with what java-config is configured for. Otherwise specific"
+ elog "vendor specific options runtime may not work."
+ elog
+ elog "Remember to check the host property in startup.sh to the host that is"
+ elog "running the server"
+
+}