summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2019-10-11 14:12:24 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2019-10-11 16:50:06 -0400
commitf9f29b92305e671573b2bc81acb61706dcb97a7c (patch)
treeb405a91b9ab1805fcbf88d93c0178792f8c93121 /app-crypt/yubikey-manager
parentsys-apps/portage: arm64 stable (diff)
downloadgentoo-f9f29b92305e671573b2bc81acb61706dcb97a7c.tar.gz
gentoo-f9f29b92305e671573b2bc81acb61706dcb97a7c.tar.bz2
gentoo-f9f29b92305e671573b2bc81acb61706dcb97a7c.zip
app-crypt/yubikey-manager: bump to 3.1.0
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'app-crypt/yubikey-manager')
-rw-r--r--app-crypt/yubikey-manager/Manifest1
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-3.1.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager/Manifest b/app-crypt/yubikey-manager/Manifest
index 882365d1aaf3..2d517fd30698 100644
--- a/app-crypt/yubikey-manager/Manifest
+++ b/app-crypt/yubikey-manager/Manifest
@@ -1,3 +1,4 @@
DIST yubikey-manager-2.0.0.tar.gz 102078 BLAKE2B a2b8f90dabefb1014881cbe709222bf5cb48c9f409b415a8a2b27d7101c2da6189d0ebfe21a2701d10798c48c44e546659f9424ba6bf9257f7311abb0fc90b9b SHA512 42bebb88ba78bcce00a228109d0b4c815b3242ddbe43fd26c1209ba8666eb033ab77d5acd39a157e8310ce327de8d38bf88cfa0ffaed6273236b220c39e72e3b
DIST yubikey-manager-2.1.1.tar.gz 101672 BLAKE2B baafce3850c0cbed842508c93ec4ad71e0eebbd0dcc61833b245b6c62f74b7215519cb8b1ec82df3be8c7677ec24447193a0121e0a63e67615453c2c6032fc0a SHA512 2c5990d9421acf93113347e9b9d33af893765ae9c5d9e6c9c4f2db1274b84cd839c15ae74327bdcbe9ec32ebdbcbed95b172b8b13ac00bbeb17eb06b6dd71ccd
DIST yubikey-manager-3.0.0.tar.gz 138225 BLAKE2B 8506f7cc4d6579c1905d565d5d32a7e745389000ff67786e5b5e6bc54793230321e5f0f4840c625cae0a4d9d2893b75910bebb3207cfc75189d3a4876838a712 SHA512 47ae785356c256f31e118f2df483d3a0d7fb7b5b380fd7cd207334daaa47319855bde41931099f9acb6b310d4ba824540ab5d3008384fd4d6a373da7355b18eb
+DIST yubikey-manager-3.1.0.tar.gz 115010 BLAKE2B 1b27b9af7f3adac87a1bca58929bffef2ae397b359f70580a07193d2bd2f8cd4d2d867053f6494f1e262668443388d79dfe3775f2c3d0a5528840df8826cdf91 SHA512 518eedb52cfcf725c13114c433f848b97f711e94fa9c71685916fb8cb20e5bfc431f648b0ec710ef9ebed2bc8ddd8722ca1c9865d7a1b29537b719e167ed5f60
diff --git a/app-crypt/yubikey-manager/yubikey-manager-3.1.0.ebuild b/app-crypt/yubikey-manager/yubikey-manager-3.1.0.ebuild
new file mode 100644
index 000000000000..cf74d5ba3a68
--- /dev/null
+++ b/app-crypt/yubikey-manager/yubikey-manager-3.1.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{5,6}} )
+inherit readme.gentoo-r1 distutils-r1
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+# Per https://github.com/Yubico/yubikey-manager/issues/217, Yubico is
+# the official source for tarballs, not Github
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+ >=dev-python/fido2-0.7.0[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=sys-auth/ykpers-1.19.0
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2_7')
+ )
+"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOC_CONTENTS
+
+ distutils-r1_python_install_all
+
+ DOC_CONTENTS="
+ The 'openpgp' command may require the package 'app-crypt/ccid'
+ to be installed on the system. Furthermore, make sure that pcscd
+ daemon is running and has correct access permissions to USB
+ devices.
+ "
+ readme.gentoo_create_doc
+
+ doman "${S}"/man/ykman.1
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}