summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-07-12 14:18:06 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-07-12 14:35:30 +0200
commit9135c39fba064553d15884e108ddfd504485ff89 (patch)
treec43aed3ab1ffb910c380748d5591ac0693068be7 /app-emacs/compat
parentapp-containers/devcontainer: bump to 0.66.0 (diff)
downloadgentoo-9135c39fba064553d15884e108ddfd504485ff89.tar.gz
gentoo-9135c39fba064553d15884e108ddfd504485ff89.tar.bz2
gentoo-9135c39fba064553d15884e108ddfd504485ff89.zip
app-emacs/compat: bump to 30.0.0.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/compat')
-rw-r--r--app-emacs/compat/Manifest1
-rw-r--r--app-emacs/compat/compat-30.0.0.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-emacs/compat/Manifest b/app-emacs/compat/Manifest
index 6e0e36dbf0f1..a84805aac48a 100644
--- a/app-emacs/compat/Manifest
+++ b/app-emacs/compat/Manifest
@@ -1 +1,2 @@
DIST compat-29.1.4.5.tar.gz 130079 BLAKE2B 84b3293bec535d7f653d0aa3fac069e230c030ccf809d0a606b068d9d663e078274d15d57ca56fc180208de69ae4fee554fbc3d5e8c78394789ee756665e980f SHA512 9682224a1ab5238c7f584121652c55df257fd050279e8356632b2aafef4045dc89b2dfd20cf8f5030dda1d96db40c993cdc3ac0efd0263d23beee8310def0849
+DIST compat-30.0.0.0.tar.gz 140329 BLAKE2B 7de4dffc518e521d0c15d3deb0f544972eb6660e19e3028f956b39b9ce355901f3d39339d9f2060a3b7754d67ec9ce92a720cc83afc468f3a2cedc189d8eb922 SHA512 04e2c26f6c1fbb78fc0f2de70913694b3f37614a6992b2a36cec5288c2083481701bdfb7d7e981582c8b22cf61b71e5a3e6011f86c1602331a26ad61c1fe2f66
diff --git a/app-emacs/compat/compat-30.0.0.0.ebuild b/app-emacs/compat/compat-30.0.0.0.ebuild
new file mode 100644
index 000000000000..0de9f6e50e90
--- /dev/null
+++ b/app-emacs/compat/compat-30.0.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Compatibility libraries for Emacs"
+HOMEPAGE="https://github.com/emacs-compat/compat/
+ https://git.sr.ht/~pkal/compat/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/emacs-compat/${PN}.git"
+else
+ SRC_URI="https://github.com/emacs-compat/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="
+ sys-apps/texinfo
+"
+
+ELISP_TEXINFO="${PN}.texi"
+
+src_compile() {
+ emake compile "${PN}.info"
+}
+
+src_test() {
+ local has_json="$("${EMACS}" ${EMACSFLAGS} --eval "(princ (fboundp 'json-parse-string))")"
+ if [[ "${has_json}" != t ]] ; then
+ local line
+ while read line ; do
+ ewarn "${line}"
+ done <<-EOF
+ Your current Emacs version does not support native JSON parsing,
+ which is required for running tests of ${CATEGORY}/${PN}.
+ Emerge >=app-editors/emacs-27 with USE="json" and use "eselect emacs"
+ to select that version.
+ EOF
+ else
+ emake test
+ fi
+}