summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/mew
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/mew')
-rw-r--r--app-emacs/mew/Manifest2
-rw-r--r--app-emacs/mew/files/50mew-gentoo.el7
-rw-r--r--app-emacs/mew/metadata.xml5
-rw-r--r--app-emacs/mew/mew-6.5.ebuild48
-rw-r--r--app-emacs/mew/mew-6.6.ebuild46
5 files changed, 108 insertions, 0 deletions
diff --git a/app-emacs/mew/Manifest b/app-emacs/mew/Manifest
new file mode 100644
index 000000000000..6dcc2f4ee18c
--- /dev/null
+++ b/app-emacs/mew/Manifest
@@ -0,0 +1,2 @@
+DIST mew-6.5.tar.gz 1026322 SHA256 f198b35c2a4cc1c082aaad8f6ccede80ed93d559aed0f66ee2c00c05f8394128 SHA512 481c55915e57889e7b8c6d27c3d21802b624a886eb8f6541c2997db4d5328e16c3b5a8c9a9ce09637b1779b8c52af86a8662ee30dfbab0a411a586d4679ac69e WHIRLPOOL 218fc42969fa4581c9fb43a9a1c65c67d83faf3ebced8ccd1e95c9b43a542753623cfebd14e042e2a21c29b8eca7bee930b306b9919fca6d249901def54bd5b5
+DIST mew-6.6.tar.gz 989941 SHA256 20c879d8488620ac77144c3259fd19cebae0b63404856e426a7e8895d2f9c1e4 SHA512 55a91faaba09a28dfe7da33d34a8c3638540db71a3572ce01646976fbdd0ac3e327475ccc2908876ee6f516c6ee60082a27413b210c4591ef12cc4f878a07472 WHIRLPOOL f07a626bfa32cc9885352eca83769c343ebe539ee6e23863018e04316e14b8c2e209c09b274af7937e3023d604698720df5ae6b57e363f0d09cbeca9246ccf3c
diff --git a/app-emacs/mew/files/50mew-gentoo.el b/app-emacs/mew/files/50mew-gentoo.el
new file mode 100644
index 000000000000..1f36f8e08d93
--- /dev/null
+++ b/app-emacs/mew/files/50mew-gentoo.el
@@ -0,0 +1,7 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'mew "mew" nil t)
+(autoload 'mew-send "mew" nil t)
+
+(setq mew-icon-directory "@SITEETC@")
+(setq mew-pop-port "pop-3")
+(setq mew-imap-port "imap2")
diff --git a/app-emacs/mew/metadata.xml b/app-emacs/mew/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/mew/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>
diff --git a/app-emacs/mew/mew-6.5.ebuild b/app-emacs/mew/mew-6.5.ebuild
new file mode 100644
index 000000000000..f35b547f248b
--- /dev/null
+++ b/app-emacs/mew/mew-6.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Great MIME mail reader for Emacs/XEmacs"
+HOMEPAGE="http://www.mew.org/"
+SRC_URI="http://www.mew.org/Release/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="ssl linguas_ja"
+RESTRICT="test"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}
+ ssl? ( net-misc/stunnel )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ econf \
+ --with-elispdir="${SITELISP}/${PN}" \
+ --with-etcdir="${SITEETC}/${PN}"
+}
+
+src_compile() {
+ emake
+ use linguas_ja && emake jinfo
+ rm -f info/*~ # remove spurious backup files
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use linguas_ja && emake DESTDIR="${D}" install-jinfo
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ dodoc 00api 00changes* 00diff 00readme dot.*
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "Please refer to /usr/share/doc/${PF} for sample configuration files."
+}
diff --git a/app-emacs/mew/mew-6.6.ebuild b/app-emacs/mew/mew-6.6.ebuild
new file mode 100644
index 000000000000..0d22c63e7bca
--- /dev/null
+++ b/app-emacs/mew/mew-6.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo elisp
+
+DESCRIPTION="Great MIME mail reader for Emacs/XEmacs"
+HOMEPAGE="http://www.mew.org/"
+SRC_URI="http://www.mew.org/Release/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="ssl linguas_ja"
+RESTRICT="test"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}
+ ssl? ( net-misc/stunnel )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ econf \
+ --with-elispdir="${SITELISP}/${PN}" \
+ --with-etcdir="${SITEETC}/${PN}"
+}
+
+src_compile() {
+ emake
+ use linguas_ja && emake jinfo
+ rm -f info/*~ # remove spurious backup files
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use linguas_ja && emake DESTDIR="${D}" install-jinfo
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc 00api 00changes* 00diff 00readme dot.*
+
+ DOC_CONTENTS="Please refer to /usr/share/doc/${PF} for sample
+ configuration files."
+ readme.gentoo_create_doc
+}