summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-21 21:14:53 +0100
committerSam James <sam@gentoo.org>2023-08-21 21:15:02 +0100
commit7ef7e506b561a041e9ae1a66cb0a0a4ba6e009cd (patch)
tree0566e9a320587f489cbefeb9c09cd5fd0dfd5869 /app-i18n
parentdev-libs/protobuf-c: fix build w/ new protobuf (diff)
downloadgentoo-7ef7e506b561a041e9ae1a66cb0a0a4ba6e009cd.tar.gz
gentoo-7ef7e506b561a041e9ae1a66cb0a0a4ba6e009cd.tar.bz2
gentoo-7ef7e506b561a041e9ae1a66cb0a0a4ba6e009cd.zip
app-i18n/mozc: fix build w/ new abseil
Closes: https://bugs.gentoo.org/912776 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/mozc/files/mozc-2.28.5029.102-abseil.patch15
-rw-r--r--app-i18n/mozc/mozc-2.28.5029.102.ebuild1
2 files changed, 16 insertions, 0 deletions
diff --git a/app-i18n/mozc/files/mozc-2.28.5029.102-abseil.patch b/app-i18n/mozc/files/mozc-2.28.5029.102-abseil.patch
new file mode 100644
index 000000000000..08421910d098
--- /dev/null
+++ b/app-i18n/mozc/files/mozc-2.28.5029.102-abseil.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/912776
+Adapted from https://src.fedoraproject.org/rpms/mozc/raw/aa3cba136c9a28e176d246f450465d3a8a4e8533/f/mozc-build-new-abseil.patch
+--- a/src/base/init_mozc.cc
++++ b/src/base/init_mozc.cc
+@@ -87,7 +87,10 @@ std::string GetLogFilePathFromProgramName(const std::string &program_name) {
+ void ParseCommandLineFlags(int argc, char **argv) {
+ absl::flags_internal::ParseCommandLineImpl(
+ argc, argv,
++ #if defined(ABSL_LTS_RELEASE_VERSION) && ABSL_LTS_RELEASE_VERSION < 20230802
++ // Abseil 20230802.0 does not use ArgvListAction
+ absl::flags_internal::ArgvListAction::kRemoveParsedArgs,
++ #endif
+ // Suppress help messages invoked by --help and others.
+ // Use UsageFlagsAction::kHandleUsage to enable it.
+ absl::flags_internal::UsageFlagsAction::kIgnoreUsage,
diff --git a/app-i18n/mozc/mozc-2.28.5029.102.ebuild b/app-i18n/mozc/mozc-2.28.5029.102.ebuild
index ee6de0134b29..a6790b3d1213 100644
--- a/app-i18n/mozc/mozc-2.28.5029.102.ebuild
+++ b/app-i18n/mozc/mozc-2.28.5029.102.ebuild
@@ -118,6 +118,7 @@ SITEFILE="50${PN}-gentoo.el"
PATCHES=(
"${WORKDIR}"/mozc-2.28.5029.102-patches
+ "${FILESDIR}"/mozc-2.28.5029.102-abseil.patch
)
python_check_deps() {