summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-06-10 18:45:26 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-06-10 19:00:02 -0700
commit845abbef40e2d97c25e111e18cee63424b1bd5ea (patch)
tree32294d2d3fa9cd6472c1217f9f6be570a212d7dc /app-misc/binwalk
parentapp-misc/binwalk: ppc64 stable (diff)
downloadgentoo-845abbef40e2d97c25e111e18cee63424b1bd5ea.tar.gz
gentoo-845abbef40e2d97c25e111e18cee63424b1bd5ea.tar.bz2
gentoo-845abbef40e2d97c25e111e18cee63424b1bd5ea.zip
app-misc/binwalk: drop old
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-misc/binwalk')
-rw-r--r--app-misc/binwalk/Manifest1
-rw-r--r--app-misc/binwalk/binwalk-2.1.1.ebuild40
-rw-r--r--app-misc/binwalk/files/0001-Added-check-for-backports.lzma-when-importing-lzma-m.patch67
-rw-r--r--app-misc/binwalk/metadata.xml3
4 files changed, 0 insertions, 111 deletions
diff --git a/app-misc/binwalk/Manifest b/app-misc/binwalk/Manifest
index 4b66b45413d1..dc96e51cb0f9 100644
--- a/app-misc/binwalk/Manifest
+++ b/app-misc/binwalk/Manifest
@@ -1,2 +1 @@
-DIST binwalk-2.1.1.tar.gz 263977 BLAKE2B 8fd5f20dcdb22a6528131fbebc1454cc496079bfeafa63ddb0679c7c7b5d5c29d81dccd4f52e8f6f7d8881d9e672d691c2b2ef367f2bf3180ffbb4ad22dca021 SHA512 373e276a4d6ec845952f1091f85f953d3b0d52d561d9b74a54000ebdef85d13cafc997a4f8f76f25842db8b76fdcd1e602d4d81792a3ea01c9dea6c6ed5c2168
DIST binwalk-2.2.0.tar.gz 39594514 BLAKE2B 899a919647258759f16c2e59766b0db68d1a78edf0f5c3755c2a987695199a1851deed2820e6323d82d8af85d294a6f1fcafb655e5d2257d49b673ddae49da67 SHA512 5f3ed31c0b5f9ca3057f86e82787a73b06f9f73747b51dd72130a78e4d69cf43a0207bffc495d177e97811de5bf835b3d0507f314b7a0c960eddf6d1efe0f0f9
diff --git a/app-misc/binwalk/binwalk-2.1.1.ebuild b/app-misc/binwalk/binwalk-2.1.1.ebuild
deleted file mode 100644
index c69739d3e4da..000000000000
--- a/app-misc/binwalk/binwalk-2.1.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/ReFirmLabs/binwalk.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/ReFirmLabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 x86 ~x64-macos"
-fi
-
-DESCRIPTION="A tool for identifying files embedded inside firmware images"
-HOMEPAGE="https://github.com/ReFirmLabs/binwalk"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="graph"
-
-RDEPEND="
- graph? ( dev-python/pyqtgraph[opengl,${PYTHON_USEDEP}] )
-"
-
-PATCHES=( "${FILESDIR}"/0001-Added-check-for-backports.lzma-when-importing-lzma-m.patch )
-
-python_install_all() {
- local DOCS=( API.md INSTALL.md README.md )
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "binwalk has many optional dependencies to automatically"
- elog "extract/decompress data, see INSTALL.md for more details."
- fi
-}
diff --git a/app-misc/binwalk/files/0001-Added-check-for-backports.lzma-when-importing-lzma-m.patch b/app-misc/binwalk/files/0001-Added-check-for-backports.lzma-when-importing-lzma-m.patch
deleted file mode 100644
index 708498060bc7..000000000000
--- a/app-misc/binwalk/files/0001-Added-check-for-backports.lzma-when-importing-lzma-m.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From 95bce4edcc6e92c9517b80ccb1fb956f591e0738 Mon Sep 17 00:00:00 2001
-From: Craig Heffner <heffnercj@gmail.com>
-Date: Tue, 5 Jan 2016 13:28:24 -0500
-Subject: [PATCH] Added check for backports.lzma when importing lzma module
-
----
- src/binwalk/modules/compression.py | 5 ++++-
- src/binwalk/plugins/lzmaextract.py | 6 +++++-
- src/binwalk/plugins/lzmavalid.py | 5 ++++-
- 3 files changed, 13 insertions(+), 3 deletions(-)
-
-diff --git a/src/binwalk/modules/compression.py b/src/binwalk/modules/compression.py
-index 97ca68d..e919f7e 100644
---- a/src/binwalk/modules/compression.py
-+++ b/src/binwalk/modules/compression.py
-@@ -2,11 +2,14 @@
-
- import os
- import zlib
--import lzma
- import struct
- import binwalk.core.compat
- import binwalk.core.common
- from binwalk.core.module import Option, Kwarg, Module
-+try:
-+ import lzma
-+except ImportError:
-+ from backports import lzma
-
- class LZMAHeader(object):
- def __init__(self, **kwargs):
-diff --git a/src/binwalk/plugins/lzmaextract.py b/src/binwalk/plugins/lzmaextract.py
-index 137b4cc..93f6240 100755
---- a/src/binwalk/plugins/lzmaextract.py
-+++ b/src/binwalk/plugins/lzmaextract.py
-@@ -12,7 +12,11 @@ class LZMAExtractPlugin(binwalk.core.plugin.Plugin):
- # lzma package in Python 2.0 decompress() does not handle multiple
- # compressed streams, only first stream is extracted.
- # backports.lzma package could be used to keep consistent behaviour.
-- import lzma
-+ try:
-+ import lzma
-+ except ImportError:
-+ from backports import lzma
-+
- self.decompressor = lzma.decompress
-
- # If the extractor is enabled for the module we're currently loaded
-diff --git a/src/binwalk/plugins/lzmavalid.py b/src/binwalk/plugins/lzmavalid.py
-index a343656..62e15b9 100644
---- a/src/binwalk/plugins/lzmavalid.py
-+++ b/src/binwalk/plugins/lzmavalid.py
-@@ -17,7 +17,10 @@ class LZMAPlugin(binwalk.core.plugin.Plugin):
-
- def init(self):
- try:
-- import lzma
-+ try:
-+ import lzma
-+ except ImportError:
-+ from backports import lzma
- self.decompressor = lzma.decompress
- except ImportError as e:
- self.decompressor = None
---
-2.12.2
-
diff --git a/app-misc/binwalk/metadata.xml b/app-misc/binwalk/metadata.xml
index 12e5ca8a3e8a..6064ade4c2bd 100644
--- a/app-misc/binwalk/metadata.xml
+++ b/app-misc/binwalk/metadata.xml
@@ -18,7 +18,4 @@
<upstream>
<remote-id type="github">ReFirmLabs/binwalk</remote-id>
</upstream>
- <use>
- <flag name="graph">Enable support for generating entropy graphs</flag>
- </use>
</pkgmetadata>