summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-09 07:20:39 +0000
committerSam James <sam@gentoo.org>2024-02-09 07:20:39 +0000
commit0f756e3d2e27f8a2a61256f4a6c10b48656d2b34 (patch)
tree9165fef68dc297ea15f6a4acacf52ae752e62e5f /app-portage
parentsys-process/parallel: Stabilize 20240122 x86, #924121 (diff)
downloadgentoo-0f756e3d2e27f8a2a61256f4a6c10b48656d2b34.tar.gz
gentoo-0f756e3d2e27f8a2a61256f4a6c10b48656d2b34.tar.bz2
gentoo-0f756e3d2e27f8a2a61256f4a6c10b48656d2b34.zip
app-portage/getuto: add 1.10.1
Sam James (1): getuto: move set -e to after sourcing gentoo-functions Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/getuto/Manifest1
-rw-r--r--app-portage/getuto/getuto-1.10.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-portage/getuto/Manifest b/app-portage/getuto/Manifest
index a2a8257d732e..ca055e29b976 100644
--- a/app-portage/getuto/Manifest
+++ b/app-portage/getuto/Manifest
@@ -1,3 +1,4 @@
+DIST getuto-1.10.1.tar.gz 10546 BLAKE2B c5e4a1b3425b1289bd7486bb973032b297c07d587ca57fe6ddf3c598acafdaee5cf3188cd21671e4e848a364f3f40d76ddea93b1270bd6c995b67bfcc584ef51 SHA512 0481780ffe5a5ddfbde72f408cff118de61fecc58143ecde226d7a2200c47a25d7fc92ea94ac31dc94b144dc7e04ba30b838e041fd3f5d4c7cee58e34bfd52c2
DIST getuto-1.10.tar.gz 10544 BLAKE2B b4f5d2d591eb9f41e9fd528122b07bd90d69bcffe1abd721ea747f2d773a6295263bb120437d09b091f95fa0249ce764a2a262a049c74777b7adea765bf88c9a SHA512 2b016fbe7fa046349af7d2a4e8ff26c5ae7328a4af7f1186cd19b3ff5ed6b639d0a6eb7db2f345c71169c0d30c7aea6d5a3a289000878328e776111d025eddb4
DIST getuto-1.9.1.tar.gz 10220 BLAKE2B 4c756f36e9d1272ab194c65e75b6c4d47c248190029ce2b5fe6edb1253998aaa311dd1ae59f893200d1588a52d1bcb53376a32f279c841ae6b5cf5e5b0eeb163 SHA512 3f8e5359940fa5582bea8dc11f2a0846c3f6bdc555974f2f049d5c6ff282029b6393a8c6ae221d327376b4df05de492f44720de90f76f5e3deb436171507f0cb
DIST libc-1-r1-1.gpkg.tar 20480 BLAKE2B b2c184e20c1a29ff66240e992f9f81219285f525eb63cea081372685cf03a2e231a2edb528259617e74c655fbe61b6e0d8fc0bbdbd8452b6098de58432f019d7 SHA512 ce52f398ea8979ec16161381803740d49a4294c77303880f54090c379ba5eb8e545a3d3550f229cacc18c7763dc3adf7936561ba1c64b43c87692ec66084e4e6
diff --git a/app-portage/getuto/getuto-1.10.1.ebuild b/app-portage/getuto/getuto-1.10.1.ebuild
new file mode 100644
index 000000000000..7be78a7129e1
--- /dev/null
+++ b/app-portage/getuto/getuto-1.10.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Standalone Gentoo gpg trust anchor generation tool for binpkgs"
+HOMEPAGE="https://github.com/projg2/getuto"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/projg2/getuto"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/projg2/getuto/archive/refs/tags/${P}.tar.gz
+ "
+ S=${WORKDIR}/${PN}-${P}
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+SRC_URI+=" test? ( https://mirror.bytemark.co.uk/gentoo/releases/amd64/binpackages/17.1/x86-64/virtual/libc/libc-1-r1-1.gpkg.tar )"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-crypt/gnupg
+ dev-libs/openssl
+ sec-keys/openpgp-keys-gentoo-release
+ sys-apps/gentoo-functions
+"
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+ else
+ # Don't mangle test data
+ unpack ${P}.tar.gz
+ fi
+
+ if use test ; then
+ cp "${DISTDIR}"/libc-1-r1-1.gpkg.tar "${S}" || die
+ fi
+}
+
+src_install() {
+ dobin getuto
+}