summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-02-13 21:45:21 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-02-13 21:45:36 +0200
commit6e2b1c2ec2c8a1734182a8e9ef70ea9960324196 (patch)
tree0fbcabc89c224f11d76bcccd2777cbe6c2bcf5d9 /app-shells/liquidprompt/liquidprompt-2.0.4.ebuild
parentdev-libs/libgit2: Revert "Bump to 1.4.0" (diff)
downloadgentoo-6e2b1c2ec2c8a1734182a8e9ef70ea9960324196.tar.gz
gentoo-6e2b1c2ec2c8a1734182a8e9ef70ea9960324196.tar.bz2
gentoo-6e2b1c2ec2c8a1734182a8e9ef70ea9960324196.zip
app-shells/liquidprompt: add 2.0.4
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-shells/liquidprompt/liquidprompt-2.0.4.ebuild')
-rw-r--r--app-shells/liquidprompt/liquidprompt-2.0.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-shells/liquidprompt/liquidprompt-2.0.4.ebuild b/app-shells/liquidprompt/liquidprompt-2.0.4.ebuild
new file mode 100644
index 000000000000..aed3cbeb58e8
--- /dev/null
+++ b/app-shells/liquidprompt/liquidprompt-2.0.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Full-featured & carefully designed adaptive prompt for Bash & Zsh"
+HOMEPAGE="https://github.com/nojhan/liquidprompt"
+SRC_URI="
+ https://github.com/nojhan/liquidprompt/releases/download/v${PV}/${PN}-v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+S="${WORKDIR}/${PN}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-util/shunit2 )"
+
+DOCS=( CHANGELOG.md example.bashrc README.md )
+
+src_test() {
+ cp "$(type -P shunit2)" tests/shunit2 || die
+ ./tests.sh || die
+}
+
+src_install() {
+ default
+ dobin liquidprompt
+
+ insinto /usr/share/${PN}
+ doins liquid.theme
+ doins liquid.ps1
+ doins -r themes
+
+ insinto /etc/
+ newins liquidpromptrc-dist liquidpromptrc
+}