summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2017-01-30 00:50:34 +0100
committerNicolas Bock <nicolasbock@gentoo.org>2017-01-29 17:58:51 -0700
commit73ff0f62b7f8fe425e7d39eb4b2ab4bedda3b403 (patch)
treeed00bd518e727514d9a46bd0283070ec135268a1 /app-text/jabref-bin/jabref-bin-3.8.2.ebuild
parentprofiles/base/package.use.mask: force off mmal on media-video/motion (diff)
downloadgentoo-73ff0f62b7f8fe425e7d39eb4b2ab4bedda3b403.tar.gz
gentoo-73ff0f62b7f8fe425e7d39eb4b2ab4bedda3b403.tar.bz2
gentoo-73ff0f62b7f8fe425e7d39eb4b2ab4bedda3b403.zip
app-text/jabref-bin: bump to 3.8.2, LICENSE change
Upstream changed license from GPL-2 to MIT Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-text/jabref-bin/jabref-bin-3.8.2.ebuild')
-rw-r--r--app-text/jabref-bin/jabref-bin-3.8.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/jabref-bin/jabref-bin-3.8.2.ebuild b/app-text/jabref-bin/jabref-bin-3.8.2.ebuild
new file mode 100644
index 000000000000..c2c74dff4d54
--- /dev/null
+++ b/app-text/jabref-bin/jabref-bin-3.8.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils java-pkg-2
+
+MY_PV_1="${PV/_beta/b}"
+MY_PV="${MY_PV_1/_rc/}"
+MY_URI_PV_1="${PV/rc/}"
+MY_URI_PV="${MY_URI_PV_1//_/%20}"
+
+DESCRIPTION="Java GUI for managing BibTeX and other bibliographies"
+HOMEPAGE="http://www.jabref.org/"
+# SRC_URI="mirror://sourceforge/jabref/JabRef-${MY_PV}.jar"
+SRC_URI="https://github.com/JabRef/jabref/releases/download/v${PV}/JabRef-${MY_PV}.jar"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip"
+
+RDEPEND=">=virtual/jre-1.8"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp -v "${DISTDIR}/${A}" . || die
+ unzip ${A} images/icons/JabRef-icon-48.png || die
+}
+
+src_install() {
+ java-pkg_newjar "JabRef-${MY_PV}.jar"
+ java-pkg_dolauncher "${PN}" --jar "${PN}.jar"
+ newicon images/icons/JabRef-icon-48.png JabRef-bin-icon.png
+ make_desktop_entry "${PN}" JabRef-bin JabRef-bin-icon Office
+}