summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2017-05-28 22:06:46 +0200
committerMichał Górny <mgorny@gentoo.org>2017-06-14 00:47:00 +0200
commit4c4b5008318aca6743877e82c024820e66cfd48b (patch)
tree59584794bf98e652119fd818dde629ab5673b36b /dev-db/sadisplay
parentkde-plasma: Remove KDE Plasma 5.10.1 (diff)
downloadgentoo-4c4b5008318aca6743877e82c024820e66cfd48b.tar.gz
gentoo-4c4b5008318aca6743877e82c024820e66cfd48b.tar.bz2
gentoo-4c4b5008318aca6743877e82c024820e66cfd48b.zip
dev-db/sadisplay: new package
Closes: https://github.com/gentoo/gentoo/pull/4795 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-db/sadisplay')
-rw-r--r--dev-db/sadisplay/Manifest1
-rw-r--r--dev-db/sadisplay/metadata.xml21
-rw-r--r--dev-db/sadisplay/sadisplay-0.4.8.ebuild29
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-db/sadisplay/Manifest b/dev-db/sadisplay/Manifest
new file mode 100644
index 000000000000..9493dc7d98f8
--- /dev/null
+++ b/dev-db/sadisplay/Manifest
@@ -0,0 +1 @@
+DIST sadisplay-0.4.8.tar.gz 9063 SHA256 30d786c33c62ca91b65d6e70753455d0a57fe67737856fa0f00f7ddb9789c9e5 SHA512 c3707f90a20028fdb164caa3037f4ffff3da3f4bc763c400f8204dae4d7d71862e65902892d8ad0fe3bbe636cf87e4f96a475e01e8ce0ac55bed4e17073e3308 WHIRLPOOL 18c5d8b180c8390eb8d0d320b5889e5c8daa6b1191ccb017d7d1845c2c41d5d939a98c8a7d70d84d2de217f296e20830653c836a022ec668ed0042673d3af263
diff --git a/dev-db/sadisplay/metadata.xml b/dev-db/sadisplay/metadata.xml
new file mode 100644
index 000000000000..5e098e138e88
--- /dev/null
+++ b/dev-db/sadisplay/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Simple package for describing SQLAlchemy schema and display raw
+ database tables by reflecting feature. Works with mapped classes
+ and raw tables. Relation detecting by ForeignKey columns.
+ Supports mapped class inherit.
+ </longdescription>
+ <upstream>
+ <remote-id type="bitbucket">estin/sadisplay</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/sadisplay/sadisplay-0.4.8.ebuild b/dev-db/sadisplay/sadisplay-0.4.8.ebuild
new file mode 100644
index 000000000000..56d89724d9dc
--- /dev/null
+++ b/dev-db/sadisplay/sadisplay-0.4.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="SqlAlchemy schema display script"
+HOMEPAGE="https://bitbucket.org/estin/sadisplay/wiki/Home"
+COMMIT_ID="d67d12894ebd"
+SRC_URI="https://bitbucket.org/estin/sadisplay/get/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/sqlalchemy[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )
+ "
+S="${WORKDIR}/estin-${PN}-${COMMIT_ID}"
+
+python_test() {
+ nosetests -v || die
+}