summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-11-19 22:33:06 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-11-19 22:34:25 +0000
commitbfabd57a007f46c09c5dd955cb8d4ea971e54117 (patch)
tree09fd0ec9587d1bc23a61a3080d6d3d37d5030d33 /dev-java/ws-commons-util
parentdev-java/commons-lang: EAPI 5 bump. Fixes bug 566222. (diff)
downloadgentoo-bfabd57a007f46c09c5dd955cb8d4ea971e54117.tar.gz
gentoo-bfabd57a007f46c09c5dd955cb8d4ea971e54117.tar.bz2
gentoo-bfabd57a007f46c09c5dd955cb8d4ea971e54117.zip
dev-java/ws-commons-util: EAPI 5 bump. Switch from dirty hacks to java-pkg-simple eclass. Fixes bug 566234.
Package-Manager: portage-2.2.20.1 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-java/ws-commons-util')
-rw-r--r--dev-java/ws-commons-util/ws-commons-util-1.0.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-java/ws-commons-util/ws-commons-util-1.0.1-r1.ebuild b/dev-java/ws-commons-util/ws-commons-util-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..54c51268b247
--- /dev/null
+++ b/dev-java/ws-commons-util/ws-commons-util-1.0.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+JAVA_PKG_IUSE="source doc"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Utility classes that allow high performance XML processing based on SAX"
+HOMEPAGE="http://ws.apache.org/commons/util/"
+SRC_URI="mirror://apache/ws/commons/util/sources/${P}-src.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND=">=virtual/jre-1.6"
+
+JAVA_SRC_DIR="src"
+
+java_prepare() {
+ mv "${S}"/"${P}"/src . || die
+ rm -rf "${S}"/"${P}" src/test || die
+}