summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-10 23:00:25 +0100
committerSam James <sam@gentoo.org>2023-05-10 23:00:25 +0100
commit97f1778b35848eed1adca03fa45dcf5c337e01c1 (patch)
treee0010bf5ebcd2cfa9c90454fc783d2dc09cefad4 /dev-libs/libxml2
parentx11-terms/xterm: add 380 (diff)
downloadgentoo-97f1778b35848eed1adca03fa45dcf5c337e01c1.tar.gz
gentoo-97f1778b35848eed1adca03fa45dcf5c337e01c1.tar.bz2
gentoo-97f1778b35848eed1adca03fa45dcf5c337e01c1.zip
dev-libs/libxml2: backport various patches to 2.11.2 from 2.11.x branch
2.11.3 should be coming soon hopefully. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libxml2')
-rw-r--r--dev-libs/libxml2/files/libxml2-2.11.2-0001-iconv.patch63
-rw-r--r--dev-libs/libxml2/files/libxml2-2.11.2-0002-crash-old-libxslt.patch27
-rw-r--r--dev-libs/libxml2/files/libxml2-2.11.2-0003-no-xpath.patch245
-rw-r--r--dev-libs/libxml2/files/libxml2-2.11.2-0004-huge-push.patch27
-rw-r--r--dev-libs/libxml2/files/libxml2-2.11.2-0005-icu-detection.patch21
-rw-r--r--dev-libs/libxml2/libxml2-2.11.2-r1.ebuild206
6 files changed, 589 insertions, 0 deletions
diff --git a/dev-libs/libxml2/files/libxml2-2.11.2-0001-iconv.patch b/dev-libs/libxml2/files/libxml2-2.11.2-0001-iconv.patch
new file mode 100644
index 000000000000..615f413c4419
--- /dev/null
+++ b/dev-libs/libxml2/files/libxml2-2.11.2-0001-iconv.patch
@@ -0,0 +1,63 @@
+https://gitlab.gnome.org/GNOME/libxml2/-/commit/9c1f5fe7fbad2b57149c628802c4ded3e4f3d284
+
+From 9c1f5fe7fbad2b57149c628802c4ded3e4f3d284 Mon Sep 17 00:00:00 2001
+From: Mike Dalessio <mike.dalessio@gmail.com>
+Date: Fri, 5 May 2023 17:34:57 -0400
+Subject: [PATCH] autoconf: fix iconv library paths
+
+and pass cflags when building executables
+
+See 0f77167f for prior related work
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -145,11 +145,12 @@ runsuite_DEPENDENCIES = $(DEPS)
+ runsuite_LDADD= $(LDADDS)
+
+ xmllint_SOURCES=xmllint.c
+-xmllint_CFLAGS = $(AM_CFLAGS) $(RDL_CFLAGS)
++xmllint_CFLAGS = $(AM_CFLAGS) $(RDL_CFLAGS) $(ICONV_CFLAGS)
+ xmllint_DEPENDENCIES = $(DEPS)
+ xmllint_LDADD= $(RDL_LIBS) $(LDADDS)
+
+ xmlcatalog_SOURCES=xmlcatalog.c
++xmlcatalog_CFLAGS = $(AM_CFLAGS) $(RDL_CFLAGS) $(ICONV_CFLAGS)
+ xmlcatalog_DEPENDENCIES = $(DEPS)
+ xmlcatalog_LDADD = $(RDL_LIBS) $(LDADDS)
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -1036,7 +1036,7 @@ else
+ if test "$with_iconv" != "yes" && test "$with_iconv" != "" ; then
+ ICONV_DIR=$with_iconv
+ CPPFLAGS="$CPPFLAGS -I$ICONV_DIR/include"
+- LIBS="$LIBS -L$ICONV_DIR/libs"
++ LIBS="$LIBS -L$ICONV_DIR/lib"
+ # Export this since our headers include iconv.h
+ XML_INCLUDEDIR="$XML_INCLUDEDIR -I$ICONV_DIR/include"
+ fi
+@@ -1052,12 +1052,13 @@ else
+ ICONV_LIBS="-liconv"])])])
+ if test "$WITH_ICONV" = "1" && test "$ICONV_DIR" != ""; then
+ ICONV_CFLAGS="-I$ICONV_DIR/include"
+- ICONV_LIBS="-L$ICONV_DIR/libs $ICONV_LIBS"
++ ICONV_LIBS="-L$ICONV_DIR/lib $ICONV_LIBS"
+ fi
+ CPPFLAGS=$_cppflags
+ LIBS=$_libs
+ fi
+ AC_SUBST(WITH_ICONV)
++AC_SUBST(ICONV_CFLAGS)
+
+ dnl
+ dnl Checks for ICU library.
+@@ -1100,7 +1101,7 @@ else
+ ICU_LIBS=-licucore
+ if test "$ICU_DIR" != ""; then
+ ICU_CFLAGS="-I$ICU_DIR/include"
+- ICU_LIBS="-L$ICU_DIR/libs $ICU_LIBS"
++ ICU_LIBS="-L$ICU_DIR/lib $ICU_LIBS"
+ fi])])
+ CPPFLAGS=$_cppflags
+ LIBS=$_libs
+--
+GitLab
diff --git a/dev-libs/libxml2/files/libxml2-2.11.2-0002-crash-old-libxslt.patch b/dev-libs/libxml2/files/libxml2-2.11.2-0002-crash-old-libxslt.patch
new file mode 100644
index 000000000000..2253ea6211d1
--- /dev/null
+++ b/dev-libs/libxml2/files/libxml2-2.11.2-0002-crash-old-libxslt.patch
@@ -0,0 +1,27 @@
+https://gitlab.gnome.org/GNOME/libxml2/-/commit/e6a9cc8d66778c20435a46e50d4e5866deace5f6
+
+From e6a9cc8d66778c20435a46e50d4e5866deace5f6 Mon Sep 17 00:00:00 2001
+From: Nick Wellnhofer <wellnhofer@aevum.de>
+Date: Sat, 6 May 2023 15:28:13 +0200
+Subject: [PATCH] hash: Fix possible startup crash with old libxslt versions
+
+Call xmlInitParser in xmlHashCreate to make it work if the library
+wasn't initialized yet.
+
+Otherwise, exsltRegisterAll from libxslt 1.1.24 or older might cause
+a crash.
+
+See #534.
+--- a/hash.c
++++ b/hash.c
+@@ -180,6 +180,8 @@ xmlHashTablePtr
+ xmlHashCreate(int size) {
+ xmlHashTablePtr table;
+
++ xmlInitParser();
++
+ if (size <= 0)
+ size = 256;
+
+--
+GitLab
diff --git a/dev-libs/libxml2/files/libxml2-2.11.2-0003-no-xpath.patch b/dev-libs/libxml2/files/libxml2-2.11.2-0003-no-xpath.patch
new file mode 100644
index 000000000000..f036c5814f26
--- /dev/null
+++ b/dev-libs/libxml2/files/libxml2-2.11.2-0003-no-xpath.patch
@@ -0,0 +1,245 @@
+https://gitlab.gnome.org/GNOME/libxml2/-/commit/41e78f8f8656b8e2206c06995da6bd8dcc82823d
+
+From 41e78f8f8656b8e2206c06995da6bd8dcc82823d Mon Sep 17 00:00:00 2001
+From: Nick Wellnhofer <wellnhofer@aevum.de>
+Date: Mon, 8 May 2023 23:12:33 +0200
+Subject: [PATCH] xpath: Fix build without LIBXML_XPATH_ENABLED
+
+Move static function declaration into XPATH block. Also move comparison
+functions.
+
+Fixes #537.
+--- a/xpath.c
++++ b/xpath.c
+@@ -145,6 +145,114 @@
+ * any use of the macros IS_ASCII_CHARACTER and IS_ASCII_DIGIT)
+ */
+
++#if defined(LIBXML_XPATH_ENABLED) || defined(LIBXML_SCHEMAS_ENABLED)
++
++/************************************************************************
++ * *
++ * Floating point stuff *
++ * *
++ ************************************************************************/
++
++double xmlXPathNAN = 0.0;
++double xmlXPathPINF = 0.0;
++double xmlXPathNINF = 0.0;
++
++/**
++ * xmlXPathInit:
++ *
++ * DEPRECATED: Alias for xmlInitParser.
++ */
++void
++xmlXPathInit(void) {
++ xmlInitParser();
++}
++
++/**
++ * xmlInitXPathInternal:
++ *
++ * Initialize the XPath environment
++ */
++ATTRIBUTE_NO_SANITIZE("float-divide-by-zero")
++void
++xmlInitXPathInternal(void) {
++#if defined(NAN) && defined(INFINITY)
++ xmlXPathNAN = NAN;
++ xmlXPathPINF = INFINITY;
++ xmlXPathNINF = -INFINITY;
++#else
++ /* MSVC doesn't allow division by zero in constant expressions. */
++ double zero = 0.0;
++ xmlXPathNAN = 0.0 / zero;
++ xmlXPathPINF = 1.0 / zero;
++ xmlXPathNINF = -xmlXPathPINF;
++#endif
++}
++
++/**
++ * xmlXPathIsNaN:
++ * @val: a double value
++ *
++ * Returns 1 if the value is a NaN, 0 otherwise
++ */
++int
++xmlXPathIsNaN(double val) {
++#ifdef isnan
++ return isnan(val);
++#else
++ return !(val == val);
++#endif
++}
++
++/**
++ * xmlXPathIsInf:
++ * @val: a double value
++ *
++ * Returns 1 if the value is +Infinite, -1 if -Infinite, 0 otherwise
++ */
++int
++xmlXPathIsInf(double val) {
++#ifdef isinf
++ return isinf(val) ? (val > 0 ? 1 : -1) : 0;
++#else
++ if (val >= xmlXPathPINF)
++ return 1;
++ if (val <= -xmlXPathPINF)
++ return -1;
++ return 0;
++#endif
++}
++
++#endif /* SCHEMAS or XPATH */
++
++#ifdef LIBXML_XPATH_ENABLED
++
++/*
++ * TODO: when compatibility allows remove all "fake node libxslt" strings
++ * the test should just be name[0] = ' '
++ */
++#ifdef DEBUG_XPATH_EXPRESSION
++#define DEBUG_STEP
++#define DEBUG_EXPR
++#define DEBUG_EVAL_COUNTS
++#endif
++
++static xmlNs xmlXPathXMLNamespaceStruct = {
++ NULL,
++ XML_NAMESPACE_DECL,
++ XML_XML_NAMESPACE,
++ BAD_CAST "xml",
++ NULL,
++ NULL
++};
++static xmlNsPtr xmlXPathXMLNamespace = &xmlXPathXMLNamespaceStruct;
++#ifndef LIBXML_THREAD_ENABLED
++/*
++ * Optimizer is disabled only when threaded apps are detected while
++ * the library ain't compiled for thread safety.
++ */
++static int xmlXPathDisableOptimizer = 0;
++#endif
++
+ static void
+ xmlXPathNodeSetClear(xmlNodeSetPtr set, int hasNsNodes);
+
+@@ -475,114 +583,6 @@ int wrap_cmp( xmlNodePtr x, xmlNodePtr y );
+ #include "timsort.h"
+ #endif /* WITH_TIM_SORT */
+
+-#if defined(LIBXML_XPATH_ENABLED) || defined(LIBXML_SCHEMAS_ENABLED)
+-
+-/************************************************************************
+- * *
+- * Floating point stuff *
+- * *
+- ************************************************************************/
+-
+-double xmlXPathNAN = 0.0;
+-double xmlXPathPINF = 0.0;
+-double xmlXPathNINF = 0.0;
+-
+-/**
+- * xmlXPathInit:
+- *
+- * DEPRECATED: Alias for xmlInitParser.
+- */
+-void
+-xmlXPathInit(void) {
+- xmlInitParser();
+-}
+-
+-/**
+- * xmlInitXPathInternal:
+- *
+- * Initialize the XPath environment
+- */
+-ATTRIBUTE_NO_SANITIZE("float-divide-by-zero")
+-void
+-xmlInitXPathInternal(void) {
+-#if defined(NAN) && defined(INFINITY)
+- xmlXPathNAN = NAN;
+- xmlXPathPINF = INFINITY;
+- xmlXPathNINF = -INFINITY;
+-#else
+- /* MSVC doesn't allow division by zero in constant expressions. */
+- double zero = 0.0;
+- xmlXPathNAN = 0.0 / zero;
+- xmlXPathPINF = 1.0 / zero;
+- xmlXPathNINF = -xmlXPathPINF;
+-#endif
+-}
+-
+-/**
+- * xmlXPathIsNaN:
+- * @val: a double value
+- *
+- * Returns 1 if the value is a NaN, 0 otherwise
+- */
+-int
+-xmlXPathIsNaN(double val) {
+-#ifdef isnan
+- return isnan(val);
+-#else
+- return !(val == val);
+-#endif
+-}
+-
+-/**
+- * xmlXPathIsInf:
+- * @val: a double value
+- *
+- * Returns 1 if the value is +Infinite, -1 if -Infinite, 0 otherwise
+- */
+-int
+-xmlXPathIsInf(double val) {
+-#ifdef isinf
+- return isinf(val) ? (val > 0 ? 1 : -1) : 0;
+-#else
+- if (val >= xmlXPathPINF)
+- return 1;
+- if (val <= -xmlXPathPINF)
+- return -1;
+- return 0;
+-#endif
+-}
+-
+-#endif /* SCHEMAS or XPATH */
+-
+-#ifdef LIBXML_XPATH_ENABLED
+-
+-/*
+- * TODO: when compatibility allows remove all "fake node libxslt" strings
+- * the test should just be name[0] = ' '
+- */
+-#ifdef DEBUG_XPATH_EXPRESSION
+-#define DEBUG_STEP
+-#define DEBUG_EXPR
+-#define DEBUG_EVAL_COUNTS
+-#endif
+-
+-static xmlNs xmlXPathXMLNamespaceStruct = {
+- NULL,
+- XML_NAMESPACE_DECL,
+- XML_XML_NAMESPACE,
+- BAD_CAST "xml",
+- NULL,
+- NULL
+-};
+-static xmlNsPtr xmlXPathXMLNamespace = &xmlXPathXMLNamespaceStruct;
+-#ifndef LIBXML_THREAD_ENABLED
+-/*
+- * Optimizer is disabled only when threaded apps are detected while
+- * the library ain't compiled for thread safety.
+- */
+-static int xmlXPathDisableOptimizer = 0;
+-#endif
+-
+ /************************************************************************
+ * *
+ * Error handling routines *
+--
+GitLab
diff --git a/dev-libs/libxml2/files/libxml2-2.11.2-0004-huge-push.patch b/dev-libs/libxml2/files/libxml2-2.11.2-0004-huge-push.patch
new file mode 100644
index 000000000000..5f3d06038271
--- /dev/null
+++ b/dev-libs/libxml2/files/libxml2-2.11.2-0004-huge-push.patch
@@ -0,0 +1,27 @@
+https://gitlab.gnome.org/GNOME/libxml2/-/commit/7c14859d0779797a93ea75744266425028599944
+
+From 7c14859d0779797a93ea75744266425028599944 Mon Sep 17 00:00:00 2001
+From: Nick Wellnhofer <wellnhofer@aevum.de>
+Date: Tue, 9 May 2023 13:28:06 +0200
+Subject: [PATCH] parser: Fix "huge input lookup" error with push parser
+
+Fix parsing of larger documents without XML_PARSE_HUGE.
+
+Should fix #538.
+--- a/parserInternals.c
++++ b/parserInternals.c
+@@ -418,9 +418,10 @@ xmlParserShrink(xmlParserCtxtPtr ctxt) {
+ xmlParserInputBufferPtr buf = in->buf;
+ size_t used;
+
+- /* Don't shrink memory buffers. */
++ /* Don't shrink pull parser memory buffers. */
+ if ((buf == NULL) ||
+- ((buf->encoder == NULL) && (buf->readcallback == NULL)))
++ ((ctxt->progressive == 0) &&
++ (buf->encoder == NULL) && (buf->readcallback == NULL)))
+ return;
+
+ used = in->cur - in->base;
+--
+GitLab
diff --git a/dev-libs/libxml2/files/libxml2-2.11.2-0005-icu-detection.patch b/dev-libs/libxml2/files/libxml2-2.11.2-0005-icu-detection.patch
new file mode 100644
index 000000000000..6fffb156ea9c
--- /dev/null
+++ b/dev-libs/libxml2/files/libxml2-2.11.2-0005-icu-detection.patch
@@ -0,0 +1,21 @@
+https://gitlab.gnome.org/GNOME/libxml2/-/commit/55f221a4c57903ced5721008607d4133d6eb51cf
+
+From 55f221a4c57903ced5721008607d4133d6eb51cf Mon Sep 17 00:00:00 2001
+From: Nick Wellnhofer <wellnhofer@aevum.de>
+Date: Wed, 10 May 2023 18:13:47 +0200
+Subject: [PATCH] autotools: Fix ICU detection
+
+Fixes #540.
+--- a/configure.ac
++++ b/configure.ac
+@@ -1096,7 +1096,7 @@ else
+ fi
+
+ AC_CHECK_HEADER(unicode/ucnv.h, [
+- AC_CHECK_LIB([icucore], [uconv_open], [
++ AC_CHECK_LIB([icucore], [ucnv_open], [
+ WITH_ICU=1
+ ICU_LIBS=-licucore
+ if test "$ICU_DIR" != ""; then
+--
+GitLab
diff --git a/dev-libs/libxml2/libxml2-2.11.2-r1.ebuild b/dev-libs/libxml2/libxml2-2.11.2-r1.ebuild
new file mode 100644
index 000000000000..005ddba984c7
--- /dev/null
+++ b/dev-libs/libxml2/libxml2-2.11.2-r1.ebuild
@@ -0,0 +1,206 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Note: Please bump in sync with dev-libs/libxslt
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="xml(+)"
+inherit flag-o-matic python-r1 multilib-minimal
+
+XSTS_HOME="http://www.w3.org/XML/2004/xml-schema-test-suite"
+XSTS_NAME_1="xmlschema2002-01-16"
+XSTS_NAME_2="xmlschema2004-01-14"
+XSTS_TARBALL_1="xsts-2002-01-16.tar.gz"
+XSTS_TARBALL_2="xsts-2004-01-14.tar.gz"
+XMLCONF_TARBALL="xmlts20130923.tar.gz"
+
+DESCRIPTION="XML C parser and toolkit"
+HOMEPAGE="http://www.xmlsoft.org/ https://gitlab.gnome.org/GNOME/libxml2"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/libxml2"
+ inherit autotools git-r3
+else
+ inherit autotools gnome.org libtool
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+SRC_URI+="
+ test? (
+ ${XSTS_HOME}/${XSTS_NAME_1}/${XSTS_TARBALL_1}
+ ${XSTS_HOME}/${XSTS_NAME_2}/${XSTS_TARBALL_2}
+ https://www.w3.org/XML/Test/${XMLCONF_TARBALL}
+ )
+"
+S="${WORKDIR}/${PN}-${PV%_rc*}"
+
+LICENSE="MIT"
+SLOT="2"
+IUSE="debug examples +ftp icu lzma +python readline static-libs test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ >=sys-libs/zlib-1.2.8-r1:=[${MULTILIB_USEDEP}]
+ icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
+ lzma? ( >=app-arch/xz-utils-5.0.5-r1:=[${MULTILIB_USEDEP}] )
+ python? ( ${PYTHON_DEPS} )
+ readline? ( sys-libs/readline:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+if [[ ${PV} == 9999 ]] ; then
+ BDEPEND+=" dev-util/gtk-doc-am"
+fi
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/xml2-config
+)
+
+PATCHES=(
+ "${FILESDIR}"/${P}-0001-iconv.patch
+ "${FILESDIR}"/${P}-0002-crash-old-libxslt.patch
+ "${FILESDIR}"/${P}-0003-no-xpath.patch
+ "${FILESDIR}"/${P}-0004-huge-push.patch
+ "${FILESDIR}"/${P}-0005-icu-detection.patch
+)
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+ else
+ local tarname=${P/_rc/-rc}.tar.xz
+
+ # ${A} isn't used to avoid unpacking of test tarballs into ${WORKDIR},
+ # as they are needed as tarballs in ${S}/xstc instead and not unpacked
+ unpack ${tarname}
+
+ if [[ -n ${PATCHSET_VERSION} ]] ; then
+ unpack ${PN}-${PATCHSET_VERSION}.tar.bz2
+ fi
+ fi
+
+ cd "${S}" || die
+
+ if use test ; then
+ cp "${DISTDIR}/${XSTS_TARBALL_1}" \
+ "${DISTDIR}/${XSTS_TARBALL_2}" \
+ "${S}"/xstc/ \
+ || die "Failed to install test tarballs"
+ unpack ${XMLCONF_TARBALL}
+ fi
+}
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ else
+ # Please do not remove, as else we get references to PORTAGE_TMPDIR
+ # in /usr/lib/python?.?/site-packages/libxml2mod.la among things.
+ #elibtoolize
+
+ # TODO: remove me >2.11.2, just here for backports
+ eautoreconf
+ fi
+}
+
+multilib_src_configure() {
+ # Filter seemingly problematic CFLAGS (bug #26320)
+ filter-flags -fprefetch-loop-arrays -funroll-loops
+
+ # Notes:
+ # The meaning of the 'debug' USE flag does not apply to the --with-debug
+ # switch (enabling the libxml2 debug module). See bug #100898.
+ libxml2_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --enable-ipv6 \
+ $(use_with ftp) \
+ $(use_with debug run-debug) \
+ $(use_with icu) \
+ $(use_with lzma) \
+ $(use_enable static-libs static) \
+ $(multilib_native_use_with readline) \
+ $(multilib_native_use_with readline history) \
+ "$@"
+ }
+
+ # Build python bindings separately
+ libxml2_configure --without-python
+
+ multilib_is_native_abi && use python &&
+ python_foreach_impl run_in_build_dir libxml2_configure --with-python
+}
+
+libxml2_py_emake() {
+ pushd "${BUILD_DIR}"/python >/dev/null || die
+
+ emake top_builddir="${NATIVE_BUILD_DIR}" "$@"
+
+ popd >/dev/null || die
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi && use python ; then
+ NATIVE_BUILD_DIR="${BUILD_DIR}"
+ python_foreach_impl run_in_build_dir libxml2_py_emake all
+ fi
+}
+
+multilib_src_test() {
+ ln -s "${S}"/xmlconf || die
+
+ emake check
+
+ multilib_is_native_abi && use python &&
+ python_foreach_impl run_in_build_dir libxml2_py_emake check
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ multilib_is_native_abi && use python &&
+ python_foreach_impl run_in_build_dir libxml2_py_emake DESTDIR="${D}" install
+
+ # Hack until automake release is made for the optimise fix
+ # https://git.savannah.gnu.org/cgit/automake.git/commit/?id=bde43d0481ff540418271ac37012a574a4fcf097
+ multilib_is_native_abi && use python && python_foreach_impl python_optimize
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if ! use examples ; then
+ rm -rf "${ED}"/usr/share/doc/${PF}/examples || die
+ rm -rf "${ED}"/usr/share/doc/${PF}/python/examples || die
+ fi
+
+ rm -rf "${ED}"/usr/share/doc/${PN}-python-${PVR} || die
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ # We don't want to do the xmlcatalog during stage1, as xmlcatalog will not
+ # be in / and stage1 builds to ROOT=/tmp/stage1root. This fixes bug #208887.
+ if [[ -n "${ROOT}" ]]; then
+ elog "Skipping XML catalog creation for stage building (bug #208887)."
+ else
+ # Need an XML catalog, so no-one writes to a non-existent one
+ CATALOG="${EROOT}/etc/xml/catalog"
+
+ # We don't want to clobber an existing catalog though,
+ # only ensure that one is there
+ # <obz@gentoo.org>
+ if [[ ! -e "${CATALOG}" ]]; then
+ [[ -d "${EROOT}/etc/xml" ]] || mkdir -p "${EROOT}/etc/xml"
+ "${EPREFIX}"/usr/bin/xmlcatalog --create > "${CATALOG}"
+ einfo "Created XML catalog in ${CATALOG}"
+ fi
+ fi
+}