summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-15 02:12:24 +0000
committerSam James <sam@gentoo.org>2020-12-15 02:13:09 +0000
commitab7b1a7283457e9ab07edf0d031d78bf19b9c05b (patch)
treef83ea86768866de389484c5891d6e6e1163ee638 /dev-libs/pugixml
parentsci-libs/vtk: further >=dev-libs/pugixml-1.11 fixes (diff)
downloadgentoo-ab7b1a7283457e9ab07edf0d031d78bf19b9c05b.tar.gz
gentoo-ab7b1a7283457e9ab07edf0d031d78bf19b9c05b.tar.bz2
gentoo-ab7b1a7283457e9ab07edf0d031d78bf19b9c05b.zip
dev-libs/pugixml: add upstream patch for CMake file
Ensure that the compatibility target uses legal syntax. Closes: https://bugs.gentoo.org/758611 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/pugixml')
-rw-r--r--dev-libs/pugixml/files/pugixml-1.11.1-cmake-config.patch23
-rw-r--r--dev-libs/pugixml/pugixml-1.11.1-r1.ebuild (renamed from dev-libs/pugixml/pugixml-1.11.1.ebuild)4
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/pugixml/files/pugixml-1.11.1-cmake-config.patch b/dev-libs/pugixml/files/pugixml-1.11.1-cmake-config.patch
new file mode 100644
index 000000000000..2aec70d4f767
--- /dev/null
+++ b/dev-libs/pugixml/files/pugixml-1.11.1-cmake-config.patch
@@ -0,0 +1,23 @@
+https://github.com/zeux/pugixml/pull/389.patch
+From 4feab60bb7ecced7cea18c570ca9a39a08246a57 Mon Sep 17 00:00:00 2001
+From: Ben Boeckel <ben.boeckel@kitware.com>
+Date: Thu, 10 Dec 2020 07:52:35 -0500
+Subject: [PATCH] cmake: avoid ALIAS target
+
+This is not allowed on IMPORTED targets.
+---
+ scripts/pugixml-config.cmake.in | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/scripts/pugixml-config.cmake.in b/scripts/pugixml-config.cmake.in
+index 5af37501..58be6391 100644
+--- a/scripts/pugixml-config.cmake.in
++++ b/scripts/pugixml-config.cmake.in
+@@ -6,5 +6,6 @@ include("${CMAKE_CURRENT_LIST_DIR}/pugixml-targets.cmake")
+ # version or not requesting one at all), provide the old imported target name
+ # for compatibility.
+ if (NOT DEFINED PACKAGE_FIND_VERSION OR PACKAGE_FIND_VERSION VERSION_LESS "1.11")
+- add_library(pugixml ALIAS pugixml::pugixml)
++ add_library(pugixml INTERFACE IMPORTED)
++ target_link_libraries(pugixml INTERFACE pugixml::pugixml)
+ endif ()
diff --git a/dev-libs/pugixml/pugixml-1.11.1.ebuild b/dev-libs/pugixml/pugixml-1.11.1-r1.ebuild
index 0750359ebd79..ebdf4d377152 100644
--- a/dev-libs/pugixml/pugixml-1.11.1.ebuild
+++ b/dev-libs/pugixml/pugixml-1.11.1-r1.ebuild
@@ -18,3 +18,7 @@ HOMEPAGE="https://pugixml.org/ https://github.com/zeux/pugixml/"
LICENSE="MIT"
SLOT="0"
+
+PATCHES=(
+ "${FILESDIR}/${P}-cmake-config.patch"
+)