summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/batteries
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/batteries')
-rw-r--r--dev-ml/batteries/Manifest3
-rw-r--r--dev-ml/batteries/batteries-2.1.ebuild23
-rw-r--r--dev-ml/batteries/batteries-2.2.ebuild22
-rw-r--r--dev-ml/batteries/batteries-2.3.ebuild22
-rw-r--r--dev-ml/batteries/files/batteries-2.1-ocaml-4.01.patch21
-rw-r--r--dev-ml/batteries/metadata.xml5
6 files changed, 96 insertions, 0 deletions
diff --git a/dev-ml/batteries/Manifest b/dev-ml/batteries/Manifest
new file mode 100644
index 000000000000..160f5d3da9a4
--- /dev/null
+++ b/dev-ml/batteries/Manifest
@@ -0,0 +1,3 @@
+DIST batteries-2.1.tar.gz 695812 SHA256 ad7b85ebc4404192ef101fa143147dd12713017de7941d71c64f7c7d354e91bf SHA512 03fa0d9ba3333e0b80d2aec087453c13497b419f22229432e7c99a519a03a013c647c9a09e32250f17dad3fe47975ff76901df9dd289c87a877e4665ac344f70 WHIRLPOOL 29c50e51b74964971412a2026d571644920cd367c22b6c62375d19ff4a87342e50a46164317b5da3b40d7d51c2fcf33a3000ba67588ff9a8fbc3608d4f0f1120
+DIST batteries-2.2.tar.gz 711616 SHA256 7a7139ffa0c0da356a3be63a1024eb15f15eaf6d396b999565e77f77ca789c7c SHA512 023d919cbb402e1386334865dfbd17a5a7a2eb07f8ddce682bab37b1d4b140bf5ce90519744d026ae012da20abbddf65707cff5e2568c9682b8fc69cf3f0977a WHIRLPOOL ba61455f2f4323c420f7b53424449bdda40ddf8f3766d31ac91b4f043d07bd19c53fc6f7d5d47de3debcf1cf30210696a24201e78fc2163a8726a19310b7e274
+DIST batteries-2.3.tar.gz 728917 SHA256 f54276dfad1b00a90d6d64c4e35621879a1a9409e024f9267155071725d209fe SHA512 0f55e75cc8057ec4ba9683aee91509a3bf2ee93d1990a932cd3924cd602aeeea80a5da50b0651500fc153285b1d80b9378ec1fa656e7f94311e992e9ba308c88 WHIRLPOOL bdab9410456e35f5251dc9994507faf602bb617fd7077b444003960528e38fdf0c97ccab96cd0d4a265402fa457a66635d6948e1c87dac9793069e0b34a18029
diff --git a/dev-ml/batteries/batteries-2.1.ebuild b/dev-ml/batteries/batteries-2.1.ebuild
new file mode 100644
index 000000000000..1ce1feca1fd1
--- /dev/null
+++ b/dev-ml/batteries/batteries-2.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit oasis
+
+DESCRIPTION="The community-maintained foundation library for your OCaml projects"
+HOMEPAGE="http://batteries.forge.ocamlcore.org/"
+SRC_URI="https://forge.ocamlcore.org/frs/download.php/1218/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-ml/camomile:="
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit dev-ml/iTeML )"
+
+DOCS=( "ChangeLog" "FAQ" "README.folders" "README.md" )
+PATCHES=( "${FILESDIR}/${P}-ocaml-4.01.patch" )
diff --git a/dev-ml/batteries/batteries-2.2.ebuild b/dev-ml/batteries/batteries-2.2.ebuild
new file mode 100644
index 000000000000..af9f5d2f8aa4
--- /dev/null
+++ b/dev-ml/batteries/batteries-2.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit oasis
+
+DESCRIPTION="The community-maintained foundation library for your OCaml projects"
+HOMEPAGE="http://batteries.forge.ocamlcore.org/"
+SRC_URI="https://forge.ocamlcore.org/frs/download.php/1363/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-ml/camomile:="
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit dev-ml/iTeML )"
+
+DOCS=( "ChangeLog" "FAQ" "README.folders" "README.md" )
diff --git a/dev-ml/batteries/batteries-2.3.ebuild b/dev-ml/batteries/batteries-2.3.ebuild
new file mode 100644
index 000000000000..93a77346a503
--- /dev/null
+++ b/dev-ml/batteries/batteries-2.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit oasis
+
+DESCRIPTION="The community-maintained foundation library for your OCaml projects"
+HOMEPAGE="http://batteries.forge.ocamlcore.org/"
+SRC_URI="https://forge.ocamlcore.org/frs/download.php/1465/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-ml/camomile:="
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit dev-ml/iTeML )"
+
+DOCS=( "ChangeLog" "FAQ" "README.folders" "README.md" )
diff --git a/dev-ml/batteries/files/batteries-2.1-ocaml-4.01.patch b/dev-ml/batteries/files/batteries-2.1-ocaml-4.01.patch
new file mode 100644
index 000000000000..49194794e967
--- /dev/null
+++ b/dev-ml/batteries/files/batteries-2.1-ocaml-4.01.patch
@@ -0,0 +1,21 @@
+commit 1db918c5966c6f95dda9b2c4c26975b0a8fddb2c
+Author: Gabriel Scherer <gabriel.scherer@gmail.com>
+Date: Thu Aug 8 11:59:49 2013 +0200
+
+ Add the new O_CLOEXEC flag to Unix.open_flag in version 4.1
+
+diff --git a/src/batUnix.mliv b/src/batUnix.mliv
+index bd710a7..943db0a 100644
+--- a/src/batUnix.mliv
++++ b/src/batUnix.mliv
+@@ -261,6 +261,10 @@ type open_flag = Unix.open_flag =
+ O_SYNC/O_DSYNC) *)
+ ##V4## | O_SHARE_DELETE (** OCaml 4 and Windows only: allow the file to be deleted
+ ##V4## while still open *)
++##V4.1## | O_CLOEXEC (** Set the close-on-exec flag on the
++##V4.1## descriptor returned by {!openfile}
++##V4.1##
++##V4.1## Since OCaml 4.1 *)
+ (** The flags to {!Unix.openfile}. *)
+
+
diff --git a/dev-ml/batteries/metadata.xml b/dev-ml/batteries/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/batteries/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>