summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-02-02 15:29:50 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-02-02 15:30:03 +0100
commitd7525d7953d7952da3c531e516f00b0f1d1c6fd9 (patch)
treeb2ed9c50af359d885e5a000e113500437591121d /dev-ml
parentnet-misc/xmrig: drop 6.18.0 (diff)
downloadgentoo-d7525d7953d7952da3c531e516f00b0f1d1c6fd9.tar.gz
gentoo-d7525d7953d7952da3c531e516f00b0f1d1c6fd9.tar.bz2
gentoo-d7525d7953d7952da3c531e516f00b0f1d1c6fd9.zip
dev-ml/ocaml-sha: add 1.15.4
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-sha/Manifest1
-rw-r--r--dev-ml/ocaml-sha/ocaml-sha-1.15.4.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/ocaml-sha/Manifest b/dev-ml/ocaml-sha/Manifest
index 07c86dccea07..046f52c7dfb3 100644
--- a/dev-ml/ocaml-sha/Manifest
+++ b/dev-ml/ocaml-sha/Manifest
@@ -1,2 +1,3 @@
DIST ocaml-sha-1.15.1.tar.gz 15972 BLAKE2B c80fe4ba9a216fb88b0ca4cdf4f467450ad7225c9aa8fbb7389c85b8372de0a965683dc4a674c82ae4c2801b9f6a83777fbd3bfe5deb68af3d5e9193c058c9d9 SHA512 25af4f3fff6d5126e5e3b5f4dff4d6cc48396ffea48da186450236825bbb79110c7918a2bfa1c77dfaee9570965f9052d87c513d9f9da01208d95962b12cfd1c
DIST ocaml-sha-1.15.2.tar.gz 15700 BLAKE2B 7504d4302d54d94f6b8143efce6487dbc95c4f909baef515a85a7a6f7adcc5cff94225ae9231770193025312a82384b738e47001f1b6975cd39f4d21b8f6a162 SHA512 7ea47377747ef4c36791c4ed9ff88fe138ee14d012cc3f7b41fcc28776e57ea54c5ee5cc033adc6288177ed834afb73c44e60cfff01f1be28492a992f97a1d06
+DIST sha-1.15.4.tbz 17759 BLAKE2B 24ca05f6228aa3fce3bd4d0478115f7664569b6d1a3049298d4c4255b4e9ff0e91ac1d957236331fef275466744d539721251d9bfaf6790f55f438223e761581 SHA512 dbb31b523ba0bace023bc1b0558a8f572a0ec20fb3f19f783935be755cd161e09aba352eda2bcf7c4e5ab838c7f874cfbfaed9debf0813df25d9dbe7b9314fdf
diff --git a/dev-ml/ocaml-sha/ocaml-sha-1.15.4.ebuild b/dev-ml/ocaml-sha/ocaml-sha-1.15.4.ebuild
new file mode 100644
index 000000000000..3da8b2a1fbbe
--- /dev/null
+++ b/dev-ml/ocaml-sha/ocaml-sha-1.15.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DUNE_PKG_NAME=sha
+
+inherit dune
+
+MYP=sha-${PV}
+DESCRIPTION="Binding to the SHA cryptographic functions"
+HOMEPAGE="https://github.com/djs55/ocaml-sha/"
+SRC_URI="https://github.com/djs55/${PN}/releases/download/v${PV}/${MYP}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-ml/stdlib-shims:="
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-ml/ounit2 )"
+
+S="${WORKDIR}"/${MYP}