summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Business-ISMN
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Business-ISMN')
-rw-r--r--dev-perl/Business-ISMN/Business-ISMN-1.110.0-r1.ebuild33
-rw-r--r--dev-perl/Business-ISMN/Business-ISMN-1.130.0.ebuild33
-rw-r--r--dev-perl/Business-ISMN/Manifest2
-rw-r--r--dev-perl/Business-ISMN/metadata.xml10
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-perl/Business-ISMN/Business-ISMN-1.110.0-r1.ebuild b/dev-perl/Business-ISMN/Business-ISMN-1.110.0-r1.ebuild
new file mode 100644
index 000000000000..cad919d5ff34
--- /dev/null
+++ b/dev-perl/Business-ISMN/Business-ISMN-1.110.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=BDFOY
+MODULE_VERSION=1.11
+inherit perl-module
+
+DESCRIPTION="International Standard Music Numbers"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Tie-Cycle
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )
+"
+
+SRC_TEST=do
+
+src_install() {
+ perl-module_src_install
+ rm -rf "${ED}"/usr/share/man || die
+}
diff --git a/dev-perl/Business-ISMN/Business-ISMN-1.130.0.ebuild b/dev-perl/Business-ISMN/Business-ISMN-1.130.0.ebuild
new file mode 100644
index 000000000000..00ce548c9d8d
--- /dev/null
+++ b/dev-perl/Business-ISMN/Business-ISMN-1.130.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=BDFOY
+MODULE_VERSION=1.13
+inherit perl-module
+
+DESCRIPTION="International Standard Music Numbers"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Tie-Cycle
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )
+"
+
+SRC_TEST=do
+
+src_install() {
+ perl-module_src_install
+ rm -rf "${ED}"/usr/share/man || die
+}
diff --git a/dev-perl/Business-ISMN/Manifest b/dev-perl/Business-ISMN/Manifest
new file mode 100644
index 000000000000..664ab9509150
--- /dev/null
+++ b/dev-perl/Business-ISMN/Manifest
@@ -0,0 +1,2 @@
+DIST Business-ISMN-1.11.tar.gz 9053 SHA256 76d5240a5672c7a8b1ba9e9ea8238a5c8882139911acbb67b7059b5ee3da342d SHA512 e5bbaf048b06ee133a95443227fe2bf0e49abbb2164330105f7ccd4360503ca97848e4ff6b663064ceb36a34d4e5f7b47209f0153e5fa6e88d8ae8a0c90bd41a WHIRLPOOL f780112fddb09ece0bd784e29cf23fca31ee135f582eabe0bbc3192efdf554bfa610d94c8d222b2eac766c0615b2ca8806e4f1f1707d9f6c6624c9bec4bae1a3
+DIST Business-ISMN-1.13.tar.gz 9703 SHA256 89b598dcde116732f8621b18660fec9a6989b1ad5bf96599b98fbcaecad9a132 SHA512 bad9fdfe16a6b62c823019af4162e0cb2f97dbda8cc5cad01ff3a6e80d22e5fa1d260ef410ad1393d03fc750f7976f06932ac948390cdeb995cc458e1d3cd984 WHIRLPOOL fe1bf9401fa4b973388028451d5cd06df8ac3ccc8887b6ef714b4a1f4e9c0e38a2c65ba8a5a500b55b59ffaa37067ad97e5724e47778a3642138cd6085c7cf55
diff --git a/dev-perl/Business-ISMN/metadata.xml b/dev-perl/Business-ISMN/metadata.xml
new file mode 100644
index 000000000000..3d758b849626
--- /dev/null
+++ b/dev-perl/Business-ISMN/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Business-ISMN</remote-id>
+ <remote-id type="cpan-module">Business::ISBM::Data</remote-id>
+ <remote-id type="cpan-module">Business::ISMN</remote-id>
+ </upstream>
+</pkgmetadata>