summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-05-01 18:06:44 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-05-01 18:06:44 +0200
commitca75ad98018f6e901c64c2935c753d81e4173278 (patch)
tree62bf1d24ff2bdc86b383ed4ccf3b49f2b22e195b /dev-perl/Cairo
parentdev-perl/Perl-LanguageServer: New package, bug 745792 (diff)
downloadgentoo-ca75ad98018f6e901c64c2935c753d81e4173278.tar.gz
gentoo-ca75ad98018f6e901c64c2935c753d81e4173278.tar.bz2
gentoo-ca75ad98018f6e901c64c2935c753d81e4173278.zip
dev-perl/Cairo: Version bump 1.109
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Cairo')
-rw-r--r--dev-perl/Cairo/Cairo-1.109.0.ebuild43
-rw-r--r--dev-perl/Cairo/Manifest1
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-perl/Cairo/Cairo-1.109.0.ebuild b/dev-perl/Cairo/Cairo-1.109.0.ebuild
new file mode 100644
index 000000000000..d8aff7bd7da4
--- /dev/null
+++ b/dev-perl/Cairo/Cairo-1.109.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=XAOC
+DIST_VERSION=1.109
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Perl interface to the cairo library"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=x11-libs/cairo-1.0.0
+"
+DEPEND="
+ >=x11-libs/cairo-1.0.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/ExtUtils-Depends-0.200.0
+ >=dev-perl/ExtUtils-PkgConfig-1.0.0
+ test? (
+ dev-perl/Test-Number-Delta
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.107-fatal-exit.patch"
+)
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
diff --git a/dev-perl/Cairo/Manifest b/dev-perl/Cairo/Manifest
index 65e1f2bf9ad0..dfa6674e2d4d 100644
--- a/dev-perl/Cairo/Manifest
+++ b/dev-perl/Cairo/Manifest
@@ -1 +1,2 @@
DIST Cairo-1.107.tar.gz 111203 BLAKE2B 17093ee7058ecf27848042d3f49a841b6d6b4be9327adb959ee0d93a10f03de9caecd172b31775847b3561470aaf0f3c72b458fe0b37d2a451df47833e0df622 SHA512 613ba59ee3bd1adc2f33be60b395148f23d1de793fde888fd417f0b0cb6631a35429ee696172e9292b7d3fecab93de8ca958c96f803b9f5a16747a6d1fc7e9cb
+DIST Cairo-1.109.tar.gz 116924 BLAKE2B 0761066948797b06dcf89adb5f0d962f4ed48ba6bc3aa0c4b99a31c4bea96f71ffe0f378a1ea27e080c099b99cf8e99896abcbd042d91da747786475a3da1bf5 SHA512 b80841bff480acf95f69659cba02ca17c79b67a2dc5c9b9302efb15bbd79bd4bc2f1801c001c220723da11081e86a08a83e07ecc8866810ebf9406e1f6fa1c53