summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2022-01-20 10:49:40 -0500
committerBrian Evans <grknight@gentoo.org>2022-01-20 11:21:14 -0500
commitbd2b1638dd10f82d76bcc0cae56b9f7554723a76 (patch)
tree2bc49b707a944a1b3f2038e7b73e46bed7b57a9d /dev-php/pecl-gnupg/pecl-gnupg-1.5.1.ebuild
parentdev-php/pecl-amqp: Drop beta and rc 1.11.0 (diff)
downloadgentoo-bd2b1638dd10f82d76bcc0cae56b9f7554723a76.tar.gz
gentoo-bd2b1638dd10f82d76bcc0cae56b9f7554723a76.tar.bz2
gentoo-bd2b1638dd10f82d76bcc0cae56b9f7554723a76.zip
dev-php/pecl-gnupg: Version bump for 1.5.1
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/pecl-gnupg/pecl-gnupg-1.5.1.ebuild')
-rw-r--r--dev-php/pecl-gnupg/pecl-gnupg-1.5.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/pecl-gnupg/pecl-gnupg-1.5.1.ebuild b/dev-php/pecl-gnupg/pecl-gnupg-1.5.1.ebuild
new file mode 100644
index 000000000000..b4e056c760fa
--- /dev/null
+++ b/dev-php/pecl-gnupg/pecl-gnupg-1.5.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+MY_P="${PN/pecl-/}-${PV/_rc/RC}"
+PHP_EXT_NAME="gnupg"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
+PHP_EXT_S="${WORKDIR}/${MY_P}"
+
+USE_PHP="php7-3 php7-4 php8-0 php8-1"
+
+inherit php-ext-pecl-r3
+
+S="${PHP_EXT_S}"
+
+KEYWORDS="~amd64 ~x86"
+DESCRIPTION="PHP wrapper around the gpgme library"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="app-crypt/gpgme app-crypt/gnupg"
+RDEPEND="${DEPEND}"