summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-19 05:10:22 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-19 05:26:36 +0100
commit81de49e3e7a95ce0d9dc617c6be2de7212b5af7d (patch)
treebebba6adc48713eead718674b465203cd74c30cb /dev-python/aiohttp
parentdev-python/starlette: Bump to 0.41.3 (diff)
downloadgentoo-81de49e3e7a95ce0d9dc617c6be2de7212b5af7d.tar.gz
gentoo-81de49e3e7a95ce0d9dc617c6be2de7212b5af7d.tar.bz2
gentoo-81de49e3e7a95ce0d9dc617c6be2de7212b5af7d.zip
dev-python/aiohttp: Bump to 3.11.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiohttp')
-rw-r--r--dev-python/aiohttp/Manifest1
-rw-r--r--dev-python/aiohttp/aiohttp-3.11.3.ebuild134
2 files changed, 135 insertions, 0 deletions
diff --git a/dev-python/aiohttp/Manifest b/dev-python/aiohttp/Manifest
index 23b25b288893..41a754241438 100644
--- a/dev-python/aiohttp/Manifest
+++ b/dev-python/aiohttp/Manifest
@@ -4,3 +4,4 @@ DIST aiohttp-3.11.0rc0.tar.gz 7621610 BLAKE2B a7ef4a7d373bd87155519bd71c396e2422
DIST aiohttp-3.11.0rc1.tar.gz 7653785 BLAKE2B 070dba6f84b7924f5129b9a022de98ef9586d35cc188a38229d77d5598cf322931687c5295f322f8aca28a8fcf7da1d30e021d4dd2b8aa9327c1c60084423480 SHA512 3ed987c6f0fe53373b5f3cb0b3858fdc216d029f8b6f205ed3fc234e2474b77fd245ad39a86f607616878499d88b607b72f68cae02f95b2073f3dc1ac3fe8d5b
DIST aiohttp-3.11.0rc2.tar.gz 7655719 BLAKE2B 3fc553c3ff927861bd280401cc6741c6bd720c4ac0827db40230270cf3bf2f30a0bfdb3d933227ffb2b22800ddc6e2d6b045277c1c8bf9fb8467b1582a3dcedb SHA512 d6f5c6ef50ce333106071dbd33d57e49be638e9d6855a9c5dc6f9b7e87063319d314f70186d7df0e09f3e7ecf4bee40da44af0dccf9124d6c6c16c5f98e9fee8
DIST aiohttp-3.11.2.tar.gz 7658216 BLAKE2B f371bfcac2fc300119d33024b4d026fa204976259becc4fdf98bf785f7658589fe3de2cae49ef71a3b299eb12a79d24048b82364c03fa09138a5a42c6daed73c SHA512 7e4dac852e47999a1e6ae47a3a124ad97ad0cb7b4a9e0b4746c0cca4156267ed0cceed86722de78550cb4ff0f54580db44318c1bd4b486e8e94ff84d98dfa56e
+DIST aiohttp-3.11.3.tar.gz 7665862 BLAKE2B a81b0b6fbc819e51d0a3bd0c7c96c403af8fe35530924ec47202ad350358ca037eebb8479bb4b6b29927c3cbea088021e4de971a392aea78dcafd2db49d24554 SHA512 4f65a4fd2191656c6e123a263557842bf91251cdb57be68e967bcee7e6678027bc1717c344e30f7c3dfe5f6fc1a75a8fccdf07056cab244fc98460ce5238d93a
diff --git a/dev-python/aiohttp/aiohttp-3.11.3.ebuild b/dev-python/aiohttp/aiohttp-3.11.3.ebuild
new file mode 100644
index 000000000000..aab347bd3181
--- /dev/null
+++ b/dev-python/aiohttp/aiohttp-3.11.3.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="HTTP client/server for asyncio"
+HOMEPAGE="
+ https://github.com/aio-libs/aiohttp/
+ https://pypi.org/project/aiohttp/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+native-extensions test-rust"
+
+RDEPEND="
+ >=dev-python/aiodns-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/aiohappyeyeballs-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/aiosignal-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/attrs-17.3.0[${PYTHON_USEDEP}]
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ >=dev-python/frozenlist-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/multidict-4.5.0[${PYTHON_USEDEP}]
+ >=dev-python/propcache-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.17.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ <dev-python/async-timeout-6[${PYTHON_USEDEP}]
+ >=dev-python/async-timeout-4.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ native-extensions? (
+ dev-python/cython[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/re-assert[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/time-machine[${PYTHON_USEDEP}]
+ ' 'python3*')
+ test-rust? (
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+DOCS=( CHANGES.rst CONTRIBUTORS.txt README.rst )
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # increase the timeout a little
+ sed -e '/abs=/s/0.001/0.01/' -i tests/test_helpers.py || die
+ # xfail_strict fails on py3.10
+ sed -i -e '/--cov/d' -e '/pytest_cov/d' -e '/xfail_strict/d' setup.cfg || die
+ sed -i -e 's:-Werror::' Makefile || die
+
+ distutils-r1_src_prepare
+}
+
+python_configure() {
+ if [[ ! -d tools && ${EPYTHON} != pypy3 ]] && use native-extensions
+ then
+ # workaround missing files
+ mkdir tools || die
+ > requirements/cython.txt || die
+ > tools/gen.py || die
+ chmod +x tools/gen.py || die
+ # force rehashing first
+ emake requirements/.hash/cython.txt.hash
+ > .update-pip || die
+ > .install-cython || die
+ emake cythonize
+ fi
+}
+
+python_compile() {
+ # implicitly disabled for pypy3
+ if ! use native-extensions; then
+ local -x AIOHTTP_NO_EXTENSIONS=1
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # proxy is not packaged
+ tests/test_proxy_functional.py
+ # python_on_whales is not packaged
+ tests/autobahn/test_autobahn.py
+ # benchmarks
+ tests/test_benchmarks_client.py
+ tests/test_benchmarks_client_request.py
+ tests/test_benchmarks_client_ws.py
+ tests/test_benchmarks_cookiejar.py
+ tests/test_benchmarks_http_websocket.py
+ tests/test_benchmarks_http_writer.py
+ tests/test_benchmarks_web_middleware.py
+ tests/test_benchmarks_web_response.py
+ tests/test_benchmarks_web_urldispatcher.py
+ )
+
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/test_client_session.py::test_client_session_timeout_zero
+ # broken by irrelevant deprecation warnings
+ tests/test_circular_imports.py::test_no_warnings
+ )
+
+ # upstream unconditionally blocks building C extensions
+ # on PyPy3 but the test suite needs an explicit switch
+ if [[ ${EPYTHON} == pypy3 ]] || ! use native-extensions; then
+ local -x AIOHTTP_NO_EXTENSIONS=1
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_mock,xdist.plugin
+ rm -rf aiohttp || die
+ epytest -m "not internal and not dev_mode" \
+ -p rerunfailures --reruns=5
+}