summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-11 19:26:48 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-11 19:26:48 +0200
commit472fcc4f6ddf55c3cd4931f7e27d89a3db8495f7 (patch)
tree27863190aa3ac36e816bc7215200b00f348b7d92 /dev-python/aws-sam-translator
parentnet-libs/libsrtp: Stabilize 2.4.2 ppc, #876700 (diff)
downloadgentoo-472fcc4f6ddf55c3cd4931f7e27d89a3db8495f7.tar.gz
gentoo-472fcc4f6ddf55c3cd4931f7e27d89a3db8495f7.tar.bz2
gentoo-472fcc4f6ddf55c3cd4931f7e27d89a3db8495f7.zip
dev-python/aws-sam-translator: Bump to 1.53.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aws-sam-translator')
-rw-r--r--dev-python/aws-sam-translator/Manifest1
-rw-r--r--dev-python/aws-sam-translator/aws-sam-translator-1.53.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/aws-sam-translator/Manifest b/dev-python/aws-sam-translator/Manifest
index 28df4f7b464c..79143504b5d9 100644
--- a/dev-python/aws-sam-translator/Manifest
+++ b/dev-python/aws-sam-translator/Manifest
@@ -1,3 +1,4 @@
DIST aws-sam-translator-1.50.0.gh.tar.gz 1103467 BLAKE2B 8d9408b7e92a5c515da47075a0722c937223e73dfa99d92d6daf91997a2edf4e1854afb88f7020fdab3457453d1c54ea77cf7e3466ec71ede36bfb3fc9c469fa SHA512 2f8f494218a1ac018893de59e7bede88b73ce446b29cc818d9309275851b080608656f69c422a9b49c885a6e6cbe7f34826f31cf4da9f2ee0667a1663dbee32a
DIST aws-sam-translator-1.51.0.gh.tar.gz 1107033 BLAKE2B be5d46fa4caa7619c0b959eeec65d0902fdb197369c84c930618398a9b4110c2b1e281c80e63c659be266bb6b2f191495c40578fde73ab31c93bd05906bd55e3 SHA512 d21f3d0b3d4947ad25811f0274e5807089a8d1e2aab76310a80a92f48cfe9ac683bcecea3c833692948f94934be5662cf7585aab0a4a949fcf368901d2e1b9a8
DIST aws-sam-translator-1.52.0.gh.tar.gz 1155351 BLAKE2B 523b7b8b31ee001da05b43a1a9ca17da30d3a4a63ebfefdd7dcb9e4a67088f8b6d51da3eefa241e4330bf901a7cd3544094d58b1b512fb8d967198a7d7b92ab0 SHA512 d6108086143d76bce810ec0276763dac944381ad22bb89f8ed5ed5197168bf9139808c5177655c6d59b57017b398cb8220acfb69d14d25883753e3b695b456f4
+DIST aws-sam-translator-1.53.0.gh.tar.gz 1158682 BLAKE2B 4bc8430936a1b180dc04637e540ecad7eb82cd7a5da5254f2b823075878a03ad3e63422c183b365b0dad927bcdf063b8ab40984ab23abe1d91d8bc3c411aa2f1 SHA512 292259bf8d4002b72be51db0358673eee61fe368be5db15e7faff195baae8fa194bef882fd0f5a9b5c46379fe5f9593d101a212121da8d0636aca709dd087f05
diff --git a/dev-python/aws-sam-translator/aws-sam-translator-1.53.0.ebuild b/dev-python/aws-sam-translator/aws-sam-translator-1.53.0.ebuild
new file mode 100644
index 000000000000..4194237c6fc3
--- /dev/null
+++ b/dev-python/aws-sam-translator/aws-sam-translator-1.53.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library that transform SAM templates into AWS CloudFormation templates"
+HOMEPAGE="
+ https://github.com/aws/serverless-application-model/
+ https://pypi.org/project/aws-sam-translator/
+"
+SRC_URI="
+ https://github.com/aws/serverless-application-model/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/serverless-application-model-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/boto3-2[${PYTHON_USEDEP}]
+ >=dev-python/boto3-1.19.5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/validator/test_validator_api.py::TestValidatorApi::test_errors_13_error_definitionuri
+ tests/unit/test_region_configuration.py::TestRegionConfiguration::test_is_service_supported_positive_4_ec2
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_transform_template_translate::test_sar_success_one_app
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_transform_template_translate::test_sar_throttling_doesnt_stop_processing
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_transform_template_translate::test_sleep_between_sar_checks
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_transform_template_translate::test_unexpected_sar_error_stops_processing
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_and_on_after_transform_template::test_time_limit_exceeds_between_combined_sar_calls
+)
+
+python_prepare_all() {
+ # remove pytest-cov dependency
+ sed -i -e '/addopts/d' pytest.ini || die
+
+ # deps are installed by ebuild, don't try to reinstall them via pip
+ truncate --size=0 requirements/*.txt || die
+
+ distutils-r1_python_prepare_all
+}