summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-28 04:50:59 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-28 05:02:58 +0100
commit6aab79c82dbc8d2e9a0d2db9dec9ac82f4bfbee4 (patch)
treea5dff1431169802c7d9db08a4f17fa9d381cd766 /dev-python/crispy-bootstrap4
parentdev-python/tekore: Bump to 5.4.0 (diff)
downloadgentoo-6aab79c82dbc8d2e9a0d2db9dec9ac82f4bfbee4.tar.gz
gentoo-6aab79c82dbc8d2e9a0d2db9dec9ac82f4bfbee4.tar.bz2
gentoo-6aab79c82dbc8d2e9a0d2db9dec9ac82f4bfbee4.zip
dev-python/crispy-bootstrap4: Bump to 2024.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/crispy-bootstrap4')
-rw-r--r--dev-python/crispy-bootstrap4/Manifest1
-rw-r--r--dev-python/crispy-bootstrap4/crispy-bootstrap4-2024.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/crispy-bootstrap4/Manifest b/dev-python/crispy-bootstrap4/Manifest
index 93eb3e0186a0..834baab14ce7 100644
--- a/dev-python/crispy-bootstrap4/Manifest
+++ b/dev-python/crispy-bootstrap4/Manifest
@@ -1 +1,2 @@
DIST crispy-bootstrap4-2023.1.gh.tar.gz 31707 BLAKE2B 0a3c4c1b86ba9701365f1fcfb90811e1f6793fb9f374a510410c460bc62a48e06b72a75330f0efd3a06e51380f457eea66f236488774c3ee6bf758510136f08b SHA512 fbbc8c6e0f4351b50b0fa3a4d2faefb0775906c995f42cf9ccd9688d4780e05877a9a53f065ad92785d135a560064809f429dbcebe9f257f65f063d9539973e8
+DIST crispy-bootstrap4-2024.1.gh.tar.gz 31818 BLAKE2B 5778544067c7c23971a410bb52556a267fed9109bee4b5a4cd7e72c9bde0888e6744c2e12aa079c92217c0b6bc0ef2709de2eae127fe92ccc92ca1acb5015aa6 SHA512 c4c4e02117a2b3cf24c9111579c20f1454c5feb8c485c954e48436354e82d0a26e34b54212fb642d010a7c370236028119e5193fdb43ff2053cabae56a01a7c2
diff --git a/dev-python/crispy-bootstrap4/crispy-bootstrap4-2024.1.ebuild b/dev-python/crispy-bootstrap4/crispy-bootstrap4-2024.1.ebuild
new file mode 100644
index 000000000000..4f779d097fda
--- /dev/null
+++ b/dev-python/crispy-bootstrap4/crispy-bootstrap4-2024.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Bootstrap4 template pack for django-crispy-forms"
+HOMEPAGE="
+ https://github.com/django-crispy-forms/crispy-bootstrap4/
+ https://pypi.org/project/crispy-bootstrap4/
+"
+SRC_URI="
+ https://github.com/django-crispy-forms/crispy-bootstrap4/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/django-4.2[${PYTHON_USEDEP}]
+ >=dev-python/django-crispy-forms-2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest