summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-28 06:56:57 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-28 06:56:57 +0200
commitf6bc74c2fff42381f6d60f4137be782a93ea30a2 (patch)
tree8a803fc940d7dae3ded7524f3b543760a92f9f32 /dev-python/django-tables2
parentdev-python/tempora: Bump to 5.5.0 (diff)
downloadgentoo-f6bc74c2fff42381f6d60f4137be782a93ea30a2.tar.gz
gentoo-f6bc74c2fff42381f6d60f4137be782a93ea30a2.tar.bz2
gentoo-f6bc74c2fff42381f6d60f4137be782a93ea30a2.zip
dev-python/django-tables2: Bump to 2.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-tables2')
-rw-r--r--dev-python/django-tables2/Manifest1
-rw-r--r--dev-python/django-tables2/django-tables2-2.6.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/django-tables2/Manifest b/dev-python/django-tables2/Manifest
index 372b24983200..2deb03483bdb 100644
--- a/dev-python/django-tables2/Manifest
+++ b/dev-python/django-tables2/Manifest
@@ -1 +1,2 @@
DIST django-tables2-2.5.3.gh.tar.gz 431016 BLAKE2B 5564cd1ea19ffd7de83f949103bb5a56f987efd1e8a0cb356a0455c2244118b60c7ef78eb8fc7e57e023007046c51b4717470ee3542e1ed8a84b65e481455e75 SHA512 61b79e9fd8c2ea69afe88d7f2dd7f7015e53a6b68800c769106214bbc5818bc4f5b30eebe2d190cd6cc3a36686978befcc9b88fb4a0a7930f5bb37c608345e30
+DIST django-tables2-2.6.0.gh.tar.gz 431368 BLAKE2B 56896a416599e6f4293202ca945bf808c99ce08c4b5f53848919c3a32590e18d867e694fe7c989fdb855a5cdaf94350199c65735078c0d312d1f4f0a556ed9ae SHA512 29cabb777ed102dfde4d24836c5952bf892c7c8e3c5e5f608e00fd1aa4eecc33c6a2b1be1fd07617b354d7de34215d501592c53033d6f48c29e89ab68fdcb22d
diff --git a/dev-python/django-tables2/django-tables2-2.6.0.ebuild b/dev-python/django-tables2/django-tables2-2.6.0.ebuild
new file mode 100644
index 000000000000..3db8a9bb8dd1
--- /dev/null
+++ b/dev-python/django-tables2/django-tables2-2.6.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Table/data-grid framework for Django"
+HOMEPAGE="
+ https://pypi.org/project/django-tables2/
+ https://github.com/jieter/django-tables2/
+"
+SRC_URI="
+ https://github.com/jieter/django-tables2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/django-filter[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ # these tests require tablib
+ rm tests/test_export.py tests/test_templatetags.py || die
+ # these tests require fudge
+ rm tests/test_config.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${EPYTHON}" manage.py test -v 2 tests || die
+}