summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-25 08:12:52 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-25 09:12:23 +0200
commitf5280034e2530c878d7d343a097f9c12841493c1 (patch)
tree0835a1603861944060eb426f901a44b507505a22 /dev-python/elementpath
parentdev-python/graphviz: Bump to 0.20.1 (diff)
downloadgentoo-f5280034e2530c878d7d343a097f9c12841493c1.tar.gz
gentoo-f5280034e2530c878d7d343a097f9c12841493c1.tar.bz2
gentoo-f5280034e2530c878d7d343a097f9c12841493c1.zip
dev-python/elementpath: Bump to 3.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/elementpath')
-rw-r--r--dev-python/elementpath/Manifest1
-rw-r--r--dev-python/elementpath/elementpath-3.0.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/elementpath/Manifest b/dev-python/elementpath/Manifest
index 0c056ce23bda..827a5040fbf7 100644
--- a/dev-python/elementpath/Manifest
+++ b/dev-python/elementpath/Manifest
@@ -1,2 +1,3 @@
DIST elementpath-2.5.3.gh.tar.gz 264387 BLAKE2B a0904e95675570783f2f8bf854490a3f424d6ce0fa85e3c2030483e9c31af4a5eaaf727db6423e17a402f55e7d42b0625a5183b543f886ec8b12426eb0e57a57 SHA512 da561446ac3a059c60480084648ebc1190d0ec1dc495dfa128dc2598d5762ae1067f39be36fc6bca466e6785aae80edf6dc1415a2885bfbb2d54b97ca6611572
DIST elementpath-3.0.0.gh.tar.gz 271802 BLAKE2B c766ab1654b89b6a1b09ed7273a65aa25bcad0e8f8188c50d2f85d852672ac650b6cee3411839f915b0fe46915bbe6c17269f0218f0de27b51e4bd48b9218c20 SHA512 171d5e19e3efeb0b80cd1dcca7a0604fff2a87a52db4570d2182ff155aaef5074517d1ee89992ea1937746481a10fdd62f317672fa7ad5014e64dc73fc39ffaf
+DIST elementpath-3.0.1.gh.tar.gz 272163 BLAKE2B dc3b46e9c01af57f6456b71062cc38cab1fb73aa3d272907b96a7144c8329a3b6925b804d7929662e083ec7f50889eb488f075a4155bb934939d6750aae29901 SHA512 bac73a3c9051fe556e47e0ac530fe45e7a66fb66c8fe51fc12d36d9f4f87d62ca28662bdafbdae68b867048fcb8a51d312b5294328f4df259d7d4d63ca35af4d
diff --git a/dev-python/elementpath/elementpath-3.0.1.ebuild b/dev-python/elementpath/elementpath-3.0.1.ebuild
new file mode 100644
index 000000000000..44481bdc806a
--- /dev/null
+++ b/dev-python/elementpath/elementpath-3.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="
+ https://github.com/sissaschool/elementpath/
+ https://pypi.org/project/elementpath/
+"
+SRC_URI="
+ https://github.com/sissaschool/elementpath/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # fails for some reason, more fit for upstream testing anyway
+ rm tests/test_typing.py || die
+ distutils-r1_src_prepare
+}