summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/fabric
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/fabric')
-rw-r--r--dev-python/fabric/Manifest3
-rw-r--r--dev-python/fabric/fabric-1.10.0-r1.ebuild67
-rw-r--r--dev-python/fabric/fabric-1.10.1.ebuild63
-rw-r--r--dev-python/fabric/fabric-1.10.2.ebuild63
-rw-r--r--dev-python/fabric/files/doc-extensions.patch13
-rw-r--r--dev-python/fabric/files/fabric-1.4.2-git_tags_docs.patch21
-rw-r--r--dev-python/fabric/metadata.xml8
7 files changed, 238 insertions, 0 deletions
diff --git a/dev-python/fabric/Manifest b/dev-python/fabric/Manifest
new file mode 100644
index 000000000000..89b337410dbd
--- /dev/null
+++ b/dev-python/fabric/Manifest
@@ -0,0 +1,3 @@
+DIST Fabric-1.10.0.tar.gz 208969 SHA256 edb2702b4655600f0a49a97e654c79f5b21490ce30f77d1313dd851f0b60335a SHA512 991341dfb3f71e938c2a2e30f5bc158be84cb1600ab64c4f7c5c49decd0a38bc57615f9e07edfbed70d9ca796592d7c1a4f7f3e25a40c4d31049015df928b2e3 WHIRLPOOL c07ba33bd6e7832fd5527ec14e206d74a6a2b983dbb49a43d972f31e15e22f9642df4809adff72f43f92fca5c1d758a4ac540ed87e22f46adc25094b2aa4ccb3
+DIST Fabric-1.10.1.tar.gz 209750 SHA256 ab9c54e9496c89ae96ed4aa669e01c792376d75a7389ec90d4292282cc26f008 SHA512 a00f46ac28c61d20575af9f34e4e2bc54a79e836c29b395bbdf58538b6c75523a7ec6f3f40caf0f270d2ec8b0500806b14e80c4ed4d2077e39f4dbdd773d8637 WHIRLPOOL 88b5865ec80ff923292b0ba4a868a06fa5cc0f68b3a8ab2fbfb68f17422b9b60a365ea3b14b5f04929425bbcf9350acbc72dc1733200c18a80d954c3c1762ce9
+DIST Fabric-1.10.2.tar.gz 212942 SHA256 666a3da92273532d3a49dd1ac53e3d721c5ec2f2512cd7dddb7ce19e29e9f038 SHA512 3102616a8fbc6237df74eb9b506e95628487d2bb112a56826d388a943b6e8af926f4f174a8d8810b27b63e58d2018667d927795c6a5e53833a1d3fc87324b0af WHIRLPOOL f08af6300432655786692a99385f4cd4d8605ac3bd952dd198706bd975c737431df7aaa6dc2d737719ca029305cb3e3359876ac32702f3ad539b65a5ad5501fb
diff --git a/dev-python/fabric/fabric-1.10.0-r1.ebuild b/dev-python/fabric/fabric-1.10.0-r1.ebuild
new file mode 100644
index 000000000000..c9e68f064073
--- /dev/null
+++ b/dev-python/fabric/fabric-1.10.0-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="Fabric"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A simple pythonic tool for remote execution and deployment"
+HOMEPAGE="http://fabfile.org http://pypi.python.org/pypi/Fabric"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/paramiko-1.10[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/python-docs-2.7.6-r1:2.7
+ dev-python/alabaster[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ <dev-python/fudge-1.0[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # Re-set intersphinx_mapping for doc build
+ if use doc; then
+ local PYTHON_DOC_ATOM=$(best_version --host-root dev-python/python-docs:2.7)
+ local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
+ local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
+ local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
+ sed -e "s|'http://docs.python.org/2.6', None|'${PYTHON_DOC}', '${PYTHON_DOC_INVENTORY}'|" \
+ -e "s| 'www'| #'www'|" \
+ -i sites/docs/conf.py || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build -b html -c sites/docs/ sites/docs/ sites/docs/html || die
+ fi
+}
+
+src_test() {
+ local DISTUTILS_NO_PARALLEL_BUILD=1
+ distutils-r1_src_test
+}
+
+python_test() {
+ nosetests tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( sites/docs/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/fabric/fabric-1.10.1.ebuild b/dev-python/fabric/fabric-1.10.1.ebuild
new file mode 100644
index 000000000000..0fae319ba275
--- /dev/null
+++ b/dev-python/fabric/fabric-1.10.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="Fabric"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A simple pythonic tool for remote execution and deployment"
+HOMEPAGE="http://fabfile.org http://pypi.python.org/pypi/Fabric"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/paramiko-1.10[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/python-docs-2.7.6-r1:2.7
+ dev-python/alabaster[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ <dev-python/fudge-1.0[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # Re-set intersphinx_mapping for doc build
+ if use doc; then
+ local PYTHON_DOC_ATOM=$(best_version --host-root dev-python/python-docs:2.7)
+ local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
+ local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
+ local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
+ sed -e "s|'http://docs.python.org/2.6', None|'${PYTHON_DOC}', '${PYTHON_DOC_INVENTORY}'|" \
+ -e "s| 'www'| #'www'|" \
+ -i sites/docs/conf.py || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build -b html -c sites/docs/ sites/docs/ sites/docs/html || die
+ fi
+}
+
+python_test() {
+ nosetests tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( sites/docs/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/fabric/fabric-1.10.2.ebuild b/dev-python/fabric/fabric-1.10.2.ebuild
new file mode 100644
index 000000000000..00b36432bd91
--- /dev/null
+++ b/dev-python/fabric/fabric-1.10.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="Fabric"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A simple pythonic tool for remote execution and deployment"
+HOMEPAGE="http://fabfile.org http://pypi.python.org/pypi/Fabric"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/paramiko-1.10[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/python-docs-2.7.6-r1:2.7
+ dev-python/alabaster[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ <dev-python/fudge-1.0[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # Re-set intersphinx_mapping for doc build
+ if use doc; then
+ local PYTHON_DOC_ATOM=$(best_version --host-root dev-python/python-docs:2.7)
+ local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
+ local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
+ local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
+ sed -e "s|'http://docs.python.org/2.6', None|'${PYTHON_DOC}', '${PYTHON_DOC_INVENTORY}'|" \
+ -e "s| 'www'| #'www'|" \
+ -i sites/docs/conf.py || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build -b html -c sites/docs/ sites/docs/ sites/docs/html || die
+ fi
+}
+
+python_test() {
+ # 1 failure, reported https://github.com/fabric/fabric/issues/1360
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( sites/docs/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/fabric/files/doc-extensions.patch b/dev-python/fabric/files/doc-extensions.patch
new file mode 100644
index 000000000000..e426d6197b36
--- /dev/null
+++ b/dev-python/fabric/files/doc-extensions.patch
@@ -0,0 +1,13 @@
+releases module cannot be found and would cause un-needed d'loading
+diff -ur Fabric-1.8.3.orig/docs/conf.py Fabric-1.8.3/docs/conf.py
+--- docs/conf.py 2014-02-15 01:28:56.000000000 +0800
++++ docs/conf.py 2014-04-09 22:55:42.851674861 +0800
+@@ -26,7 +26,7 @@
+
+ # Add any Sphinx extension module names here, as strings. They can be extensions
+ # coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
+-extensions = ['sphinx.ext.autodoc', 'releases']
++extensions = ['sphinx.ext.autodoc']
+
+ # 'releases' (changelog) settings
+ releases_issue_uri = "https://github.com/fabric/fabric/issues/%s"
diff --git a/dev-python/fabric/files/fabric-1.4.2-git_tags_docs.patch b/dev-python/fabric/files/fabric-1.4.2-git_tags_docs.patch
new file mode 100644
index 000000000000..46e9044a45c6
--- /dev/null
+++ b/dev-python/fabric/files/fabric-1.4.2-git_tags_docs.patch
@@ -0,0 +1,21 @@
+--- docs/conf.py.org 2012-05-08 02:08:14.000000000 -0400
++++ docs/conf.py 2012-05-10 10:06:28.000000000 -0400
+@@ -170,12 +170,13 @@
+ html_theme = 'default'
+ html_style = 'rtd.css'
+
+-from fabric.api import local, hide
+-with hide('everything'):
+- get_tags = 'git tag | sort -r | egrep "(1\.[^0]+)\.."'
+- fabric_tags = local(get_tags, True).split()
+-html_context = {'fabric_tags': fabric_tags}
++#from fabric.api import local, hide
++#with hide('everything'):
++# get_tags = 'git tag | sort -r | egrep "(1\.[^0]+)\.."'
++# fabric_tags = local(get_tags, True).split()
++#html_context = {'fabric_tags': fabric_tags}
+
++html_context={'fabric_tags': ['1.4.2', '1.4.1', '1.4.0', '1.3.7', '1.3.6', '1.3.5', '1.3.4', '1.3.3', '1.3.2', '1.3.1', '1.3.0', '1.2.6', '1.2.5', '1.2.4', '1.2.3', '1.2.2', '1.2.1', '1.2.0', '1.1.8', '1.1.7', '1.1.6', '1.1.5', '1.1.4', '1.1.3', '1.1.2', '1.1.1', '1.1.0']}
+
+ # Theme options are theme-specific and customize the look and feel of a theme
+ # further. For a list of options available for each theme, see the
diff --git a/dev-python/fabric/metadata.xml b/dev-python/fabric/metadata.xml
new file mode 100644
index 000000000000..d64f1992692e
--- /dev/null
+++ b/dev-python/fabric/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">Fabric</remote-id>
+ </upstream>
+</pkgmetadata>