summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-02-01 15:10:03 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-02-01 15:10:03 +0100
commit1b7c95ddc3c0693281a5208efe18780573b0a7fe (patch)
tree1e4666472c09199962ed625e75b11a8b4edc8ebb /dev-python/memory_profiler
parentdev-python/raet: Version bump to 0.6.6 (diff)
downloadgentoo-1b7c95ddc3c0693281a5208efe18780573b0a7fe.tar.gz
gentoo-1b7c95ddc3c0693281a5208efe18780573b0a7fe.tar.bz2
gentoo-1b7c95ddc3c0693281a5208efe18780573b0a7fe.zip
dev-python/memory_profiler: Version bump to 0.43
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/memory_profiler')
-rw-r--r--dev-python/memory_profiler/Manifest1
-rw-r--r--dev-python/memory_profiler/memory_profiler-0.43.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/memory_profiler/Manifest b/dev-python/memory_profiler/Manifest
index 71c4b4cfc160..418e987b29e7 100644
--- a/dev-python/memory_profiler/Manifest
+++ b/dev-python/memory_profiler/Manifest
@@ -1,3 +1,4 @@
DIST memory_profiler-0.39.tar.gz 27859 SHA256 61021f2dade7edd6cc09d7924bfdccc453bd1949608412a3e021d44a410d3a23 SHA512 aaf8bcb105bf7301af16a9f090b62177e608d93f1ec5ca51ca78005515943f216657dd316fcd60a56784dc65c879a605f9712723a810400ecc5685e01b3dcf72 WHIRLPOOL a329950674ff9f34a8152be257e282821c9282fb16b6df9484307717ac104dbbb107381bd0ccef53a35ab1391f2dbde04fb0de13c20e66c726cc7006dcc834e3
DIST memory_profiler-0.40.tar.gz 28508 SHA256 95822fc82a288f3ebc1e0e91d8e33e7f80c2a691bb2ec5e8cca555c1350c5b8f SHA512 73f9849faae430225ea1f3b43c56e8d95d535ef4a85d0ddeb92aaba6a357fef72e76aca6f661d9ff0ac26a8ae14e6adff6ef0ecad1e5d0a22d6e262e7d657b25 WHIRLPOOL e88256260d74a4e5285509e55dccad3069b8cfaa0e21a0bcf4ba63043597176a5a4b15e7ef18c79d35bc8170b1879210bc95814b6246cecdffbd6b111ffb5b38
DIST memory_profiler-0.41.tar.gz 28835 SHA256 dce6e931c281662a500b142595517d095267216472c2926e5ec8edab89898d10 SHA512 f22a4593f1edfeaa7afd1786b74df46f224e3fbfe7c40e70243d70de1c41ca3fc7614f035b2cffa93e377ca02b197d2136079d53273414ea1da47e4fd981cb65 WHIRLPOOL ce2cd6be428425e5f14e77d86a2114e84d6dacba5725aea9e37374a48a498f3ab3dc27aab2849c00584bda55ca940cb3a09bf1fb6fcf940b1770be777f033c9a
+DIST memory_profiler-0.43.tar.gz 31496 SHA256 ee2d4fb8f95b90d6faa511e46f4d117d4f17f7c62bb081f7266e9c98c23aeba4 SHA512 6c0bbece0b2a7da5504e878db3777ae86009ed3730a00527af457e4c216e7f5423feee79216bf28496374a2a597fd0cc2b267a312587ed01ac42f6ec3351eca6 WHIRLPOOL e0ac0eb1a99463fe295277768c4c97f23e7bd70f34e9d8a32b115247baa4c51b3c639e86ae24e77602aa97a648d026b36afd1c35dfda63bd7e7759bf5aeddcea
diff --git a/dev-python/memory_profiler/memory_profiler-0.43.ebuild b/dev-python/memory_profiler/memory_profiler-0.43.ebuild
new file mode 100644
index 000000000000..f26c4c718676
--- /dev/null
+++ b/dev-python/memory_profiler/memory_profiler-0.43.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module for monitoring memory usage of a python program"
+HOMEPAGE="http://pypi.python.org/pypi/memory_profiler https://github.com/fabianp/memory_profiler"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} -m memory_profiler test/test_func.py || die
+ ${EPYTHON} -m memory_profiler test/test_loop.py || die
+ ${EPYTHON} -m memory_profiler test/test_as.py || die
+ ${EPYTHON} -m memory_profiler test/test_global.py || die
+ ${EPYTHON} -m memory_profiler test/test_precision_command_line.py || die
+ ${EPYTHON} -m memory_profiler test/test_gen.py || die
+ if python_is_python3; then
+ ${EPYTHON} -m memory_profiler test/test_unicode.py || die
+ fi
+ ${PYTHON} test/test_tracemalloc.py || die
+ ${EPYTHON} test/test_import.py || die
+ ${EPYTHON} test/test_memory_usage.py || die
+ ${EPYTHON} test/test_precision_import.py || die
+}