summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-15 09:52:53 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-15 09:59:13 +0100
commit737f955030be620d890d71d66ee130a9b423afb7 (patch)
treedec40668c457956f99e75ea7874c770abb6ee0df /dev-python/mido
parentdev-python/statsmodels: Bump to 0.14.1 (diff)
downloadgentoo-737f955030be620d890d71d66ee130a9b423afb7.tar.gz
gentoo-737f955030be620d890d71d66ee130a9b423afb7.tar.bz2
gentoo-737f955030be620d890d71d66ee130a9b423afb7.zip
dev-python/mido: Bump to 1.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mido')
-rw-r--r--dev-python/mido/Manifest1
-rw-r--r--dev-python/mido/mido-1.3.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/mido/Manifest b/dev-python/mido/Manifest
index c53baa6af83f..b1b39338d4c6 100644
--- a/dev-python/mido/Manifest
+++ b/dev-python/mido/Manifest
@@ -1 +1,2 @@
DIST mido-1.3.0.tar.gz 121330 BLAKE2B bf6a20e12b609dc89600fa3b93ccf857fe9aad47ea71564773280c5cf0069b59deec3f8f7263d9949ccf0848b2b73e3e904057c3645069097a85469c8d78a391 SHA512 7e91daa704e72204af30af9c16a2e712a60794f8180c49d78de870381d50aac31029c01ae23fbb7c00947e299c1feba89622ea2648d54bd8786f497cf0a1bd20
+DIST mido-1.3.1.tar.gz 124019 BLAKE2B 0d132d3f993b0f6d663b0347c7286e5d0d6bf32fe164bc1ccdd980ebce0edb83e00e37ab1f62759111b6e3b5b32edd6b822abbec208c93abe14d884de3cf490a SHA512 a40cc8a140cbf1db815cad9b03c7f91e32292cf25aaea2b45613cbb4f1ee573847de3c8ad8bc24a8ef3cf68c01ce166881fe7156dd445b150c6f2a14e655d968
diff --git a/dev-python/mido/mido-1.3.1.ebuild b/dev-python/mido/mido-1.3.1.ebuild
new file mode 100644
index 000000000000..fc7fb16de40f
--- /dev/null
+++ b/dev-python/mido/mido-1.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="MIDI Objects, a library for working with MIDI messages and ports"
+HOMEPAGE="
+ https://pypi.org/project/mido/
+ https://github.com/mido/mido
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+portmidi rtmidi"
+
+RDEPEND="
+ >=dev-python/packaging-23.1[${PYTHON_USEDEP}]
+ portmidi? ( media-libs/portmidi )
+ rtmidi? ( dev-python/python-rtmidi[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # performance test
+ tests/midifiles/test_tracks.py::test_merge_large_midifile
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}