summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-31 06:05:14 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-31 06:05:14 +0200
commitea1a1fd27af4964f34020553b0d42d8e7c2c14cc (patch)
tree8fe9ecd362ba46496552fff93307989d9dac05ce /dev-python/nose2
parentdev-python/jupyter-server: Bump to 2.14.1 (diff)
downloadgentoo-ea1a1fd27af4964f34020553b0d42d8e7c2c14cc.tar.gz
gentoo-ea1a1fd27af4964f34020553b0d42d8e7c2c14cc.tar.bz2
gentoo-ea1a1fd27af4964f34020553b0d42d8e7c2c14cc.zip
dev-python/nose2: Bump to 0.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nose2')
-rw-r--r--dev-python/nose2/Manifest1
-rw-r--r--dev-python/nose2/nose2-0.15.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/nose2/Manifest b/dev-python/nose2/Manifest
index c34908cab7f9..cafff1507ec3 100644
--- a/dev-python/nose2/Manifest
+++ b/dev-python/nose2/Manifest
@@ -1 +1,2 @@
DIST nose2-0.14.2.tar.gz 167874 BLAKE2B b2d1d1d026de10e9d73a312205b0562c377775016b8adea0b64213cb32930e9a58823021fa970f23e8acd79d2ea2a3df1f294732fcb2f96c454a2345f65091db SHA512 728d6c3f1c037630b6b3a4fc3012a488d91dfdcef5fe1d1f6473b317f71ac6ba16a33d33721de7422caec019eac00137e95190eb2c98edd67c4c5f7f8ee09440
+DIST nose2-0.15.0.tar.gz 168825 BLAKE2B fc61b1be549cc725a05825cc801b23fa3055b13f745f63c5a1929b87724691001cf743248cb9606b6ae11b32090b99de0e583dac175141a6a6c9e5efb5a16099 SHA512 e0c1287aec4092fba55814bca8f5ac867d2ac0f9c9da15d6eb955007050b7e4beb2f211d049acc4dce9fa9990bc42468d01f2945cc358127295b60f9a5f998a6
diff --git a/dev-python/nose2/nose2-0.15.0.ebuild b/dev-python/nose2/nose2-0.15.0.ebuild
new file mode 100644
index 000000000000..5aa2066d832e
--- /dev/null
+++ b/dev-python/nose2/nose2-0.15.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Unittest with plugins"
+HOMEPAGE="
+ https://github.com/nose-devs/nose2/
+ https://pypi.org/project/nose2/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/coverage-4.4.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme \
+ dev-python/sphinx-issues
+
+python_test() {
+ "${EPYTHON}" -m nose2.__main__ -vv || die "tests failed under ${EPYTHON}"
+}