summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-26 07:59:55 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-26 09:11:42 +0200
commitb5f501fa792b0ad49a9be7f689e70609541cd908 (patch)
tree4cceb3f87be274cbef2992d4b8031588698c988d /dev-python/path-py
parentdev-python/path-py: Revert "Bump to 14.0.1" (diff)
downloadgentoo-b5f501fa792b0ad49a9be7f689e70609541cd908.tar.gz
gentoo-b5f501fa792b0ad49a9be7f689e70609541cd908.tar.bz2
gentoo-b5f501fa792b0ad49a9be7f689e70609541cd908.zip
dev-python/path-py: Bump to 14.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/path-py')
-rw-r--r--dev-python/path-py/Manifest1
-rw-r--r--dev-python/path-py/path-py-14.0.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/path-py/Manifest b/dev-python/path-py/Manifest
index 1ad0eff15273..683d18f7e33e 100644
--- a/dev-python/path-py/Manifest
+++ b/dev-python/path-py/Manifest
@@ -1,2 +1,3 @@
+DIST path-14.0.1.tar.gz 73830 BLAKE2B 7528f90708423802dbb177309b1a608bf8dd6b8b1563fcf3904a805830b1c53b76866ec8055bb8d4afda4adb88209b789aed90a33916e450748866479cad1889 SHA512 195abf3e70f3e82566653c8a1154047a8ab82b98eda09a2ae38ba8989e382fd3225fb5c772b827be54a3eafa696829afda2a0198d1bef7ee369e6dc40b0bf11c
DIST path.py-11.5.2.tar.gz 43542 BLAKE2B 6b376eebf5b9197c4a2e23ee25c8261c7a8b9428007a626bc0f7d1be71496f4abf7fc6f11cee628432304e6a684bd690d6895f325981c4dd0092bdf3c4a4a4e3 SHA512 8a76ffd7d369adb4c5cbc25f2a52c5cabe899bf59d248d217fc5a086e45438d9dfe6b65b63aa2c89edd7662a793d213662cd6726d15f5ce49dc6bdaf22425865
DIST path.py-12.0.2.tar.gz 44859 BLAKE2B c82bfd248e0e6eb21e3416c86f7a3a5fbfc5f5b327fe20da4084c53f22834013fc224bfbcf455690f53002c8f1c3e060aa0f04f3792e749dad62e51702cea348 SHA512 97971fa1e6bcdd4acf057ab4fe6cde2edb9d9d3d06dc049ea3779cae867221ae3e9d905daa1ec706f867473f738bb328b2795d3030244f8bd8ff7e8f0d5a6b2c
diff --git a/dev-python/path-py/path-py-14.0.1.ebuild b/dev-python/path-py/path-py-14.0.1.ebuild
new file mode 100644
index 000000000000..a9be9a3f748e
--- /dev/null
+++ b/dev-python/path-py/path-py-14.0.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+MY_P="path-${PV}"
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="https://pypi.org/project/path/ https://github.com/jaraco/path"
+SRC_URI="mirror://pypi/p/path/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' python3_{5,6,7} pypy3)
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ !<dev-python/pytest-shutil-1.7.0-r1
+ !<dev-python/pytest-virtualenv-1.7.0-r1"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/path-py-12.0.2-py38.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # avoid a setuptools_scm dependency
+ sed -e "s/setup_requires = setuptools_scm/version = '${PV}'/" \
+ -i setup.cfg || die
+
+ # disable fancy test deps
+ sed -e 's: --flake8:: ; s: --black:: ; s: --cov:: ; s: --mypy::' \
+ -i pytest.ini || die
+
+ # fragile test for import time
+ sed -i -e 's:test_import_time:_&:' test_path.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH=. pytest -vv || die
+}