summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-12-13 23:14:12 +0100
committerSebastian Pipping <sping@gentoo.org>2020-12-14 00:07:16 +0100
commit86c0135880121b0af5863dc742365725997e78f5 (patch)
tree683586b9d24c805a594d1e6f64813d350abcb683 /dev-python/piexif
parentdev-perl/File-ShareDir: 1.116.0 Restore ~riscv (diff)
downloadgentoo-86c0135880121b0af5863dc742365725997e78f5.tar.gz
gentoo-86c0135880121b0af5863dc742365725997e78f5.tar.bz2
gentoo-86c0135880121b0af5863dc742365725997e78f5.zip
dev-python/piexif: Fix test dependencies
Needed to drop pypy3 for -r1 because test dependency pillow doesn't support it. Will open a dedicated bug to re-add in a second. Closes: https://bugs.gentoo.org/759856 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.0, Repoman-2.3.23
Diffstat (limited to 'dev-python/piexif')
-rw-r--r--dev-python/piexif/piexif-1.1.3-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/piexif/piexif-1.1.3-r1.ebuild b/dev-python/piexif/piexif-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..8cc00f501540
--- /dev/null
+++ b/dev-python/piexif/piexif-1.1.3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit edos2unix distutils-r1
+
+DESCRIPTION="Exif manipulation with pure Python"
+HOMEPAGE="https://github.com/hMatoba/Piexif
+ https://pypi.org/project/piexif/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip
+ test? ( dev-python/pillow[jpeg,${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+PATCHES=(
+ # From https://github.com/hMatoba/Piexif/pull/109
+ "${FILESDIR}"/${P}-tests-pillow-7.2.0.patch
+)
+
+src_prepare() {
+ edos2unix tests/s_test.py # to be able to patch it
+ default
+}
+
+python_test() {
+ "${PYTHON}" setup.py test || die
+}