summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-10-04 15:28:06 -0500
committerTim Harder <radhermit@gentoo.org>2017-10-04 15:31:22 -0500
commitdb3a5a70d0520dfc37b8d1fb8357f713074b1c34 (patch)
treece4c2a33bc722bc5983fa6e9775639523070593f /dev-python/snakeoil
parentsys-auth/pam_pkcs11: treeclean (diff)
downloadgentoo-db3a5a70d0520dfc37b8d1fb8357f713074b1c34.tar.gz
gentoo-db3a5a70d0520dfc37b8d1fb8357f713074b1c34.tar.bz2
gentoo-db3a5a70d0520dfc37b8d1fb8357f713074b1c34.zip
dev-python/snakeoil: version bump to 0.7.4
Diffstat (limited to 'dev-python/snakeoil')
-rw-r--r--dev-python/snakeoil/Manifest1
-rw-r--r--dev-python/snakeoil/snakeoil-0.7.4.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/snakeoil/Manifest b/dev-python/snakeoil/Manifest
index 6933a8624209..d964b0cc7f6e 100644
--- a/dev-python/snakeoil/Manifest
+++ b/dev-python/snakeoil/Manifest
@@ -1,2 +1,3 @@
DIST snakeoil-0.7.1.tar.gz 214261 SHA256 e210db2713da8431eea6b6b3afc98bea829c6612733e6309871b2614d08dcc5b SHA512 1c0d03d50a1738cbb3cceecec9445585d089ea535657467871930cca7282d3426780451fb45774e16b05714a1da13766d68f62def7a2d957e2124bd71335d0a0 WHIRLPOOL aa20cabbceaae564802b8ed5a7a6e5dc1039d27021d477179bcad28d4317b875cbddb889e7196fc1c091a802dd28f8c7efe1c6680b170a54c5e2b07c23052623
DIST snakeoil-0.7.3.tar.gz 301229 SHA256 c51ba2e3e6f59b7988afd9ad49bf37e9b155fe4a54da3fa11fc728e02ebf5ea3 SHA512 a3b303a6b5da9e12b2eef8ffbd86bae173ef5cd8c2c2d36e818af8c228519fa44bf79c7f8122cc5e3c555f47e904dc766ceb8393dbef6f2edd9a218c7080b95e WHIRLPOOL 988c3a9eb07e251908628f4c899827b868432979759fd8a935386ed843f89cca855f1262cd88b8ba5aa1a0ad088e3942ec94d818282d086036ac03add58c0e23
+DIST snakeoil-0.7.4.tar.gz 301878 SHA256 67280c86e4b02c34100603d7525270c0017e0d182df54ad31ec2e5c145e69ceb SHA512 b3ae2223a267fa74699664470a4c4f6888cf2b68e688fe61d3acca85e00a138c3a037482ef304ee26f326cba252b473d265dcd72d0e0ab5723f4b0ed6e5e04ce WHIRLPOOL c76905b7540ad1ab2186d2ce9a75a55660eb343a1cfefc835f8012f3cf10ad706ee837a995085fa327f38de8f790cc2155c540e5b0d2a6f90a0aebbf7198c7bb
diff --git a/dev-python/snakeoil/snakeoil-0.7.4.ebuild b/dev-python/snakeoil/snakeoil-0.7.4.ebuild
new file mode 100644
index 000000000000..c037456a6ebe
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-0.7.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="misc common functionality and useful optimizations"
+HOMEPAGE="https://github.com/pkgcore/snakeoil"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+[[ ${PV} == 9999 ]] && DEPEND+=" $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' 'python3*')"
+
+python_configure_all() {
+ # disable snakeoil 2to3 caching
+ unset PY2TO3_CACHEDIR
+}
+
+python_test() {
+ esetup.py test
+}