summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-21 14:13:29 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-21 14:35:00 +0200
commit6173357146a2081d7042f67d50ee3552b7899014 (patch)
tree14b4babb22262649c49dff2edf7b962f30249eec /dev-python/testresources
parentwww-client/firefox: add 100.0.2 (diff)
downloadgentoo-6173357146a2081d7042f67d50ee3552b7899014.tar.gz
gentoo-6173357146a2081d7042f67d50ee3552b7899014.tar.bz2
gentoo-6173357146a2081d7042f67d50ee3552b7899014.zip
dev-python/testresources: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/testresources')
-rw-r--r--dev-python/testresources/testresources-2.0.1-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/testresources/testresources-2.0.1-r1.ebuild b/dev-python/testresources/testresources-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..395cd1ce312e
--- /dev/null
+++ b/dev-python/testresources/testresources-2.0.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A pyunit extension for managing expensive test resources"
+HOMEPAGE="
+ https://launchpad.net/testresources/
+ https://github.com/testing-cabal/testresources/
+ https://pypi.org/project/testresources/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+# sed \
+# -e 's:testBasicSortTests:_&:g' \
+# -i testresources/tests/test_optimising_test_suite.py || die
+ distutils-r1_python_prepare_all
+}