summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-06-04 04:16:57 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-06-04 15:30:48 -0400
commitac9b0588d9ccc601e2be8c58e37940cf4957b851 (patch)
tree43564cf47a65c3e709d3cbc24dab851f25ea7222 /dev-qt/qtwayland
parentdev-qt/qtvirtualkeyboard: add 6.8.9999 (diff)
downloadgentoo-ac9b0588d9ccc601e2be8c58e37940cf4957b851.tar.gz
gentoo-ac9b0588d9ccc601e2be8c58e37940cf4957b851.tar.bz2
gentoo-ac9b0588d9ccc601e2be8c58e37940cf4957b851.zip
dev-qt/qtwayland: add 6.8.9999
tst_client, tst_scaling, and tst_compositor failed but still early on look at what's up with these. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/qtwayland-6.8.9999.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/qtwayland-6.8.9999.ebuild b/dev-qt/qtwayland/qtwayland-6.8.9999.ebuild
new file mode 100644
index 000000000000..93ba392322f1
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-6.8.9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+IUSE="accessibility compositor gnome qml vulkan"
+
+RDEPEND="
+ dev-libs/wayland
+ ~dev-qt/qtbase-${PV}:6[accessibility=,gui,opengl,vulkan=,wayland]
+ media-libs/libglvnd
+ x11-libs/libxkbcommon
+ compositor? (
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+ )
+ gnome? (
+ ~dev-qt/qtbase-${PV}:6[dbus]
+ ~dev-qt/qtsvg-${PV}:6
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ vulkan? ( dev-util/vulkan-headers )
+"
+BDEPEND="dev-util/wayland-scanner"
+
+CMAKE_SKIP_TESTS=(
+ # segfaults for not-looked-into reasons, but not considered
+ # an issue given >=seatv5 exists since wayland-1.10 (2016)
+ tst_seatv4
+ # needs a compositor/opengl, skip the extra trouble
+ tst_surface
+ tst_xdgdecorationv1
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt6Quick)
+ $(qt_feature compositor wayland_server)
+ $(qt_feature gnome wayland_decoration_adwaita)
+ )
+
+ qt6-build_src_configure
+}
+
+src_test() {
+ # users' session setting may break tst_clientextension (bug #927030)
+ unset DESKTOP_SESSION XDG_CURRENT_DESKTOP
+ unset GNOME_DESKTOP_SESSION_ID KDE_FULL_SESSION
+
+ qt6-build_src_test
+}