summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/plist
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/plist')
-rw-r--r--dev-ruby/plist/Manifest1
-rw-r--r--dev-ruby/plist/files/plist-3.1.0-nordoc.patch28
-rw-r--r--dev-ruby/plist/metadata.xml5
-rw-r--r--dev-ruby/plist/plist-3.1.0-r1.ebuild27
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-ruby/plist/Manifest b/dev-ruby/plist/Manifest
new file mode 100644
index 000000000000..fcc370298b61
--- /dev/null
+++ b/dev-ruby/plist/Manifest
@@ -0,0 +1 @@
+DIST plist-3.1.0.gem 37888 SHA256 9ae1a010cab13bb533af87d5a1aca23958e5dae8911317244248f9c65bb30866 SHA512 d31f4f2f30cab864c42e374799ce8e85d8b0c6e10b115c28054529fa2b76c36a7ae20087a7949fb8508f9a2360c83f8f0ddec9356505afa1c8539a46cb73d352 WHIRLPOOL 500e3f494c04a293e7bc9b7a6a98023c19756b4b19e745208f052ba17bdab575f543bf7bf26b6a4ee27c30ac3a4c5bafe9cf96327306239b95383abc4ef6d6dc
diff --git a/dev-ruby/plist/files/plist-3.1.0-nordoc.patch b/dev-ruby/plist/files/plist-3.1.0-nordoc.patch
new file mode 100644
index 000000000000..30f289efae22
--- /dev/null
+++ b/dev-ruby/plist/files/plist-3.1.0-nordoc.patch
@@ -0,0 +1,28 @@
+Index: plist-3.1.0/Rakefile
+===================================================================
+--- plist-3.1.0.orig/Rakefile
++++ plist-3.1.0/Rakefile
+@@ -15,7 +15,13 @@ require 'rake/testtask'
+ require 'rake/packagetask'
+ require 'rake/gempackagetask'
+ require 'rake/contrib/rubyforgepublisher'
+-require 'rdoc/task'
++begin
++ require 'rdoc/task'
++ doctask = RDoc::Task
++rescue LoadError
++ require 'rake/rdoctask'
++ doctask = Rake::RDocTask
++end
+
+ $:.unshift(File.dirname(__FILE__) + "/lib")
+ require 'plist'
+@@ -104,7 +110,7 @@ task :update_rdoc => [ :rdoc ] do
+ end
+
+ # Genereate the RDoc documentation
+-RDoc::Task.new do |rdoc|
++doctask.new do |rdoc|
+ rdoc.title = "All-purpose Property List manipulation library"
+ rdoc.main = "README.rdoc"
+
diff --git a/dev-ruby/plist/metadata.xml b/dev-ruby/plist/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/plist/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/plist/plist-3.1.0-r1.ebuild b/dev-ruby/plist/plist-3.1.0-r1.ebuild
new file mode 100644
index 000000000000..72dd5a091dd3
--- /dev/null
+++ b/dev-ruby/plist/plist-3.1.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library to manipulate Property List files, also known as plists"
+HOMEPAGE="http://plist.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES=( "${FILESDIR}"/${P}-nordoc.patch )
+
+all_ruby_prepare() {
+ sed -e '/gempackagetask/ s:^:#:' \
+ -e '/GemPackageTask/,/end/ s:^:#:' \
+ -i Rakefile || die
+}