summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-28 21:13:30 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-28 21:13:56 +0200
commit021a15b57d353e418bec3e4ebdc85fb3d5d2f029 (patch)
tree2d86835558f2e6dfa9402958e35d927dd74db699 /dev-util/pkgcheck/pkgcheck-9999.ebuild
parentdev-perl/Test-Portability-Files: Version bump 0.10 (diff)
downloadgentoo-021a15b57d353e418bec3e4ebdc85fb3d5d2f029.tar.gz
gentoo-021a15b57d353e418bec3e4ebdc85fb3d5d2f029.tar.bz2
gentoo-021a15b57d353e418bec3e4ebdc85fb3d5d2f029.zip
dev-util/pkgcheck: Add missing test deps
Closes: https://bugs.gentoo.org/810820 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/pkgcheck/pkgcheck-9999.ebuild')
-rw-r--r--dev-util/pkgcheck/pkgcheck-9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-util/pkgcheck/pkgcheck-9999.ebuild b/dev-util/pkgcheck/pkgcheck-9999.ebuild
index 9a255efb0571..5cce16c33f18 100644
--- a/dev-util/pkgcheck/pkgcheck-9999.ebuild
+++ b/dev-util/pkgcheck/pkgcheck-9999.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_IN_SOURCE_BUILD=1
inherit distutils-r1 optfeature
@@ -37,7 +38,11 @@ RDEPEND+="
>=dev-python/tree-sitter-0.19.0[${PYTHON_USEDEP}]
"
BDEPEND="
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
"
distutils_enable_tests setup.py