summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-04-08 21:59:30 -0400
committerMatt Turner <mattst88@gentoo.org>2023-04-08 22:10:20 -0400
commit6e7f7a33697e2334e8457e9e29661486ca6b2033 (patch)
tree07b00b4aac91d17cd41e6d16a89f5f08a08fe393 /dev-util/wayland-scanner
parentwww-plugins/browserpass: Version bump to 3.1.0 (diff)
downloadgentoo-6e7f7a33697e2334e8457e9e29661486ca6b2033.tar.gz
gentoo-6e7f7a33697e2334e8457e9e29661486ca6b2033.tar.bz2
gentoo-6e7f7a33697e2334e8457e9e29661486ca6b2033.zip
dev-util/wayland-scanner: Version bump to 1.22.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/wayland-scanner')
-rw-r--r--dev-util/wayland-scanner/Manifest1
-rw-r--r--dev-util/wayland-scanner/wayland-scanner-1.22.0.ebuild44
-rw-r--r--dev-util/wayland-scanner/wayland-scanner-9999.ebuild2
3 files changed, 46 insertions, 1 deletions
diff --git a/dev-util/wayland-scanner/Manifest b/dev-util/wayland-scanner/Manifest
index b1576035cfe9..49599048a0b7 100644
--- a/dev-util/wayland-scanner/Manifest
+++ b/dev-util/wayland-scanner/Manifest
@@ -1 +1,2 @@
DIST wayland-1.21.0.tar.xz 225936 BLAKE2B 2b43eb1517d476bb2b4daed1083373655b57d047968fdb93dbbbbe4235af12e25557627e30b5c3d2575bac4beaf1e0a0b8ef10a3c673538d9097501f33c05836 SHA512 5575216d30fdf5c63caa6bcad071e15f2a4f3acb12df776806073f65db37a50b5b5b3cc7957c5497636f4ac01893e2eaab26e453ded44b287acde01762f5fdc3
+DIST wayland-1.22.0.tar.xz 229544 BLAKE2B b0bb366e7f3494813d1574228ae5dd48eccde035120d6dd8709e3a24738681ab9dd9ba6a13924b6a35982d331fa8911fa7346911da9f618be9c9109da0288629 SHA512 fb1974efc8433e97254eb83fe28974198f2b4d8246418eb3d34ce657055461e0c97bc06dd52e5066ae91bbe05bac611dc49a0937ba226ac6388d5a47241efb12
diff --git a/dev-util/wayland-scanner/wayland-scanner-1.22.0.ebuild b/dev-util/wayland-scanner/wayland-scanner-1.22.0.ebuild
new file mode 100644
index 000000000000..10efdab1bcfc
--- /dev/null
+++ b/dev-util/wayland-scanner/wayland-scanner-1.22.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/wayland.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wayland/wayland/-/releases/${PV}/downloads/wayland-${PV}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ S="${WORKDIR}/wayland-${PV}"
+fi
+inherit meson
+
+DESCRIPTION="wayland-scanner tool"
+HOMEPAGE="https://wayland.freedesktop.org/ https://gitlab.freedesktop.org/wayland/wayland"
+
+LICENSE="MIT"
+SLOT="0"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ !<dev-libs/wayland-${PV}
+ >=dev-libs/expat-2.1.0-r3
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocumentation=false
+ -Ddtd_validation=false
+ -Dlibraries=false
+ -Dscanner=true
+ -Dtests=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ mv "${ED}"/usr/$(get_libdir)/pkgconfig "${ED}"/usr/share/pkgconfig
+}
diff --git a/dev-util/wayland-scanner/wayland-scanner-9999.ebuild b/dev-util/wayland-scanner/wayland-scanner-9999.ebuild
index a71f5f47ad48..10efdab1bcfc 100644
--- a/dev-util/wayland-scanner/wayland-scanner-9999.ebuild
+++ b/dev-util/wayland-scanner/wayland-scanner-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8