summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/jumpnbump
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/jumpnbump')
-rw-r--r--games-arcade/jumpnbump/Manifest2
-rw-r--r--games-arcade/jumpnbump/jumpnbump-1.50-r1.ebuild54
-rw-r--r--games-arcade/jumpnbump/metadata.xml8
3 files changed, 64 insertions, 0 deletions
diff --git a/games-arcade/jumpnbump/Manifest b/games-arcade/jumpnbump/Manifest
new file mode 100644
index 000000000000..ff0d03120d99
--- /dev/null
+++ b/games-arcade/jumpnbump/Manifest
@@ -0,0 +1,2 @@
+DIST jumpnbump-1.50-autotool.patch.bz2 94692 SHA256 0fa9173293a893187b1e01086d296c04eaafa619be24d3b87d94b33f7d557462 SHA512 3749f3bda969d9ab2225019d8a6333d23402c8e284c3278aad23f76d5436326fed1efcae28a8922f814e0cf8417ea20fc51abb34f70bd6d37afca803475214fa WHIRLPOOL 51cbe8df33836547a1c0200392c2eeb6097e9ee276bfe291408527c3e91d10956e938bc9b693f4045720dcfd2a292c27a13ea7b21c119663f61feafd1d51e126
+DIST jumpnbump-1.50.tar.gz 397208 SHA256 b208bae76b07d7f39740bbbd385927e51cd821187c3e89270208710210dca8f3 SHA512 a343e514efa42aacd2c0fd113269ebf27418ea851dad21cecfa16a765639cc6a5de43fbdb9ad2f0282740f369b7e457a236fc3e918b486af10222c733f5c8fb0 WHIRLPOOL 78484a4eacd583127a9aaf9ec143ea81f4618108fc2d7228ebef450ce8cad231ba6e4613c20499e65f7c381bceada0401d3e86de28cb5cd4153b31190ad50754
diff --git a/games-arcade/jumpnbump/jumpnbump-1.50-r1.ebuild b/games-arcade/jumpnbump/jumpnbump-1.50-r1.ebuild
new file mode 100644
index 000000000000..de3753bf796f
--- /dev/null
+++ b/games-arcade/jumpnbump/jumpnbump-1.50-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils games
+
+DESCRIPTION="a funny multiplayer game about cute little fluffy bunnies"
+HOMEPAGE="http://www.jumpbump.mine.nu/"
+SRC_URI="
+ http://www.jumpbump.mine.nu/port/${P}.tar.gz
+ mirror://gentoo/${P}-autotool.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="X fbcon kde svga tk +music"
+
+DEPEND="
+ media-libs/sdl-mixer
+ media-libs/libsdl[sound,joystick,video]
+ media-libs/sdl-net
+ X? ( x11-libs/libXext )
+ kde? ( kde-apps/kdialog )
+ music? ( media-libs/sdl-mixer[mod] )
+"
+RDEPEND="${DEPEND}
+ tk? (
+ dev-lang/tcl:0=
+ dev-lang/tk:0=
+ )"
+
+src_prepare() {
+ epatch ../${P}-autotool.patch
+ rm -f configure
+ eautoreconf
+ sed -i \
+ -e "/PREFIX/ s:PREFIX.*:\"${GAMES_DATADIR}/${PN}/jumpbump.dat\":" \
+ globals.h \
+ || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ # clean up a bit. It leaves a dep on Xdialog but ignore that.
+ use fbcon || rm -f "${D}${GAMES_BINDIR}/jumpnbump.fbcon"
+ use kde || rm -f "${D}${GAMES_BINDIR}/jumpnbump-kdialog"
+ use svga || rm -f "${D}${GAMES_BINDIR}/jumpnbump.svgalib"
+ use tk || rm -f "${D}${GAMES_BINDIR}/jnbmenu.tcl"
+ newicon sdl/jumpnbump64.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Jump n Bump"
+ prepgamesdirs
+}
diff --git a/games-arcade/jumpnbump/metadata.xml b/games-arcade/jumpnbump/metadata.xml
new file mode 100644
index 000000000000..658a1ecd0c6d
--- /dev/null
+++ b/games-arcade/jumpnbump/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<use>
+ <flag name="music">Enable playing of background music</flag>
+</use>
+</pkgmetadata>