summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-07-24 08:09:57 +0100
committerSam James <sam@gentoo.org>2024-07-24 08:09:57 +0100
commit8b3738e86054758f9f325eca67cc371448ce3ba1 (patch)
treee80e12d6872a2274261a4b76d7ed2c2f8043f54d /games-simulation/openttd
parentgames-simulation/openttd: fix build w/ gcc-15 (diff)
downloadgentoo-8b3738e86054758f9f325eca67cc371448ce3ba1.tar.gz
gentoo-8b3738e86054758f9f325eca67cc371448ce3ba1.tar.bz2
gentoo-8b3738e86054758f9f325eca67cc371448ce3ba1.zip
games-simulation/openttd: drop 13.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-simulation/openttd')
-rw-r--r--games-simulation/openttd/Manifest1
-rw-r--r--games-simulation/openttd/openttd-13.3.ebuild134
2 files changed, 0 insertions, 135 deletions
diff --git a/games-simulation/openttd/Manifest b/games-simulation/openttd/Manifest
index c18777a14612..f79a14b6fda2 100644
--- a/games-simulation/openttd/Manifest
+++ b/games-simulation/openttd/Manifest
@@ -1,2 +1 @@
-DIST openttd-13.3-source.tar.xz 7417568 BLAKE2B dbeacb0e40af76feda5fd9946a63267e4ce9f342be4479bca24e04be7dbf05453184396e2b78f62ee045d636f70f5969ee1b1f045c68961a80875f7788a570d2 SHA512 bb91755f65bd3c3f4716b6722f29bc63633e04557d427cb224f4c3aecdbd3744df4921aba3872966fc587541fe2cdaa2fd80891236a9c87826cea0a6865e2318
DIST openttd-13.4-source.tar.xz 7428012 BLAKE2B 0ef635e40fe47185168bd13e4b8ce24a8ff9c4afe3eced6197298986127ee196a6dcb379643bbb1de9bb552e71cda5df5b5b35006ed2b43d6e33e8513b1cd550 SHA512 84f57a39c0dade44f0e6153dff7a40eec0da8e2f892ce870d5f9e037f80daa5c7c46ff786fa51c3671366dd5056504cd7ccbc1c4e5bce8b2c5575533b454c001
diff --git a/games-simulation/openttd/openttd-13.3.ebuild b/games-simulation/openttd/openttd-13.3.ebuild
deleted file mode 100644
index 20010db20802..000000000000
--- a/games-simulation/openttd/openttd-13.3.ebuild
+++ /dev/null
@@ -1,134 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake xdg
-
-DESCRIPTION="A clone of Transport Tycoon Deluxe"
-HOMEPAGE="https://www.openttd.org/"
-SRC_URI="https://cdn.openttd.org/openttd-releases/${PV}/${P}-source.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-IUSE="allegro cpu_flags_x86_sse debug dedicated +fluidsynth icu +lzma lzo +openmedia +png +sdl timidity +truetype +zlib"
-REQUIRED_USE="!dedicated? ( || ( allegro sdl ) )"
-
-# TODO: On master (after 13.x):
-# - icu-layoutex is gone (https://github.com/OpenTTD/OpenTTD/commit/81d4fa69990abbc18bd83d60658b0eedd66b7447)
-# - icu-le-hb looks like it might be too (https://github.com/OpenTTD/OpenTTD/issues/6922)
-RDEPEND="
- dedicated? (
- acct-group/openttd
- acct-user/openttd
- app-misc/dtach
- )
- !dedicated? (
- allegro? ( media-libs/allegro:5 )
- fluidsynth? ( media-sound/fluidsynth )
- icu? (
- dev-libs/icu-layoutex:=
- dev-libs/icu-le-hb
- >=dev-libs/icu-58.1:=
- )
- sdl? ( media-libs/libsdl2[sound,video] )
- truetype? (
- media-libs/fontconfig
- media-libs/freetype:2
- sys-libs/zlib:=
- )
- )
- lzma? ( app-arch/xz-utils )
- lzo? ( dev-libs/lzo:2 )
- png? ( media-libs/libpng:= )
- zlib? ( sys-libs/zlib:= )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- >=games-util/grfcodec-6.0.6_p20210310
- virtual/pkgconfig
-"
-PDEPEND="
- !dedicated? (
- openmedia? (
- >=games-misc/openmsx-0.4.0
- >=games-misc/opensfx-1.0.1
- )
- )
- openmedia? ( >=games-misc/opengfx-0.6.1 )
- timidity? ( media-sound/timidity++ )
-"
-
-DOCS=( docs/directory_structure.md )
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.11.2_dont_compress_man.patch"
-)
-
-src_prepare() {
- # Drop automagic LTO usage
- sed -i -e '/check_ipo_supported(RESULT IPO_FOUND)/d' CMakeLists.txt || die
-
- # Don't force _FORTIFY_SOURCE via CMake
- # (we already set it in the toolchain by default with a minimum level
- # of _FORTIFY_SOURCE=2)
- sed -i -e '/-D_FORTIFY_SOURCE/d' cmake/CompileFlags.cmake || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_INSTALL_BINDIR=bin
- -DCMAKE_INSTALL_DATADIR=share
- -DOPTION_DEDICATED=$(usex dedicated)
- -DOPTION_USE_ASSERTS=$(usex debug)
- -DCMAKE_DISABLE_FIND_PACKAGE_Allegro=$(usex !allegro)
- -DCMAKE_DISABLE_FIND_PACKAGE_Freetype=$(usex !truetype)
- -DCMAKE_DISABLE_FIND_PACKAGE_Fontconfig=$(usex !truetype)
- -DCMAKE_DISABLE_FIND_PACKAGE_Fluidsynth=$(usex !fluidsynth)
- -DCMAKE_DISABLE_FIND_PACKAGE_ICU=$(usex !icu)
- -DCMAKE_DISABLE_FIND_PACKAGE_LibLZMA=$(usex !lzma)
- -DCMAKE_DISABLE_FIND_PACKAGE_LZO=$(usex !lzo)
- -DCMAKE_DISABLE_FIND_PACKAGE_PNG=$(usex !png)
- # N.B. regarding #807364 and #828984: CMAKE_DISABLE_FIND_PACKAGE_SDL is used only
- # with USE="allegro -sdl" combination flags. There no other way to
- # completely disable SDL1 support.
- -DCMAKE_DISABLE_FIND_PACKAGE_SDL=ON
- -DCMAKE_DISABLE_FIND_PACKAGE_SDL2=$(usex !sdl)
- -DCMAKE_DISABLE_FIND_PACKAGE_SSE=$(usex !cpu_flags_x86_sse)
- -DCMAKE_DISABLE_FIND_PACKAGE_ZLIB=$(usex !zlib)
- )
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- if use dedicated ; then
- newconfd "${FILESDIR}"/openttd.confd-r1 openttd
- newinitd "${FILESDIR}"/openttd.initd-r3 openttd
- fi
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- if ! use openmedia ; then
- elog
- elog "OpenTTD was compiled without the 'openmedia' USE flag."
- elog
- elog "In order to play, you must at least install"
- elog "games-misc/opengfx, and games-misc/opensfx, or copy the "
- elog "following 6 files from a version of Transport Tycoon Deluxe"
- elog "(Windows or DOS) to shared or personal location."
- elog "See ${EROOT}/usr/share/doc/${PF}/directory_structure.md for more info."
- elog
- elog "From the Windows version you need: "
- elog "sample.cat trg1r.grf trgcr.grf trghr.grf trgir.grf trgtr.grf"
- elog "OR from the DOS version you need: "
- elog "SAMPLE.CAT TRG1.GRF TRGC.GRF TRGH.GRF TRGI.GRF TRGT.GRF"
- fi
-}