summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-12-21 10:49:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-21 10:58:28 +0100
commitec69b2fc143f28426a3db59160b157f5cc2c2b5f (patch)
tree67d7e056c2492ff81aa8aff4df0e53ef777c5ec1 /games-util
parentdev-lang/elixir: bump up to 1.5.3 (diff)
downloadgentoo-ec69b2fc143f28426a3db59160b157f5cc2c2b5f.tar.gz
gentoo-ec69b2fc143f28426a3db59160b157f5cc2c2b5f.tar.bz2
gentoo-ec69b2fc143f28426a3db59160b157f5cc2c2b5f.zip
games-util/qjoypad: 4.3.0 version bump
Bug: https://bugs.gentoo.org/623602 Thanks-to: maurerpe <junk4me46806@yahoo.com> Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'games-util')
-rw-r--r--games-util/qjoypad/Manifest1
-rw-r--r--games-util/qjoypad/qjoypad-4.3.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/games-util/qjoypad/Manifest b/games-util/qjoypad/Manifest
index 2d6f2f7529d7..4a852f20a766 100644
--- a/games-util/qjoypad/Manifest
+++ b/games-util/qjoypad/Manifest
@@ -1 +1,2 @@
DIST qjoypad-4.1.0.tar.gz 82306 BLAKE2B dbacfae302d07afc0e34d9c7d1511d7f0bc89accc7c58d673682434cca664232c7e5004302bf827bef6bc05d32e9a631d900ed6cdef0108a65b36328858b67dc SHA512 c14705aa24ead7c358dc2c82284ae5145df4eb041f47d4a017391346719b6330a8a1146e37ebd1f5d25d755385b611965b94b5835f9df0f6b2ef5e6a4ea3bc7b
+DIST v4.3.0.tar.gz 89134 BLAKE2B f035ac024176e352f2c0f88f0677cb4f30e643f64fd2f1214808c0273b0db8cf0a8b133e216b39fddf0ed9717c3e18955357e459ff30c494176ea7cf979b6943 SHA512 99febfc67fff149c476fffeed47eddd9e626e448afcb179eadc8dbe071da42ac692d153f3f43419c4280265527f5e84ede72cb4d59ba574819f7755e3d090e51
diff --git a/games-util/qjoypad/qjoypad-4.3.0.ebuild b/games-util/qjoypad/qjoypad-4.3.0.ebuild
new file mode 100644
index 000000000000..690f1076245f
--- /dev/null
+++ b/games-util/qjoypad/qjoypad-4.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils desktop
+
+DESCRIPTION="Translate gamepad/joystick input into key strokes/mouse actions in X"
+HOMEPAGE="https://github.com/panzi/qjoypad"
+SRC_URI="https://github.com/panzi/qjoypad/archive/v${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ virtual/libudev
+ x11-libs/libxcb
+ x11-libs/libXtst
+"
+DEPEND="${RDEPEND}
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+
+src_install() {
+ cmake-utils_src_install
+
+ local i
+ dodoc README.md
+ cd icons
+ for i in *.png; do
+ newicon ${i} ${i/gamepad/qjoypad}
+ done
+ make_desktop_entry ${PN} QJoypad ${PN}
+}