summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-base/orbit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-base/orbit')
-rw-r--r--gnome-base/orbit/Manifest1
-rw-r--r--gnome-base/orbit/files/orbit-2.14.19-aix-func_data.patch99
-rw-r--r--gnome-base/orbit/files/orbit-2.14.19-automake-1.13.patch22
-rw-r--r--gnome-base/orbit/files/orbit-2.14.19-fPIC.patch46
-rw-r--r--gnome-base/orbit/files/orbit-2.14.19-link_protocol_is_local.patch29
-rw-r--r--gnome-base/orbit/files/orbit-2.14.19-parallel-build.patch25
-rw-r--r--gnome-base/orbit/metadata.xml9
-rw-r--r--gnome-base/orbit/orbit-2.14.19-r4.ebuild84
8 files changed, 315 insertions, 0 deletions
diff --git a/gnome-base/orbit/Manifest b/gnome-base/orbit/Manifest
new file mode 100644
index 000000000000..38d038e18d5d
--- /dev/null
+++ b/gnome-base/orbit/Manifest
@@ -0,0 +1 @@
+DIST ORBit2-2.14.19.tar.bz2 764820 SHA256 55c900a905482992730f575f3eef34d50bda717c197c97c08fa5a6eafd857550 SHA512 313e125234e8d1195be277ad125af169f12ce312cb541a4641c5d57d3c905bbdc6a46672a86a012409cf4d7af58b5122f0e5db250730b65e8d95b2d5f4c4657e WHIRLPOOL ed9dffba86ab5a5409fbdfcbe8017ae3251ca261aa57b3ee1089ddfad0422f73e848ed72d3881d664ffe88a3582a8c4652394517ab814c4f0983d446891a1306
diff --git a/gnome-base/orbit/files/orbit-2.14.19-aix-func_data.patch b/gnome-base/orbit/files/orbit-2.14.19-aix-func_data.patch
new file mode 100644
index 000000000000..b58fd00a10b8
--- /dev/null
+++ b/gnome-base/orbit/files/orbit-2.14.19-aix-func_data.patch
@@ -0,0 +1,99 @@
+From c50f193f69f9b14dd26fafb7cb4c9514eaa6f15e Mon Sep 17 00:00:00 2001
+From: Michael Haubenwallner <michael.haubenwallner@ssi-schaefer.com>
+Date: Thu, 26 Jun 2014 12:45:18 +0200
+Subject: [PATCH 1/2] bug#732275: rename func_data to gfunc_data for AIX
+
+---
+ include/orbit/orb-core/allocators.h | 2 +-
+ src/idl-compiler/orbit-idl-utils.c | 14 +++++++-------
+ src/idl-compiler/orbit-idl2.h | 4 ++--
+ 3 files changed, 10 insertions(+), 10 deletions(-)
+
+diff --git a/include/orbit/orb-core/allocators.h b/include/orbit/orb-core/allocators.h
+index 0401a15..1861ca1 100644
+--- a/include/orbit/orb-core/allocators.h
++++ b/include/orbit/orb-core/allocators.h
+@@ -41,7 +41,7 @@ gpointer ORBit_realloc_tcval (gpointer old,
+ Below, some magic values of the fnc ptr are defined.
+ **/
+ typedef gpointer (*ORBit_Mem_free_fn) (gpointer mem,
+- gpointer func_data);
++ gpointer gfunc_data);
+
+ #define ORBIT_MEMHOW_HOW(how) ((how) & 0x3)
+ #define ORBIT_MEMHOW_ELEMENTS(how) ((how) >> 2)
+diff --git a/src/idl-compiler/orbit-idl-utils.c b/src/idl-compiler/orbit-idl-utils.c
+index 3bb0467..04fe4a2 100644
+--- a/src/idl-compiler/orbit-idl-utils.c
++++ b/src/idl-compiler/orbit-idl-utils.c
+@@ -362,7 +362,7 @@ orbit_idl_print_node(IDL_tree node, int indent_level)
+
+ static void
+ IDL_tree_traverse_helper(IDL_tree p, GFunc f,
+- gconstpointer func_data,
++ gconstpointer gfunc_data,
+ GHashTable *visited_nodes,
+ gboolean include_self)
+ {
+@@ -376,17 +376,17 @@ IDL_tree_traverse_helper(IDL_tree p, GFunc f,
+ for (curitem = IDL_INTERFACE (p).inheritance_spec; curitem;
+ curitem = IDL_LIST (curitem).next) {
+ IDL_tree_traverse_helper (IDL_get_parent_node
+- (IDL_LIST (curitem).data, IDLN_INTERFACE, NULL), f, func_data, visited_nodes, TRUE);
++ (IDL_LIST (curitem).data, IDLN_INTERFACE, NULL), f, gfunc_data, visited_nodes, TRUE);
+ }
+
+ if (include_self)
+- f(p, (gpointer)func_data);
++ f(p, (gpointer)gfunc_data);
+ }
+
+ void
+ IDL_tree_traverse_parents_full (IDL_tree p,
+ GFunc f,
+- gconstpointer func_data,
++ gconstpointer gfunc_data,
+ gboolean include_self)
+ {
+ GHashTable *visited_nodes = g_hash_table_new (NULL, g_direct_equal);
+@@ -400,7 +400,7 @@ IDL_tree_traverse_parents_full (IDL_tree p,
+ if (!p)
+ return;
+
+- IDL_tree_traverse_helper (p, f, func_data, visited_nodes, include_self);
++ IDL_tree_traverse_helper (p, f, gfunc_data, visited_nodes, include_self);
+
+ g_hash_table_destroy (visited_nodes);
+ }
+@@ -408,9 +408,9 @@ IDL_tree_traverse_parents_full (IDL_tree p,
+ void
+ IDL_tree_traverse_parents (IDL_tree p,
+ GFunc f,
+- gconstpointer func_data)
++ gconstpointer gfunc_data)
+ {
+- IDL_tree_traverse_parents_full (p, f, func_data, TRUE);
++ IDL_tree_traverse_parents_full (p, f, gfunc_data, TRUE);
+ }
+
+ /* For use by below function */
+diff --git a/src/idl-compiler/orbit-idl2.h b/src/idl-compiler/orbit-idl2.h
+index b58f57f..670e072 100644
+--- a/src/idl-compiler/orbit-idl2.h
++++ b/src/idl-compiler/orbit-idl2.h
+@@ -16,10 +16,10 @@ void orbit_idl_print_node (IDL_tree node,
+ int indent_level);
+ void IDL_tree_traverse_parents (IDL_tree p,
+ GFunc f,
+- gconstpointer func_data);
++ gconstpointer gfunc_data);
+ void IDL_tree_traverse_parents_full (IDL_tree p,
+ GFunc f,
+- gconstpointer func_data,
++ gconstpointer gfunc_data,
+ gboolean include_self);
+ gboolean orbit_cbe_type_contains_complex (IDL_tree ts);
+ void orbit_idl_check_oneway_op (IDL_tree op);
+--
+1.8.3.2
+
diff --git a/gnome-base/orbit/files/orbit-2.14.19-automake-1.13.patch b/gnome-base/orbit/files/orbit-2.14.19-automake-1.13.patch
new file mode 100644
index 000000000000..fcfeefba08cb
--- /dev/null
+++ b/gnome-base/orbit/files/orbit-2.14.19-automake-1.13.patch
@@ -0,0 +1,22 @@
+ test/everything/Makefile.am | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/test/everything/Makefile.am b/test/everything/Makefile.am
+index 32beb36..1eef7ac 100644
+--- a/test/everything/Makefile.am
++++ b/test/everything/Makefile.am
+@@ -73,12 +73,12 @@ server_DEPENDENCIES=${EVERYTHING_BUILT} $(included_src)
+
+ IDL_FLAGS= --showcpperrors --add-imodule
+ IDL_FILES= everything.idl
+-include $(top_srcdir)/Makefile.shared
++include ../../Makefile.shared
+
+ BUILT_SOURCES = ${EVERYTHING_BUILT} everything-imodule.c
+ CLEANFILES = ${BUILT_SOURCES} iorfile
+
+-TESTS = $(srcdir)/test.sh
++TESTS = test.sh
+
+ EXTRA_DIST = $(IDL_FILES) test.sh $(included_src)
+
diff --git a/gnome-base/orbit/files/orbit-2.14.19-fPIC.patch b/gnome-base/orbit/files/orbit-2.14.19-fPIC.patch
new file mode 100644
index 000000000000..394919f98568
--- /dev/null
+++ b/gnome-base/orbit/files/orbit-2.14.19-fPIC.patch
@@ -0,0 +1,46 @@
+From 31236105deaa4b50a70aa256819bfc4790f705d8 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Sun, 3 Mar 2013 13:29:24 -0500
+Subject: [PATCH] Add an option to build libname-server-2.a's objects as PIC
+
+Needed for Gentoo hardened, see https://bugs.gentoo.org/show_bug.cgi?id=312161
+---
+ configure.in | 9 +++++++++
+ src/services/name/Makefile.am | 1 +
+ 2 files changed, 10 insertions(+)
+
+diff --git a/configure.in b/configure.in
+index 0879051..38b7b8b 100644
+--- a/configure.in
++++ b/configure.in
+@@ -118,6 +118,15 @@ if test z$enable_purify = zyes; then
+ AC_DEFINE(ORBIT_PURIFY, 1, [defined if purify is enabled])
+ fi
+
++AC_ARG_ENABLE([libname-server-pic],
++ [AS_HELP_STRING([--enable-libname-server-pic], [force libname-server-2.a to be built as PIC])])
++if test x$enable_libname_server_pic = xyes; then
++ LIBNAME_SERVER_PIC=$lt_prog_compiler_pic
++else
++ LIBNAME_SERVER_PIC=
++fi
++AC_SUBST(LIBNAME_SERVER_PIC)
++
+ AC_MSG_CHECKING(which idl compiler to use)
+ IDL_COMPILER="\$(top_builddir)/src/idl-compiler/orbit-idl-2\$(EXEEXT)"
+ AC_ARG_WITH(idl-compiler,
+diff --git a/src/services/name/Makefile.am b/src/services/name/Makefile.am
+index 7212557..21b7365 100644
+--- a/src/services/name/Makefile.am
++++ b/src/services/name/Makefile.am
+@@ -65,6 +65,7 @@ name_client_2_LDADD = $(LDADDS)
+ libname_server_2_a_SOURCES = orbit-name-server.c CosNaming-skels.c \
+ name-support.c name-support.h
+ libname_server_2_a_DEPENDENCIES = $(DEPS) CosNaming.h
++libname_server_2_a_CFLAGS = $(INCLUDES) $(LIBNAME_SERVER_PIC)
+
+ orbit_name_server_2_SOURCES = boot.c
+ orbit_name_server_2_LDFLAGS = $(FLAGS)
+--
+1.8.1.5
+
diff --git a/gnome-base/orbit/files/orbit-2.14.19-link_protocol_is_local.patch b/gnome-base/orbit/files/orbit-2.14.19-link_protocol_is_local.patch
new file mode 100644
index 000000000000..2344935f46d2
--- /dev/null
+++ b/gnome-base/orbit/files/orbit-2.14.19-link_protocol_is_local.patch
@@ -0,0 +1,29 @@
+From 8b9acc9bd4ac9be12317f24c7ecafc4200e19609 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Tue, 12 Feb 2013 00:27:41 -0500
+Subject: [PATCH] Fix link_protocol_is_local_ipv46 for ipv4 on some
+ ipv6-enabled machines
+
+Ensure that saddr is compared to an ipv4 local_addr, not to an ipv6 one,
+by setting hints.ai_family before calling getaddrinfo().
+
+https://bugzilla.gnome.org/show_bug.cgi?id=693636
+---
+ linc2/src/linc-protocols.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/linc2/src/linc-protocols.c b/linc2/src/linc-protocols.c
+index e6895f4..22a77aa 100644
+--- a/linc2/src/linc-protocols.c
++++ b/linc2/src/linc-protocols.c
+@@ -383,6 +383,7 @@ link_protocol_is_local_ipv46 (const LinkProtocolInfo *proto,
+ memset(&hints, 0, sizeof(hints));
+ hints.ai_socktype = SOCK_STREAM;
+ hints.ai_flags = AI_CANONNAME;
++ hints.ai_family = proto->family;
+
+ if (getaddrinfo(link_get_local_hostname(), NULL, &hints, &local_addr) != 0) {
+ if (!warned++)
+--
+1.8.1.2
+
diff --git a/gnome-base/orbit/files/orbit-2.14.19-parallel-build.patch b/gnome-base/orbit/files/orbit-2.14.19-parallel-build.patch
new file mode 100644
index 000000000000..113b90465bae
--- /dev/null
+++ b/gnome-base/orbit/files/orbit-2.14.19-parallel-build.patch
@@ -0,0 +1,25 @@
+From c67303ecfdf80072a2852433c7f7818113e61c06 Mon Sep 17 00:00:00 2001
+From: Michael Haubenwallner <michael.haubenwallner@ssi-schaefer.com>
+Date: Thu, 26 Jun 2014 12:37:59 +0200
+Subject: [PATCH 2/2] bug#732274: fix parallel build failure
+
+---
+ src/services/name/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/services/name/Makefile.am b/src/services/name/Makefile.am
+index deda1ed..8cf868e 100644
+--- a/src/services/name/Makefile.am
++++ b/src/services/name/Makefile.am
+@@ -68,7 +68,7 @@ libname_server_2_a_DEPENDENCIES = $(DEPS) CosNaming.h
+
+ orbit_name_server_2_SOURCES = boot.c
+ orbit_name_server_2_LDFLAGS = $(FLAGS)
+-orbit_name_server_2_DEPENDENCIES = $(DEPS) CosNaming.h
++orbit_name_server_2_DEPENDENCIES = $(DEPS) CosNaming.h libname-server-2.a
+ orbit_name_server_2_LDADD = libname-server-2.a $(LDADDS)
+
+ $(libname_server_2_a_OBJECTS) $(name_client_2_OBJECTS) $(orbit_name_server_2_OBJECTS) : CosNaming.h
+--
+1.8.3.2
+
diff --git a/gnome-base/orbit/metadata.xml b/gnome-base/orbit/metadata.xml
new file mode 100644
index 000000000000..2965e3cff492
--- /dev/null
+++ b/gnome-base/orbit/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<use>
+ <flag name="pic">Force libname-server-2 to be built as PIC; needed on
+ hardened systems</flag>
+</use>
+</pkgmetadata>
diff --git a/gnome-base/orbit/orbit-2.14.19-r4.ebuild b/gnome-base/orbit/orbit-2.14.19-r4.ebuild
new file mode 100644
index 000000000000..59270cf6c96c
--- /dev/null
+++ b/gnome-base/orbit/orbit-2.14.19-r4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME_ORG_MODULE="ORBit2"
+GNOME_TARBALL_SUFFIX="bz2"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 toolchain-funcs autotools
+
+DESCRIPTION="ORBit2 is a high-performance CORBA ORB"
+HOMEPAGE="http://projects.gnome.org/ORBit2/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="2"
+KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="pic static-libs test"
+REQUIRED_USE="test? ( debug )"
+
+RDEPEND=">=dev-libs/glib-2.8:2
+ >=dev-libs/libIDL-0.8.2
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Fix wrong process kill, bug #268142
+ sed "s:killall lt-timeout-server:killall timeout-server:" \
+ -i test/timeout.sh || die "sed 1 failed"
+
+ # Do not mess with CFLAGS
+ sed 's/-ggdb -O0//' -i configure.in configure || die "sed 2 failed"
+
+ if ! use test; then
+ sed -i -e 's/test //' Makefile.am || die
+ fi
+
+ # Drop failing test, bug #331709
+ sed -i -e 's/test-mem //' test/Makefile.am || die
+
+ # Fix link_protocol_is_local() for ipv4 on machines with ipv6
+ # https://bugzilla.gnome.org/show_bug.cgi?id=693636
+ epatch "${FILESDIR}/${PN}-2.14.19-link_protocol_is_local.patch"
+
+ # Build libname-server-2.a with -fPIC on hardened, bug #312161
+ epatch "${FILESDIR}/${PN}-2.14.19-fPIC.patch"
+
+ epatch "${FILESDIR}"/${P}-automake-1.13.patch
+ epatch "${FILESDIR}"/${P}-parallel-build.patch #273031
+ epatch "${FILESDIR}"/${P}-aix-func_data.patch #515094
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf=()
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+
+ # We need to unset IDL_DIR, which is set by RSI's IDL. This causes certain
+ # files to be not found by autotools when compiling ORBit. See bug #58540
+ # for more information. Please don't remove -- 8/18/06
+ unset IDL_DIR
+
+ # We need to use the hosts IDL compiler if cross-compiling, bug #262741
+ if tc-is-cross-compiler; then
+ # check that host version is present and executable
+ [[ -x ${EPREFIX}/usr/bin/orbit-idl-2 ]] || die "Please emerge ~${CATEGORY}/${P} on the host system first"
+ myconf=("${myconf[@]}" "--with-idl-compiler=${EPREFIX}/usr/bin/orbit-idl-2")
+ fi
+ gnome2_src_configure \
+ $(use_enable pic libname-server-pic) \
+ $(use_enable static-libs static) \
+ "${myconf[@]}"
+}
+
+src_test() {
+ # can fail in parallel, see bug #235994
+ emake -j1 check
+}