summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-filter/disspam
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-filter/disspam')
-rw-r--r--mail-filter/disspam/Manifest1
-rw-r--r--mail-filter/disspam/disspam-0.14.ebuild33
-rw-r--r--mail-filter/disspam/files/0.12-sa302fix.patch22
-rw-r--r--mail-filter/disspam/metadata.xml5
4 files changed, 61 insertions, 0 deletions
diff --git a/mail-filter/disspam/Manifest b/mail-filter/disspam/Manifest
new file mode 100644
index 000000000000..a23ff0bf1e7f
--- /dev/null
+++ b/mail-filter/disspam/Manifest
@@ -0,0 +1 @@
+DIST disspam-0.14.tar.gz 14080 SHA256 28232f79a756d406285f6d698ea73bdadd1bbcc19070f6b0b9d4dabbf8d466ce SHA512 549210d7a5aacd62cdf3ce7384c5d35e011147355388fdfde14ee1f951752ebd3f1f4844c4c2016ee3b1cb0cf88242d0bb7dccbc9dfa6ec2ca3e39e2f1b7195b WHIRLPOOL 2bc514afaad0d09515235b19e89625a0084cd3bd0a24c71ba41cf6c3ee99f18fb0fbfbd642bafb0194de9d2219419a471f041977d659c4df8ae697c53f9456bb
diff --git a/mail-filter/disspam/disspam-0.14.ebuild b/mail-filter/disspam/disspam-0.14.ebuild
new file mode 100644
index 000000000000..25fa154347cc
--- /dev/null
+++ b/mail-filter/disspam/disspam-0.14.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="A Perl script that removes spam from POP3 mailboxes based on RBLs"
+HOMEPAGE="http://www.topfx.com/"
+SRC_URI="http://www.topfx.com/dist/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="alpha ~amd64 ~hppa ~mips ppc sparc x86"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5.6.1
+ >=virtual/perl-libnet-1.11
+ >=sys-apps/sed-4
+ >=dev-perl/Net-DNS-0.12"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ #This doesnt look neat but makes it work
+ sed -i \
+ -e 's/\/usr\/local\/bin\/perl/\/usr\/bin\/perl/' disspam.pl || \
+ die "sed disspam.pl failed"
+}
+
+src_install() {
+ dobin disspam.pl
+ dodoc changes.txt configuration.txt readme.txt sample.conf
+}
diff --git a/mail-filter/disspam/files/0.12-sa302fix.patch b/mail-filter/disspam/files/0.12-sa302fix.patch
new file mode 100644
index 000000000000..58f992497056
--- /dev/null
+++ b/mail-filter/disspam/files/0.12-sa302fix.patch
@@ -0,0 +1,22 @@
+diff -bur disspam-orig/disspam.pl disspam/disspam.pl
+--- disspam-orig/disspam.pl 2003-05-07 00:46:14.000000000 +0200
++++ disspam/disspam.pl 2004-12-31 18:31:49.006478280 +0100
+@@ -144,7 +144,8 @@
+ if ($HEADERHASHES{$hash} =~ /S/) {
+
+ # It's old spam
+- $reason = "Message previously detected as spam";
++ #$reason = "Message previously detected as spam";
++ undef $reason
+ }
+ else {
+
+@@ -766,7 +767,7 @@
+
+ #give email SpamAssassin headers
+ $status->rewrite_mail();
+- $$messageref = $status->get_full_message_as_text();
++ $$messageref = $status->get_message();
+ }
+ }
+ else {
diff --git a/mail-filter/disspam/metadata.xml b/mail-filter/disspam/metadata.xml
new file mode 100644
index 000000000000..51f94e3fbe0e
--- /dev/null
+++ b/mail-filter/disspam/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-mail</herd>
+</pkgmetadata>