summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-12-13 12:47:14 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2019-12-13 12:47:14 +0100
commit412d120cee8f6ccf97a753a835d83c7b3f73ae4f (patch)
tree7a08e8a19f03b9f5101e8b4e2f08aa554fedd7b0 /media-sound/qsampler
parentmedia-sound/qsampler-9999: added live ebuild (diff)
downloadgentoo-412d120cee8f6ccf97a753a835d83c7b3f73ae4f.tar.gz
gentoo-412d120cee8f6ccf97a753a835d83c7b3f73ae4f.tar.bz2
gentoo-412d120cee8f6ccf97a753a835d83c7b3f73ae4f.zip
media-sound/qsampler-9999: fixed call of xdg functions
for some reason they are not called automagically so calling them manually Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/qsampler')
-rw-r--r--media-sound/qsampler/qsampler-9999.ebuild17
1 files changed, 16 insertions, 1 deletions
diff --git a/media-sound/qsampler/qsampler-9999.ebuild b/media-sound/qsampler/qsampler-9999.ebuild
index 097079ef9d91..6e1f0a1909e7 100644
--- a/media-sound/qsampler/qsampler-9999.ebuild
+++ b/media-sound/qsampler/qsampler-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit qmake-utils autotools xdg subversion
+inherit qmake-utils xdg autotools subversion
DESCRIPTION="Graphical frontend to the LinuxSampler engine"
HOMEPAGE="https://qsampler.sourceforge.io/ https://www.linuxsampler.org/"
@@ -53,3 +53,18 @@ src_configure() {
cd src || die
eqmake5 src.pro -o Makefile
}
+
+pkg_postinst() {
+ # these are not run automagically in live ebuild for some reason so running them manually
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ # these are not run automagically in live ebuild for some reason so running them manually
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}
+