summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-10 01:41:22 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-10 01:41:22 +0100
commita592563a57351db7e65b6882384997b9e0be63b3 (patch)
tree27e2144fb60fc696b44910e4c00b8f9007f3d031 /media-sound/wavegain
parentmedia-sound/mcdp: Port to EAPI 7 (diff)
downloadgentoo-a592563a57351db7e65b6882384997b9e0be63b3.tar.gz
gentoo-a592563a57351db7e65b6882384997b9e0be63b3.tar.bz2
gentoo-a592563a57351db7e65b6882384997b9e0be63b3.zip
media-sound/wavegain: Port to EAPI 7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/wavegain')
-rw-r--r--media-sound/wavegain/wavegain-1.3.1.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/media-sound/wavegain/wavegain-1.3.1.ebuild b/media-sound/wavegain/wavegain-1.3.1.ebuild
index 82d8dd18cfcc..8e51ee45a376 100644
--- a/media-sound/wavegain/wavegain-1.3.1.ebuild
+++ b/media-sound/wavegain/wavegain-1.3.1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
inherit toolchain-funcs
@@ -14,17 +14,15 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-RDEPEND=""
-DEPEND="${RDEPEND}
- app-arch/unzip"
+BDEPEND="app-arch/unzip"
S=${WORKDIR}/${P/wavegain/WaveGain}
-src_compile(){
+src_compile() {
$(tc-getCC) ${LDFLAGS} ${CFLAGS} *.c -o ${PN} \
-DHAVE_CONFIG_H -lm || die "build failed"
}
-src_install(){
+src_install() {
dobin ${PN}
}