summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author0xd34df00d <0xd34df00d@gmail.com>2019-10-13 16:56:42 -0400
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-21 22:57:18 +0200
commit30549e62eb0acc8188144184df68d33cebd05bd0 (patch)
tree361e0da52565378ce7847e3fbb4495db3ab64011 /net-libs
parentsys-fs/btrfs-progs: Bump to version 5.3. Removed old (diff)
downloadgentoo-30549e62eb0acc8188144184df68d33cebd05bd0.tar.gz
gentoo-30549e62eb0acc8188144184df68d33cebd05bd0.tar.bz2
gentoo-30549e62eb0acc8188144184df68d33cebd05bd0.zip
net-libs/qxmpp: bump to 1.0.1, fix tests
Closes: https://bugs.gentoo.org/696684 Signed-off-by: Georg Rudoy <0xd34df00d@gmail.com> Package-Manager: Portage-2.3.76, Repoman-2.3.17 Closes: https://github.com/gentoo/gentoo/pull/13288 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/qxmpp/Manifest1
-rw-r--r--net-libs/qxmpp/qxmpp-1.0.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/net-libs/qxmpp/Manifest b/net-libs/qxmpp/Manifest
index 8ba7504729da..5fd90d72a762 100644
--- a/net-libs/qxmpp/Manifest
+++ b/net-libs/qxmpp/Manifest
@@ -1 +1,2 @@
DIST qxmpp-0.9.3.tar.gz 300764 BLAKE2B a98d9bd9ab9c84ce6ac90722cd1f1b1609d345daa0b4e690e44b845408753b006261b293898bf419bea011005558584de24090ac1c8809845ec6f8a5c8bb05b1 SHA512 c6ada4398468b9ce84955ab3a1ca155afe3098dfe39dc952c3675be1a1e3a4f118f8b1e251567bc124faa645d2654252d3e32d94e21aae79547056a10a2d6a71
+DIST qxmpp-1.0.1.tar.gz 259791 BLAKE2B 3687dd8f74db8a995bc37850f6988b1750219b2f683281d26990a430046cd1d7f1957c19604540a56c3110aa5b9a40d037388f9726f684a56a0d15c7de6a4849 SHA512 b6fb5fc0e3edfd978ac47b3ce32d8d0892678247479ba3e30beba3a7e67da1eb053bb95de07306920cf6ca5e744c12fd31f1a72612c5ee5b724a3eac7b8d6c6e
diff --git a/net-libs/qxmpp/qxmpp-1.0.1.ebuild b/net-libs/qxmpp/qxmpp-1.0.1.ebuild
new file mode 100644
index 000000000000..de71964e178c
--- /dev/null
+++ b/net-libs/qxmpp/qxmpp-1.0.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="A cross-platform C++ XMPP client library based on the Qt framework"
+HOMEPAGE="https://github.com/qxmpp-project/qxmpp/"
+SRC_URI="https://github.com/${PN}-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc opus +speex test theora vpx"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtxml:5
+ opus? ( media-libs/opus )
+ speex? ( media-libs/speex )
+ theora? ( media-libs/libtheora )
+ vpx? ( media-libs/libvpx:= )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+BDEPEND="
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ # requires network connection, bug #623708
+ sed -e "/qxmppiceconnection/d" \
+ -i tests/CMakeLists.txt || die "failed to drop single test"
+ sed -e "/qxmppserver/d" \
+ -i tests/CMakeLists.txt || die "failed to drop single test"
+ sed -e "/qxmpptransfermanager/d" \
+ -i tests/CMakeLists.txt || die "failed to drop single test"
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex doc)
+ -DBUILD_EXAMPLES=OFF
+ -DBUILD_TESTS=$(usex test)
+ -DWITH_OPUS=$(usex opus)
+ -DWITH_SPEEX=$(usex speex)
+ -DWITH_THEORA=$(usex theora)
+ -DWITH_VPX=$(usex vpx)
+ )
+
+ cmake-utils_src_configure
+}