summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfe İzbudak <efe.izbudak@metu.edu.tr>2023-06-05 02:44:28 -0400
committerMichał Górny <mgorny@gentoo.org>2023-06-05 20:34:52 +0200
commitf2aa3a1f2d911b24b21ad80891b194d36722eaf0 (patch)
tree543860fed907469ba2026c93938ef2616a5b8987 /net-misc/electrum
parentdev-python/moto: Bump to 4.1.11 (diff)
downloadgentoo-f2aa3a1f2d911b24b21ad80891b194d36722eaf0.tar.gz
gentoo-f2aa3a1f2d911b24b21ad80891b194d36722eaf0.tar.bz2
gentoo-f2aa3a1f2d911b24b21ad80891b194d36722eaf0.zip
net-misc/electrum: missing dependency pyperclip
The program was failing to run with the following error: ``` 1.66 | E | daemon.Daemon | GUI raised exception: ModuleNotFoundError("No module named 'pyperclip'"). shutting down. 1.66 | E | __main__ | daemon.run_gui errored Traceback (most recent call last): File "/usr/lib/python-exec/python3.11/electrum", line 461, in handle_cmd d.run_gui(config, plugins) File "/usr/lib/python3.11/site-packages/electrum/daemon.py", line 591, in run_gui gui = __import__('electrum.gui.' + gui_name, fromlist=['electrum']) ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ File "/usr/lib/python3.11/site-packages/electrum/gui/text.py", line 9, in <module> import pyperclip ModuleNotFoundError: No module named 'pyperclip' ``` which has been fixed by adding the dependency dev-python/pyperclip. Signed-off-by: Efe İzbudak <efe.izbudak@metu.edu.tr> Closes: https://github.com/gentoo/gentoo/pull/31314 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc/electrum')
-rw-r--r--net-misc/electrum/electrum-4.4.4-r1.ebuild (renamed from net-misc/electrum/electrum-4.4.4.ebuild)1
1 files changed, 1 insertions, 0 deletions
diff --git a/net-misc/electrum/electrum-4.4.4.ebuild b/net-misc/electrum/electrum-4.4.4-r1.ebuild
index 693674eca7e3..1cc9eb1f94ba 100644
--- a/net-misc/electrum/electrum-4.4.4.ebuild
+++ b/net-misc/electrum/electrum-4.4.4-r1.ebuild
@@ -35,6 +35,7 @@ RDEPEND="
dev-python/cryptography[${PYTHON_USEDEP}]
>=dev-python/dnspython-2[${PYTHON_USEDEP}]
dev-python/pbkdf2[${PYTHON_USEDEP}]
+ dev-python/pyperclip[${PYTHON_USEDEP}]
dev-python/PySocks[${PYTHON_USEDEP}]
dev-python/qrcode[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]