summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-06 10:37:13 +0000
committerSam James <sam@gentoo.org>2024-11-06 10:46:51 +0000
commit585c470519cdd7f0b27dd465d96f8a7b3ed03b59 (patch)
treed96d505f8da89af4accdb316575031e4e5a3e79e /net-misc/nyx
parentnet-misc/nyx: cleanup a bit (diff)
downloadgentoo-585c470519cdd7f0b27dd465d96f8a7b3ed03b59.tar.gz
gentoo-585c470519cdd7f0b27dd465d96f8a7b3ed03b59.tar.bz2
gentoo-585c470519cdd7f0b27dd465d96f8a7b3ed03b59.zip
net-misc/nyx: fix Python 3.11 compat
Closes: https://bugs.gentoo.org/942871 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/nyx')
-rw-r--r--net-misc/nyx/files/nyx-2.1.0-py311.patch11
-rw-r--r--net-misc/nyx/nyx-2.1.0-r7.ebuild (renamed from net-misc/nyx/nyx-2.1.0-r6.ebuild)4
2 files changed, 15 insertions, 0 deletions
diff --git a/net-misc/nyx/files/nyx-2.1.0-py311.patch b/net-misc/nyx/files/nyx-2.1.0-py311.patch
new file mode 100644
index 000000000000..10dbc70b1373
--- /dev/null
+++ b/net-misc/nyx/files/nyx-2.1.0-py311.patch
@@ -0,0 +1,11 @@
+--- a/nyx/panel/__init__.py
++++ b/nyx/panel/__init__.py
+@@ -78,7 +78,7 @@
+ is_match = self._key_func(key) if self._key_func else key.match(self.key)
+
+ if is_match:
+- if inspect.getargspec(self._action).args == ['key']:
++ if inspect.getfullargspec(self._action).args == ['key']:
+ self._action(key)
+ else:
+ self._action()
diff --git a/net-misc/nyx/nyx-2.1.0-r6.ebuild b/net-misc/nyx/nyx-2.1.0-r7.ebuild
index 555893ccf513..c980ee277f0c 100644
--- a/net-misc/nyx/nyx-2.1.0-r6.ebuild
+++ b/net-misc/nyx/nyx-2.1.0-r7.ebuild
@@ -27,6 +27,10 @@ RDEPEND="
net-vpn/tor
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.0-py311.patch
+)
+
distutils_enable_tests unittest
python_install_all() {