summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:10 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:32 +0200
commit095cdcf6abe7b10d2c0623768148bbb95df577c2 (patch)
tree07ee924447b916d9693a1b88f017ebf5eee06005 /ros-meta/ros_comm/ros_comm-9999.ebuild
parentdev-ros/test_rosservice: Initial import. Ebuild by me. (diff)
downloadgentoo-095cdcf6abe7b10d2c0623768148bbb95df577c2.tar.gz
gentoo-095cdcf6abe7b10d2c0623768148bbb95df577c2.tar.bz2
gentoo-095cdcf6abe7b10d2c0623768148bbb95df577c2.zip
ros-meta/ros_comm: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'ros-meta/ros_comm/ros_comm-9999.ebuild')
-rw-r--r--ros-meta/ros_comm/ros_comm-9999.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/ros-meta/ros_comm/ros_comm-9999.ebuild b/ros-meta/ros_comm/ros_comm-9999.ebuild
new file mode 100644
index 000000000000..c6421aeda598
--- /dev/null
+++ b/ros-meta/ros_comm/ros_comm-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS communications-related packages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+# utilities subdir
+RDEPEND="
+ dev-ros/roslz4
+ dev-ros/xmlrpcpp
+ dev-ros/roswtf
+ dev-ros/message_filters
+"
+# tools subdir
+RDEPEND="${RDEPEND}
+ dev-ros/rosbag
+ dev-ros/rosbag_storage
+ dev-ros/rosconsole
+ dev-ros/rosgraph
+ dev-ros/roslaunch
+ dev-ros/rosmaster
+ dev-ros/rosmsg
+ dev-ros/rosnode
+ dev-ros/rosout
+ dev-ros/rosparam
+ dev-ros/rosservice
+ dev-ros/rostest
+ dev-ros/rostopic
+ dev-ros/topic_tools
+"
+# clients subdir
+RDEPEND="${RDEPEND}
+ dev-ros/roscpp
+ dev-ros/rospy
+"
+# test subdir
+RDEPEND="${RDEPEND}
+ dev-ros/test_rosbag
+ dev-ros/test_rosbag_storage
+ dev-ros/test_roscpp
+ dev-ros/test_rosgraph
+ dev-ros/test_roslaunch
+ dev-ros/test_roslib_comm
+ dev-ros/test_rosmaster
+ dev-ros/test_rosparam
+ dev-ros/test_rospy
+ dev-ros/test_rosservice
+"
+DEPEND="${RDEPEND}"