summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-05-07 08:40:30 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-05-07 08:40:30 +0200
commit315f21a570413534c06dd4bfbffb8ef1493fd5b6 (patch)
tree6a62268582eccc5e14551825f89db5e99f40cf95 /sci-libs
parentsci-geosciences/xyzservices: add 2024.4.0 (diff)
downloadgentoo-315f21a570413534c06dd4bfbffb8ef1493fd5b6.tar.gz
gentoo-315f21a570413534c06dd4bfbffb8ef1493fd5b6.tar.bz2
gentoo-315f21a570413534c06dd4bfbffb8ef1493fd5b6.zip
sci-libs/branca: add 0.7.2
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/branca/Manifest1
-rw-r--r--sci-libs/branca/branca-0.7.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sci-libs/branca/Manifest b/sci-libs/branca/Manifest
index ac0880603f09..1bf88c0e58c3 100644
--- a/sci-libs/branca/Manifest
+++ b/sci-libs/branca/Manifest
@@ -1,2 +1,3 @@
DIST branca-0.7.0.tar.gz 42990 BLAKE2B b8de083b0b94d35dbb6df5d230e388832fe027d756767d24ae8091f25d9846ac1f2ae72799aa83583c99ec02d955c7f8cb80183f1543e503d0a802ce051acac5 SHA512 bfe6afd93752dda57e55ba7bdd433e079b51798056b2be8d9c19d4ccc4ed94cc95b733cabf0981c908887c1f8a96e16bd11cb1b495243ac91df4c1c1c1253282
DIST branca-0.7.1.tar.gz 43005 BLAKE2B 2f2834d87e32ef5507273b14b1b8fcebc33d7eae49e0ffb8e834c540b1a329d177805ccbc1441cd522092d396ba98f69f3c8ab95254068d7b352e6f7df52c60d SHA512 70b6e361e93a01c319928890a40e3aa1e887e718b0736afe0a65bc45fe56fe6ca24a4c50db099066d84876cc8efd540a5cc14aa48607671ac068df3ae5124d29
+DIST branca-0.7.2.tar.gz 42586 BLAKE2B 3bb6a1f93babb80788fbc1cbd37d8b0c2d5c975c9a98c5816298e37a447bcffb7742a768a0ad2fbb58af5ce0650ef28fdef42e8e4d505bbf29ab10c87ed388d6 SHA512 ad62e4496b43405dbc54b2cca35ee9d0265b8deeeb3df3b0868e63e6890fe491bfc4987318d74c1e78d83f05bdf56bfd570609699860ab1af9d189357bf00107
diff --git a/sci-libs/branca/branca-0.7.2.ebuild b/sci-libs/branca/branca-0.7.2.ebuild
new file mode 100644
index 000000000000..6fbc4495a341
--- /dev/null
+++ b/sci-libs/branca/branca-0.7.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+inherit distutils-r1
+
+DESCRIPTION="spinoff from folium, host the non-map-specific features"
+HOMEPAGE="https://github.com/python-visualization/branca"
+SRC_URI="https://github.com/python-visualization/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.6.0-test.patch )
+
+RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/setuptools-scm
+ test? (
+ dev-python/selenium[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs/source \
+ dev-python/nbsphinx
+
+python_test() {
+ epytest -m 'not headless'
+}